summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Patterson <pattersonc@ainfosec.com>2015-12-18 15:49:41 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-14 11:22:08 +0100
commit59cefade1d8dfd6a941d2053aeef1c784f29cb08 (patch)
tree0e774c649072b498193a33c24c4ac6a2ed7d5094
parent5556fb4d26cd40b5bc49f8edfaa56c63ae7810b7 (diff)
downloadmeta-openembedded-59cefade1d8dfd6a941d2053aeef1c784f29cb08.tar.gz
strongswan: add configure patch fix for systemd
Fixes strongswan configure script for systemd >= 209, where it merged libsystemd-journal and libsystemd-daemon into libsystemd. Signed-off-by: Chris Patterson <pattersonc@ainfosec.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-support/strongswan/files/support-newer-systemd.patch69
-rw-r--r--meta-networking/recipes-support/strongswan/strongswan_5.3.2.bb1
2 files changed, 70 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/strongswan/files/support-newer-systemd.patch b/meta-networking/recipes-support/strongswan/files/support-newer-systemd.patch
new file mode 100644
index 000000000..550cf6758
--- /dev/null
+++ b/meta-networking/recipes-support/strongswan/files/support-newer-systemd.patch
@@ -0,0 +1,69 @@
1commit 82498129e0a91dfc3ed2c4ec3b2252f44655b83c
2Author: Chris Patterson <pattersonc@ainfosec.com>
3Date: Fri Dec 18 08:27:57 2015 -0500
4
5 configure: support systemd >= 209
6
7 libsystemd-journal and libsystemd-daemon are now just
8 part of libsystemd.
9
10 Keep original systemd checks as a fallback.
11
12 Updates charon-systemd/Makefile.am accordingly.
13
14 Tested on:
15 - debian wheezy (systemd v44)
16 - ubuntu 15.10 (systemd v255).
17
18 Signed-off-by: Chris Patterson <pattersonc@ainfosec.com>
19
20Upstream-Status: Submitted
21https://github.com/strongswan/strongswan/pull/24
22
23diff --git a/configure.ac b/configure.ac
24index 3d71ce0..f6c0426 100644
25--- a/configure.ac
26+++ b/configure.ac
27@@ -941,13 +941,17 @@ if test x$systemd = xtrue; then
28 AC_MSG_ERROR([not found (try --with-systemdsystemunitdir)])
29 fi
30
31- PKG_CHECK_MODULES(systemd_daemon, [libsystemd-daemon])
32- AC_SUBST(systemd_daemon_CFLAGS)
33- AC_SUBST(systemd_daemon_LIBS)
34-
35- PKG_CHECK_MODULES(systemd_journal, [libsystemd-journal])
36- AC_SUBST(systemd_journal_CFLAGS)
37- AC_SUBST(systemd_journal_LIBS)
38+ PKG_CHECK_MODULES(systemd, [libsystemd >= 209],
39+ [AC_SUBST(systemd_CFLAGS)
40+ AC_SUBST(systemd_LIBS)],
41+ [PKG_CHECK_MODULES(systemd_daemon, [libsystemd-daemon])
42+ AC_SUBST(systemd_daemon_CFLAGS)
43+ AC_SUBST(systemd_daemon_LIBS)
44+
45+ PKG_CHECK_MODULES(systemd_journal, [libsystemd-journal])
46+ AC_SUBST(systemd_journal_CFLAGS)
47+ AC_SUBST(systemd_journal_LIBS)
48+ ])
49 fi
50
51 if test x$tss = xtrousers; then
52diff --git a/src/charon-systemd/Makefile.am b/src/charon-systemd/Makefile.am
53index 1b9ac15..ee85d43 100644
54--- a/src/charon-systemd/Makefile.am
55+++ b/src/charon-systemd/Makefile.am
56@@ -9,11 +9,11 @@ charon_systemd_CPPFLAGS = \
57 -I$(top_srcdir)/src/libstrongswan \
58 -I$(top_srcdir)/src/libhydra \
59 -I$(top_srcdir)/src/libcharon \
60- $(systemd_daemon_CFLAGS) $(systemd_journal_CFLAGS) \
61+ $(systemd_CFLAGS) $(systemd_daemon_CFLAGS) $(systemd_journal_CFLAGS) \
62 -DPLUGINS=\""${charon_plugins}\""
63
64 charon_systemd_LDADD = \
65 $(top_builddir)/src/libstrongswan/libstrongswan.la \
66 $(top_builddir)/src/libhydra/libhydra.la \
67 $(top_builddir)/src/libcharon/libcharon.la \
68- $(systemd_daemon_LIBS) $(systemd_journal_LIBS) -lm $(PTHREADLIB) $(DLLIB)
69+ $(systemd_LIBS) $(systemd_daemon_LIBS) $(systemd_journal_LIBS) -lm $(PTHREADLIB) $(DLLIB)
diff --git a/meta-networking/recipes-support/strongswan/strongswan_5.3.2.bb b/meta-networking/recipes-support/strongswan/strongswan_5.3.2.bb
index df7b4966c..aa32383a4 100644
--- a/meta-networking/recipes-support/strongswan/strongswan_5.3.2.bb
+++ b/meta-networking/recipes-support/strongswan/strongswan_5.3.2.bb
@@ -9,6 +9,7 @@ DEPENDS = "gmp openssl flex-native flex bison-native"
9 9
10SRC_URI = "http://download.strongswan.org/strongswan-${PV}.tar.bz2 \ 10SRC_URI = "http://download.strongswan.org/strongswan-${PV}.tar.bz2 \
11 file://fix-funtion-parameter.patch \ 11 file://fix-funtion-parameter.patch \
12 file://support-newer-systemd.patch \
12" 13"
13 14
14SRC_URI[md5sum] = "fab014be1477ef4ebf9a765e10f8802c" 15SRC_URI[md5sum] = "fab014be1477ef4ebf9a765e10f8802c"