summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-01-01 11:41:41 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-14 11:22:11 +0100
commit3c1ad2dcf95e087f30ac747b8702d19b1dd073e2 (patch)
treebe988d52186ca564b55b146ee0fcdb666d284b4b
parent428082d3220b99d5a367028f8776bd53f5c42e9e (diff)
downloadmeta-openembedded-3c1ad2dcf95e087f30ac747b8702d19b1dd073e2.tar.gz
fltk: fix build issue.
this patch fixes: Fl_JPEG_Image.cxx: In constructor 'Fl_JPEG_Image::Fl_JPEG_Image(const char*)': | Fl_JPEG_Image.cxx:156:29: error: invalid conversion from 'int' to 'boolean' [-fpermissive] Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/fltk/fltk-1.1.10/Fl_JPEG_Image_buildix.patch37
-rw-r--r--meta-oe/recipes-support/fltk/fltk_1.1.10.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/fltk/fltk-1.1.10/Fl_JPEG_Image_buildix.patch b/meta-oe/recipes-support/fltk/fltk-1.1.10/Fl_JPEG_Image_buildix.patch
new file mode 100644
index 000000000..ea8001110
--- /dev/null
+++ b/meta-oe/recipes-support/fltk/fltk-1.1.10/Fl_JPEG_Image_buildix.patch
@@ -0,0 +1,37 @@
1fltk: Fl_JPEG_Image.cxx bug in fltk-1.3.x for jpeg-9
2
3Link: http://www.fltk.org/str.php?L2920
4Version: 1.3-current
5
6There has been a change in jpeg-9:
7
8Fl_JPEG_Image.cxx: In constructor 'Fl_JPEG_Image::Fl_JPEG_Image(const
9char*)':
10Fl_JPEG_Image.cxx:158:29: error: invalid conversion from 'int' to
11'boolean' [-fpermissive]
12In file included from Fl_JPEG_Image.cxx:50:0:
13/usr/include/jpeglib.h:1032:13: error: initializing argument 2 of 'int
14jpeg_read_header(j_decompress_ptr, boolean)' [-fpermissive]
15
16
17http://permalink.gmane.org/gmane.comp.lib.fltk.bugs/10893
18
19Upstream-Status: Backport
20
21partical back port as this version is only affected by on change.
22
23Signed-off-by: Armin Kuster <akuster808@gmail.com>
24
25Index: fltk-1.1.10/src/Fl_JPEG_Image.cxx
26===================================================================
27--- fltk-1.1.10.orig/src/Fl_JPEG_Image.cxx
28+++ fltk-1.1.10/src/Fl_JPEG_Image.cxx
29@@ -153,7 +153,7 @@ Fl_JPEG_Image::Fl_JPEG_Image(const char
30
31 jpeg_create_decompress(&dinfo);
32 jpeg_stdio_src(&dinfo, fp);
33- jpeg_read_header(&dinfo, 1);
34+ jpeg_read_header(&dinfo, TRUE);
35
36 dinfo.quantize_colors = (boolean)FALSE;
37 dinfo.out_color_space = JCS_RGB;
diff --git a/meta-oe/recipes-support/fltk/fltk_1.1.10.bb b/meta-oe/recipes-support/fltk/fltk_1.1.10.bb
index 14049614a..22a1a50cf 100644
--- a/meta-oe/recipes-support/fltk/fltk_1.1.10.bb
+++ b/meta-oe/recipes-support/fltk/fltk_1.1.10.bb
@@ -13,6 +13,7 @@ SRC_URI = "ftp://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/fltk/${PV}/fl
13 file://dso-fix.patch \ 13 file://dso-fix.patch \
14 file://libpng15.patch \ 14 file://libpng15.patch \
15 file://fltk-no-freetype-config.patch \ 15 file://fltk-no-freetype-config.patch \
16 file://Fl_JPEG_Image_buildix.patch \
16" 17"
17 18
18S = "${WORKDIR}/fltk-${PV}" 19S = "${WORKDIR}/fltk-${PV}"