summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2015-07-23 16:00:53 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-07-30 21:07:36 +0200
commit35ae01ce6c126140439f271ee944efe69a184132 (patch)
treeabc2005b80a935b1966f13339677ee9c95645012
parent6f91b61c0755c954d7bdce680f1c9926238c1c66 (diff)
downloadmeta-openembedded-35ae01ce6c126140439f271ee944efe69a184132.tar.gz
efibootmgr: add recipe
Add efibootmgr recipe from layer meta-linaro and upgrade from 0.5.4 to 0.6.0. efibootmgr is a linux user-space application to modify the EFI Boot Manager which is useful for us to manage boot on EFI boards. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-extended/efibootmgr/efibootmgr_0.6.0.bb26
-rw-r--r--meta-oe/recipes-extended/efibootmgr/files/docbook-fixes.patch28
-rw-r--r--meta-oe/recipes-extended/efibootmgr/files/ldflags.patch17
-rw-r--r--meta-oe/recipes-extended/efibootmgr/files/w-keep-existing-mbr-signature.patch26
4 files changed, 97 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.6.0.bb b/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.6.0.bb
new file mode 100644
index 000000000..1870455ea
--- /dev/null
+++ b/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.6.0.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "Linux user-space application to modify the EFI Boot Manager."
2SUMMARY = "EFI Boot Manager"
3HOMEPAGE = "http://linux.dell.com/efibootmgr/"
4SECTION = "base"
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
8
9DEPENDS = "pciutils zlib"
10
11COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
12
13SRC_URI = "http://linux.dell.com/efibootmgr/permalink/efibootmgr-${PV}.tar.gz \
14 file://ldflags.patch \
15 file://docbook-fixes.patch \
16 file://w-keep-existing-mbr-signature.patch \
17"
18
19SRC_URI[md5sum] = "9e9a31d79e579644de83a14139b66d10"
20SRC_URI[sha256sum] = "5167488b92950e60028d1025942ce6bda04638c6fb5e110abb8c8f687844d155"
21
22EXTRA_OEMAKE = "'CC=${CC}' 'CFLAGS=${CFLAGS} -I${S}/src/lib -I${S}/src/include'"
23
24do_install () {
25 install -D -p -m0755 src/efibootmgr/efibootmgr ${D}/${sbindir}/efibootmgr
26}
diff --git a/meta-oe/recipes-extended/efibootmgr/files/docbook-fixes.patch b/meta-oe/recipes-extended/efibootmgr/files/docbook-fixes.patch
new file mode 100644
index 000000000..f2dc83bbe
--- /dev/null
+++ b/meta-oe/recipes-extended/efibootmgr/files/docbook-fixes.patch
@@ -0,0 +1,28 @@
1Upstream-Status: Pending
2
3Import this patch from meta-linaro.
4
5Signed-off-by: Kai Kang <kai.kang@windriver.com>
6
7diff --git a/src/man/man8/efibootmgr.8.docbook b/src/man/man8/efibootmgr.8.docbook
8index aef4444..eb8f266 100644
9--- a/src/man/man8/efibootmgr.8.docbook
10+++ b/src/man/man8/efibootmgr.8.docbook
11@@ -302,7 +302,7 @@
12 <title>Displaying the current settings (must be root).</title>
13
14 <para>
15- <computeroutput>
16+ <programlisting>
17 [root@localhost ~]# efibootmgr
18 BootCurrent: 0004
19 BootNext: 0003
20@@ -313,7 +313,7 @@
21 Boot0002* Hard Drive(Device:80)/HD(Part1,Sig00112233)
22 Boot0003* PXE Boot: MAC(00D0B7C15D91)
23 Boot0004* Linux
24- </computeroutput>
25+ </programlisting>
26 </para>
27 <para>This shows:</para>
28 <itemizedlist>
diff --git a/meta-oe/recipes-extended/efibootmgr/files/ldflags.patch b/meta-oe/recipes-extended/efibootmgr/files/ldflags.patch
new file mode 100644
index 000000000..0d5594a31
--- /dev/null
+++ b/meta-oe/recipes-extended/efibootmgr/files/ldflags.patch
@@ -0,0 +1,17 @@
1Upstream-Status: Pending
2
3Import this patch from meta-linaro.
4
5Signed-off-by: Kai Kang <kai.kang@windriver.com>
6
7--- efibootmgr-0.5.4.orig/Makefile
8+++ efibootmgr-0.5.4/Makefile
9@@ -11,6 +11,8 @@
10 CFLAGS = $(EXTRA_CFLAGS) -DEFIBOOTMGR_VERSION=\"$(RELEASE_MAJOR).$(RELEASE_MINOR).$(RELEASE_SUBLEVEL)$(RELEASE_EXTRALEVEL)\" \
11 -Wall -g -D_FILE_OFFSET_BITS=64
12
13+ LDFLAGS += -lz
14+
15 MODULES := src
16
17 BINDIR := /usr/sbin
diff --git a/meta-oe/recipes-extended/efibootmgr/files/w-keep-existing-mbr-signature.patch b/meta-oe/recipes-extended/efibootmgr/files/w-keep-existing-mbr-signature.patch
new file mode 100644
index 000000000..58bd13556
--- /dev/null
+++ b/meta-oe/recipes-extended/efibootmgr/files/w-keep-existing-mbr-signature.patch
@@ -0,0 +1,26 @@
1Upstream-Status: Pending
2
3Import this patch from meta-linaro.
4
5Signed-off-by: Kai Kang <kai.kang@windriver.com>
6---
7Description: Fix -w option to leave an existing unique MBR signature intact
8 This makes the implementation match the documentation.
9Author: Colin Watson <cjwatson@ubuntu.com>
10Bug-Ubuntu: https://bugs.launchpad.net/bugs/1065261
11Forwarded: no
12Last-Update: 2013-02-01
13
14Index: b/src/lib/disk.c
15===================================================================
16--- a/src/lib/disk.c
17+++ b/src/lib/disk.c
18@@ -352,7 +352,7 @@
19 printf("******************************************************\n\n");
20
21 }
22- else if (opts.write_signature) {
23+ else if (!mbr->unique_mbr_signature && opts.write_signature) {
24
25 /* MBR Signatures must be unique for the
26 EFI Boot Manager