summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge McCollister <george.mccollister@gmail.com>2015-11-12 12:35:36 -0600
committerArmin Kuster <akuster808@gmail.com>2015-12-20 14:28:29 -0800
commit05f285254f276c98e84c7f34a6586141acfa8d05 (patch)
tree8bc9480c660fd3f74857a1e96292074f8bf932b0
parent9fc5f4b83188da24270097d1675557c3c3b95f4f (diff)
downloadmeta-openembedded-05f285254f276c98e84c7f34a6586141acfa8d05.tar.gz
postgresql: Don't symlink to perl if it's disabled
Don't create a symlink to libperl.so if perl isn't in PACKAGECONFIG. Attempting to do so will fail if perl hasn't been built. Signed-off-by: George McCollister <george.mccollister@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/postgresql/postgresql.inc18
1 files changed, 10 insertions, 8 deletions
diff --git a/meta-oe/recipes-support/postgresql/postgresql.inc b/meta-oe/recipes-support/postgresql/postgresql.inc
index f3ff22583..dbc02a013 100644
--- a/meta-oe/recipes-support/postgresql/postgresql.inc
+++ b/meta-oe/recipes-support/postgresql/postgresql.inc
@@ -141,14 +141,16 @@ do_configure() {
141 -e "/^TCLSH/s:=.*:= ${bindir}/tclsh:g" \ 141 -e "/^TCLSH/s:=.*:= ${bindir}/tclsh:g" \
142 ${B}/src/Makefile.global 142 ${B}/src/Makefile.global
143 143
144 # workaround perl package's libperl.so problem 144 if ${@bb.utils.contains('PACKAGECONFIG', 'perl', 'true', 'false', d)}; then
145 # we are using perlnative so this perl should have same version 145 # workaround perl package's libperl.so problem
146 perl_version=`perl -v 2>/dev/null | \ 146 # we are using perlnative so this perl should have same version
147 sed -n 's/This is perl.*v[a-z ]*\([0-9]\.[0-9][0-9.]*\).*$/\1/p'` 147 perl_version=`perl -v 2>/dev/null | \
148 if [ ! -h "${STAGING_LIBDIR}/perl/$perl_version/CORE/libperl.so" -a \ 148 sed -n 's/This is perl.*v[a-z ]*\([0-9]\.[0-9][0-9.]*\).*$/\1/p'`
149 ! -h "${STAGING_LIBDIR}/libperl.so" ]; then 149 if [ ! -h "${STAGING_LIBDIR}/perl/$perl_version/CORE/libperl.so" -a \
150 ln -sf ../../../libperl.so.5 \ 150 ! -h "${STAGING_LIBDIR}/libperl.so" ]; then
151 ${STAGING_LIBDIR}/perl/$perl_version/CORE/libperl.so 151 ln -sf ../../../libperl.so.5 \
152 ${STAGING_LIBDIR}/perl/$perl_version/CORE/libperl.so
153 fi
152 fi 154 fi
153} 155}
154 156