summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2021-08-03 14:13:38 +0800
committerKhem Raj <raj.khem@gmail.com>2021-08-04 09:13:31 -0700
commitcf43d28c3af38f3c863dc4674c6a2b9afc579424 (patch)
tree1e6de2fb407f013c7835962d0ff10bb2764c3159
parent4685ce7a3f1f6c574091a1041106bb277f709288 (diff)
downloadmeta-openembedded-cf43d28c3af38f3c863dc4674c6a2b9afc579424.tar.gz
python3-blivet: 3.1.4 -> 3.4.0
Upgrade python3-blivet from 3.1.4 to 3.4.0. * it imports selinux conditionally, so remove 0001-comment-out-selinux.patch * rebase 0008-use-oe-variable-to-replace-hardcoded-dir.patch and 0010-invoking-mkfs-with-infinite-timeout.patch Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet/0001-comment-out-selinux.patch70
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet/0008-use-oe-variable-to-replace-hardcoded-dir.patch8
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet/0010-invoking-mkfs-with-infinite-timeout.patch10
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet_3.4.0.bb (renamed from meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb)5
4 files changed, 15 insertions, 78 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0001-comment-out-selinux.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0001-comment-out-selinux.patch
deleted file mode 100644
index 90fa387b0..000000000
--- a/meta-python/recipes-extended/python-blivet/python3-blivet/0001-comment-out-selinux.patch
+++ /dev/null
@@ -1,70 +0,0 @@
1From fc8e93530ba017ecfe111e53d3cbdc3a5b3ac286 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Fri, 23 Nov 2018 16:58:38 +0800
4Subject: [PATCH 01/11] comment out selinux
5
6Upstream-Status: Inappropriate [oe specific]
7
8Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
9---
10 blivet/flags.py | 5 +++--
11 blivet/util.py | 6 +++++-
12 2 files changed, 8 insertions(+), 3 deletions(-)
13
14diff --git a/blivet/flags.py b/blivet/flags.py
15index 4e26d82..94324ff 100644
16--- a/blivet/flags.py
17+++ b/blivet/flags.py
18@@ -20,7 +20,7 @@
19 #
20
21 import shlex
22-import selinux
23+#import selinux
24
25
26 class Flags(object):
27@@ -47,7 +47,8 @@ class Flags(object):
28 #
29 # enable/disable functionality
30 #
31- self.selinux = selinux.is_selinux_enabled()
32+ #self.selinux = selinux.is_selinux_enabled()
33+ self.selinux = False
34 self.multipath = True
35 self.dmraid = True
36 self.ibft = True
37diff --git a/blivet/util.py b/blivet/util.py
38index 9daf151..4eac8b9 100644
39--- a/blivet/util.py
40+++ b/blivet/util.py
41@@ -3,7 +3,7 @@ import functools
42 import glob
43 import itertools
44 import os
45-import selinux
46+#import selinux
47 import subprocess
48 import re
49 import sys
50@@ -444,6 +444,8 @@ def get_cow_sysfs_path(dev_path, dev_sysfsPath):
51 def match_path_context(path):
52 """ Return the default SELinux context for the given path. """
53 context = None
54+ return context
55+
56 try:
57 context = selinux.matchpathcon(os.path.normpath(path), 0)[1]
58 except OSError as e:
59@@ -468,6 +470,8 @@ def set_file_context(path, context, root=None):
60
61 True if successful, False if not.
62 """
63+ return False
64+
65 if root is None:
66 root = '/'
67
68--
692.7.4
70
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0008-use-oe-variable-to-replace-hardcoded-dir.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0008-use-oe-variable-to-replace-hardcoded-dir.patch
index ade1862d7..1e8bcac47 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet/0008-use-oe-variable-to-replace-hardcoded-dir.patch
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0008-use-oe-variable-to-replace-hardcoded-dir.patch
@@ -6,6 +6,10 @@ Subject: [PATCH 08/11] use oe variable to replace hardcoded dir
6Upstream-Status: Pending 6Upstream-Status: Pending
7 7
8Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> 8Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
9
10Rebase for python3-blivet 3.4.0.
11
12Signed-off-by: Kai Kang <kai.kang@windriver.com>
9--- 13---
10 setup.py | 8 ++++---- 14 setup.py | 8 ++++----
11 1 file changed, 4 insertions(+), 4 deletions(-) 15 1 file changed, 4 insertions(+), 4 deletions(-)
@@ -19,11 +23,11 @@ index b745a79..b5b4258 100644
19 23
20 data_files = [ 24 data_files = [
21- ('/etc/dbus-1/system.d', ['dbus/blivet.conf']), 25- ('/etc/dbus-1/system.d', ['dbus/blivet.conf']),
22- ('/usr/share/dbus-1/system-services', ['dbus/com.redhat.Blivet1.service']), 26- ('/usr/share/dbus-1/system-services', ['dbus/com.redhat.Blivet0.service']),
23- ('/usr/libexec', ['dbus/blivetd']), 27- ('/usr/libexec', ['dbus/blivetd']),
24- ('/usr/lib/systemd/system', ['dbus/blivet.service']) 28- ('/usr/lib/systemd/system', ['dbus/blivet.service'])
25+ (os.environ.get('sysconfdir')+'/dbus-1/system.d', ['dbus/blivet.conf']), 29+ (os.environ.get('sysconfdir')+'/dbus-1/system.d', ['dbus/blivet.conf']),
26+ (os.environ.get('datadir')+'/dbus-1/system-services', ['dbus/com.redhat.Blivet1.service']), 30+ (os.environ.get('datadir')+'/dbus-1/system-services', ['dbus/com.redhat.Blivet0.service']),
27+ (os.environ.get('libexecdir'), ['dbus/blivetd']), 31+ (os.environ.get('libexecdir'), ['dbus/blivetd']),
28+ (os.environ.get('systemd_system_unitdir'), ['dbus/blivet.service']) 32+ (os.environ.get('systemd_system_unitdir'), ['dbus/blivet.service'])
29 ] 33 ]
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0010-invoking-mkfs-with-infinite-timeout.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0010-invoking-mkfs-with-infinite-timeout.patch
index f12849045..c441acd17 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet/0010-invoking-mkfs-with-infinite-timeout.patch
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0010-invoking-mkfs-with-infinite-timeout.patch
@@ -9,17 +9,21 @@ lots of disks, or with slow disks.
9Upstream-Status: Pending 9Upstream-Status: Pending
10 10
11Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> 11Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
12
13Rebase for python3-blivet 3.4.0.
14
15Signed-off-by: Kai Kang <kai.kang@windriver.com>
12--- 16---
13 blivet/tasks/fsmkfs.py | 2 +- 17 blivet/tasks/fsmkfs.py | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-) 18 1 file changed, 1 insertion(+), 1 deletion(-)
15 19
16diff --git a/blivet/tasks/fsmkfs.py b/blivet/tasks/fsmkfs.py 20diff --git a/blivet/tasks/fsmkfs.py b/blivet/tasks/fsmkfs.py
17index ad166aa..7bf5075 100644 21index e4a6aaa8..9730f7e5 100644
18--- a/blivet/tasks/fsmkfs.py 22--- a/blivet/tasks/fsmkfs.py
19+++ b/blivet/tasks/fsmkfs.py 23+++ b/blivet/tasks/fsmkfs.py
20@@ -170,7 +170,7 @@ class FSMkfs(task.BasicApplication, FSMkfsTask): 24@@ -203,7 +203,7 @@ class FSMkfs(task.BasicApplication, FSMkfsTask):
21 options = options or [] 25 options = options or []
22 cmd = self._mkfs_command(options, label, set_uuid) 26 cmd = self._mkfs_command(options, label, set_uuid, nodiscard)
23 try: 27 try:
24- ret = util.run_program(cmd) 28- ret = util.run_program(cmd)
25+ ret = util.run_program(cmd, timeout=-1) 29+ ret = util.run_program(cmd, timeout=-1)
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb b/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.0.bb
index 204793759..d3373f4ae 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.0.bb
@@ -8,9 +8,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8S = "${WORKDIR}/git" 8S = "${WORKDIR}/git"
9B = "${S}" 9B = "${S}"
10 10
11SRCREV = "9b5ad2d5b5df159963e1c6c24523e1dfe1f71435" 11SRCREV = "f7d9027e4fdad11187980e73726cd75a2dc962c2"
12SRC_URI = "git://github.com/rhinstaller/blivet;branch=3.1-release \ 12SRC_URI = "git://github.com/storaged-project/blivet.git;branch=3.4-release \
13 file://0001-comment-out-selinux.patch \
14 file://0002-run_program-support-timeout.patch \ 13 file://0002-run_program-support-timeout.patch \
15 file://0003-support-infinit-timeout.patch \ 14 file://0003-support-infinit-timeout.patch \
16 file://0004-fix-new.roots-object-is-not-iterable.patch \ 15 file://0004-fix-new.roots-object-is-not-iterable.patch \