summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthieu CRAPET <Matthieu.CRAPET@ingenico.com>2015-04-01 11:24:50 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-04-13 12:55:50 +0200
commit2900fef5c56627351003a4995c58968295ca085d (patch)
treeae2bb57cc8ebe48981fdef876ceccc8911e58bc3
parent90b13eded76f7f7fa1a6715e67c32504e7788e96 (diff)
downloadmeta-openembedded-2900fef5c56627351003a4995c58968295ca085d.tar.gz
fbida: update to 2.10
This release fixes QA Issue [file-rdeps] Changes: - fix HAVE_LIBUNGIF => HAVE_LIBGIF - add "curl" and "webp" to PACKAGECONFIG Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/fbida/fbida_2.10.bb (renamed from meta-oe/recipes-graphics/fbida/fbida_git.bb)21
1 files changed, 14 insertions, 7 deletions
diff --git a/meta-oe/recipes-graphics/fbida/fbida_git.bb b/meta-oe/recipes-graphics/fbida/fbida_2.10.bb
index 41c14b88a..c7195fc98 100644
--- a/meta-oe/recipes-graphics/fbida/fbida_git.bb
+++ b/meta-oe/recipes-graphics/fbida/fbida_2.10.bb
@@ -8,20 +8,21 @@ SECTION = "utils"
8LICENSE = "GPLv2" 8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b" 9LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
10 10
11DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif curl" 11DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif"
12 12
13SRC_URI = "git://git.kraxel.org/fbida" 13SRC_URI = "https://www.kraxel.org/releases/fbida/fbida-${PV}.tar.gz"
14SRCREV = "6aa5563cb3c8864ad15cf83eb6fca3b773da1099" 14SRC_URI[md5sum] = "09460b964b58c2e39b665498eca29018"
15PV = "2.09+git${SRCPV}" 15SRC_URI[sha256sum] = "7a5a3aac61b40a6a2bbf716d270a46e2f8e8d5c97e314e927d41398a4d0b6cb6"
16S = "${WORKDIR}/git"
17 16
18EXTRA_OEMAKE = "STRIP=" 17EXTRA_OEMAKE = "STRIP="
19 18
20PACKAGECONFIG ??= "gif png" 19PACKAGECONFIG ??= "gif png curl"
20PACKAGECONFIG[curl] = ",,curl"
21PACKAGECONFIG[gif] = ",,giflib" 21PACKAGECONFIG[gif] = ",,giflib"
22PACKAGECONFIG[png] = ",,libpng" 22PACKAGECONFIG[png] = ",,libpng"
23PACKAGECONFIG[tiff] = ",,tiff" 23PACKAGECONFIG[tiff] = ",,tiff"
24PACKAGECONFIG[motif] = ",,libx11 libxext libxpm libxt openmotif" 24PACKAGECONFIG[motif] = ",,libx11 libxext libxpm libxt openmotif"
25PACKAGECONFIG[webp] = ",,libwebp"
25 26
26do_compile() { 27do_compile() {
27 sed -i -e 's:/sbin/ldconfig:echo x:' ${S}/mk/Autoconf.mk 28 sed -i -e 's:/sbin/ldconfig:echo x:' ${S}/mk/Autoconf.mk
@@ -29,8 +30,11 @@ do_compile() {
29 30
30 # Be sure to respect preferences (force to "no") 31 # Be sure to respect preferences (force to "no")
31 # Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH} 32 # Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH}
33 if [ -z "${@base_contains('PACKAGECONFIG', 'curl', 'curl', '', d)}" ]; then
34 sed -i -e '/^HAVE_LIBCURL/s/:=.*$/:= no/' ${S}/GNUmakefile
35 fi
32 if [ -z "${@base_contains('PACKAGECONFIG', 'gif', 'gif', '', d)}" ]; then 36 if [ -z "${@base_contains('PACKAGECONFIG', 'gif', 'gif', '', d)}" ]; then
33 sed -i -e '/^HAVE_LIBUNGIF/s/:=.*$/:= no/' ${S}/GNUmakefile 37 sed -i -e '/^HAVE_LIBGIF/s/:=.*$/:= no/' ${S}/GNUmakefile
34 fi 38 fi
35 if [ -z "${@base_contains('PACKAGECONFIG', 'png', 'png', '', d)}" ]; then 39 if [ -z "${@base_contains('PACKAGECONFIG', 'png', 'png', '', d)}" ]; then
36 sed -i -e '/^HAVE_LIBPNG/s/:=.*$/:= no/' ${S}/GNUmakefile 40 sed -i -e '/^HAVE_LIBPNG/s/:=.*$/:= no/' ${S}/GNUmakefile
@@ -41,6 +45,9 @@ do_compile() {
41 if [ -z "${@base_contains('PACKAGECONFIG', 'motif', 'motif', '', d)}" ]; then 45 if [ -z "${@base_contains('PACKAGECONFIG', 'motif', 'motif', '', d)}" ]; then
42 sed -i -e '/^HAVE_MOTIF/s/:=.*$/:= no/' ${S}/GNUmakefile 46 sed -i -e '/^HAVE_MOTIF/s/:=.*$/:= no/' ${S}/GNUmakefile
43 fi 47 fi
48 if [ -z "${@base_contains('PACKAGECONFIG', 'webp', 'webp', '', d)}" ]; then
49 sed -i -e '/^HAVE_LIBWEBP/s/:=.*$/:= no/' ${S}/GNUmakefile
50 fi
44 51
45 oe_runmake 52 oe_runmake
46} 53}