summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Holmes <mike.holmes@linaro.org>2015-04-01 16:50:13 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2015-04-13 12:55:50 +0200
commit1c71c2db408c18ff3b4237300c31dfe6ee8e1dd4 (patch)
tree74f9ac24dc89bb705965b43bfc599ae363d475d9
parent2900fef5c56627351003a4995c58968295ca085d (diff)
downloadmeta-openembedded-1c71c2db408c18ff3b4237300c31dfe6ee8e1dd4.tar.gz
add CUnit test suite
Adds a new recipe for building the CUnit test framework libraries Signed-off-by: Mike Holmes <mike.holmes@linaro.org> Signed-off-by: Gary S. Robertson <gary.robertson@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/cunit/cunit_2.1-3.bb19
-rw-r--r--meta-oe/recipes-devtools/cunit/files/fixup-install-docdir.patch36
2 files changed, 55 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/cunit/cunit_2.1-3.bb b/meta-oe/recipes-devtools/cunit/cunit_2.1-3.bb
new file mode 100644
index 000000000..085f4be89
--- /dev/null
+++ b/meta-oe/recipes-devtools/cunit/cunit_2.1-3.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "CUnit is a C framework for unit testing. Test output supports comandline and GUI results reporting"
2HOMEPAGE = "http://cunit.sourceforge.net"
3LICENSE = "LGPL-2.0"
4SECTION = "libs"
5LIC_FILES_CHKSUM = "file://COPYING;md5=7734aa853b85d6f935466f081490ddbb"
6
7S = "${WORKDIR}/CUnit-${PV}"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/project/cunit/CUnit/${PV}/CUnit-${PV}.tar.bz2 \
10 file://fixup-install-docdir.patch"
11SRC_URI[md5sum] = "b5f1a9f6093869c070c6e4a9450cc10c"
12SRC_URI[sha256sum] = "f5b29137f845bb08b77ec60584fdb728b4e58f1023e6f249a464efa49a40f214"
13
14inherit autotools-brokensep
15
16EXTRA_OECONF = "--enable-memtrace --enable-automated --enable-basic --enable-console"
17
18FILES_${PN}-dev += "${datadir}/CUnit"
19FILES_${PN}-doc += "${docdir}"
diff --git a/meta-oe/recipes-devtools/cunit/files/fixup-install-docdir.patch b/meta-oe/recipes-devtools/cunit/files/fixup-install-docdir.patch
new file mode 100644
index 000000000..c32822731
--- /dev/null
+++ b/meta-oe/recipes-devtools/cunit/files/fixup-install-docdir.patch
@@ -0,0 +1,36 @@
1From: "Mike Holmes" <mike.holmes@linaro.org>
2Date: Thu, 30 October 2014 16:21:03 -0500
3Subject: [PATCH] fixup-install-docdir
4
5The default configuration macros for CUnit install the documentation and
6header files in locations not consistent with the OE filesystem layout.
7So here we specify new locations which are consistent with OE filesystems.
8
9Upstream-Status: Inappropriate - configuration for OE build environment
10
11Signed-off-by: Mike Holmes <mike.holmes@linaro.org>
12Signed-off-by: Gary S. Robertson <gary.robertson@linaro.org>
13---
14
15diff -uNr a/doc/headers/Makefile.am b/doc/headers/Makefile.am
16--- a/doc/headers/Makefile.am 2014-10-30 22:06:29.704574162 +0100
17+++ b/doc/headers/Makefile.am 2014-10-30 22:07:43.578524791 +0100
18@@ -1,6 +1,6 @@
19 ## Process this file with automake to produce Makefile.in
20
21-dochdrdir = $(prefix)/doc/@PACKAGE@/headers
22+dochdrdir = $(docdir)/headers
23
24 INCLUDE_FILES = \
25 Automated.h \
26diff -uNr a/doc/Makefile.am b/doc/Makefile.am
27--- a/doc/Makefile.am 2014-10-30 22:06:29.704574162 +0100
28+++ b/doc/Makefile.am 2014-10-30 22:07:01.461412166 +0100
29@@ -1,7 +1,5 @@
30 ## Process this file with automake to produce Makefile.in
31
32-docdir = $(prefix)/doc/@PACKAGE@
33-
34 doc_DATA = \
35 CUnit_doc.css \
36 error_handling.html \