diff options
author | Anuj Mittal <anuj.mittal@intel.com> | 2019-09-12 15:49:28 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-09-12 02:20:59 -0700 |
commit | ffcd5f58636a7bd07d413ab5c8ee36866718ac19 (patch) | |
tree | a0b2e37cd1c4aa4b7b53f1902ea62bb4d2f32a5c | |
parent | 676fe1c49640162a75ddf254b4752bbd79ba4303 (diff) | |
download | meta-openembedded-ffcd5f58636a7bd07d413ab5c8ee36866718ac19.tar.gz |
python3-networkx: add recipe
networkx only supports python3 starting v2.3. Move the common code to
.inc and remove python-2to3 RDEPENDS which is no longer needed:
https://github.com/networkx/networkx/commit/4e611d7ea90c20864daba912d6118220d5bbddf3
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
3 files changed, 21 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python-networkx.inc b/meta-python/recipes-devtools/python/python-networkx.inc new file mode 100644 index 000000000..a4c31b2b2 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-networkx.inc | |||
@@ -0,0 +1,10 @@ | |||
1 | DESCRIPTION = "Python package for creating and manipulating graphs and networks" | ||
2 | LICENSE = "BSD-3-Clause" | ||
3 | |||
4 | inherit pypi | ||
5 | |||
6 | PYPI_PACKAGE_EXT = "zip" | ||
7 | |||
8 | RDEPENDS_${PN} += "\ | ||
9 | ${PYTHON_PN}-decorator \ | ||
10 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-networkx_2.2.bb b/meta-python/recipes-devtools/python/python-networkx_2.2.bb index a2381661c..648f0312f 100644 --- a/meta-python/recipes-devtools/python/python-networkx_2.2.bb +++ b/meta-python/recipes-devtools/python/python-networkx_2.2.bb | |||
@@ -1,12 +1,8 @@ | |||
1 | DESCRIPTION = "Python package for creating and manipulating graphs and networks" | 1 | require python-networkx.inc |
2 | LICENSE = "BSD-3-Clause" | 2 | |
3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3376ff7c9c58048c62d91431f7f08cde" | 3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3376ff7c9c58048c62d91431f7f08cde" |
4 | 4 | ||
5 | SRC_URI[md5sum] = "82608a3686fb3e61f20cf13bfd3c1b4a" | 5 | SRC_URI[md5sum] = "82608a3686fb3e61f20cf13bfd3c1b4a" |
6 | SRC_URI[sha256sum] = "45e56f7ab6fe81652fb4bc9f44faddb0e9025f469f602df14e3b2551c2ea5c8b" | 6 | SRC_URI[sha256sum] = "45e56f7ab6fe81652fb4bc9f44faddb0e9025f469f602df14e3b2551c2ea5c8b" |
7 | 7 | ||
8 | PYPI_PACKAGE_EXT = "zip" | 8 | inherit setuptools |
9 | |||
10 | inherit pypi setuptools | ||
11 | |||
12 | RDEPENDS_${PN} += "python-2to3" | ||
diff --git a/meta-python/recipes-devtools/python/python3-networkx_2.3.bb b/meta-python/recipes-devtools/python/python3-networkx_2.3.bb new file mode 100644 index 000000000..8feb6daa3 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-networkx_2.3.bb | |||
@@ -0,0 +1,8 @@ | |||
1 | require python-networkx.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b68290ee1026b204170a23bbdb27a4fd" | ||
4 | |||
5 | SRC_URI[md5sum] = "320d3f6c7872732baa63cedafddadea9" | ||
6 | SRC_URI[sha256sum] = "8311ddef63cf5c5c5e7c1d0212dd141d9a1fe3f474915281b73597ed5f1d4e3d" | ||
7 | |||
8 | inherit setuptools3 | ||