diff options
author | Marcel Ziswiler <marcel.ziswiler@toradex.com> | 2016-12-23 23:15:14 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-12-26 08:24:59 +0100 |
commit | ff60f7c111076710e2484ea9a7b81469cae368e9 (patch) | |
tree | b46d4668c22bcba5636a500175fede26249231f1 | |
parent | b68744fb802d5fd067586f9966dc69185a56f07c (diff) | |
download | meta-openembedded-ff60f7c111076710e2484ea9a7b81469cae368e9.tar.gz |
linuxptp: fix cross compilation not using host headers
Previously my morty build failed as follows:
| arm-angstrom-linux-gnueabi-gcc -march=armv7-a -mthumb -mfpu=neon -mfloat-abi
=hard --sysroot=/data/build/oe_core-V2.7/build/tmp-glibc/sysroots/apalis-tk1-mai
nline -Wall -DVER=1.6 -D_GNU_SOURCE -DHAVE_CLOCK_ADJTIME -DHAVE_POSIX_SPAWN -I/
lib/modules/4.8.13/build/usr/include -DHAVE_ONESTEP_SYNC -D_GNU_SOURCE -DHAVE_C
LOCK_ADJTIME -DHAVE_ONESTEP_SYNC -O2 -pipe -g -feliminate-unused-debug-types -fd
ebug-prefix-map=/data/build/oe_core-V2.7/build/tmp-glibc/work/armv7at2hf-neon-an
gstrom-linux-gnueabi/linuxptp/1.6-r0=/usr/src/debug/linuxptp/1.6-r0 -fdebug-pref
ix-map=/data/build/oe_core-V2.7/build/tmp-glibc/sysroots/x86_64-linux= -fdebug-p
refix-map=/data/build/oe_core-V2.7/build/tmp-glibc/sysroots/apalis-tk1-mainline=
-c -o msg.o msg.c
| {standard input}: Assembler messages:
| {standard input}:39: Error: bad instruction `bswapq r0'
| <builtin>: recipe for target 'msg.o' failed
| make: *** [msg.o] Error 1
As it tried using the kernel headers from my Fedora 23 build server
located at /lib/modules/4.8.13/build/usr/include.
Fix this by no longer calling the incdefs.sh shell script from the
makefile.
Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-connectivity/linuxptp/linuxptp/no-incdefs-using-host-headers.patch | 29 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/linuxptp/linuxptp_1.6.bb | 5 |
2 files changed, 32 insertions, 2 deletions
diff --git a/meta-oe/recipes-connectivity/linuxptp/linuxptp/no-incdefs-using-host-headers.patch b/meta-oe/recipes-connectivity/linuxptp/linuxptp/no-incdefs-using-host-headers.patch new file mode 100644 index 000000000..02dbb2346 --- /dev/null +++ b/meta-oe/recipes-connectivity/linuxptp/linuxptp/no-incdefs-using-host-headers.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From 8a4cad5e2f2cbb6a34bdc6e877fe499502b8c4c8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Marcel Ziswiler <marcel.ziswiler@toradex.com> | ||
3 | Date: Fri, 23 Dec 2016 18:12:29 +0100 | ||
4 | Subject: [PATCH] linuxptp: no incdefs using host headers | ||
5 | |||
6 | Avoid using host headers via incdefs.sh shell script. | ||
7 | |||
8 | Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> | ||
9 | --- | ||
10 | |||
11 | makefile | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/makefile b/makefile | ||
15 | index 8cdbd15..85174b8 100644 | ||
16 | --- a/makefile | ||
17 | +++ b/makefile | ||
18 | @@ -33,7 +33,7 @@ OBJECTS = $(OBJ) hwstamp_ctl.o phc2sys.o phc_ctl.o pmc.o pmc_common.o \ | ||
19 | SRC = $(OBJECTS:.o=.c) | ||
20 | DEPEND = $(OBJECTS:.o=.d) | ||
21 | srcdir := $(dir $(lastword $(MAKEFILE_LIST))) | ||
22 | -incdefs := $(shell $(srcdir)/incdefs.sh) | ||
23 | +#incdefs := $(shell $(srcdir)/incdefs.sh) | ||
24 | version := $(shell $(srcdir)/version.sh $(srcdir)) | ||
25 | VPATH = $(srcdir) | ||
26 | |||
27 | -- | ||
28 | 2.9.3 | ||
29 | |||
diff --git a/meta-oe/recipes-connectivity/linuxptp/linuxptp_1.6.bb b/meta-oe/recipes-connectivity/linuxptp/linuxptp_1.6.bb index 0939d17f9..2e28644f0 100644 --- a/meta-oe/recipes-connectivity/linuxptp/linuxptp_1.6.bb +++ b/meta-oe/recipes-connectivity/linuxptp/linuxptp_1.6.bb | |||
@@ -3,13 +3,14 @@ LICENSE = "GPLv2" | |||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
4 | 4 | ||
5 | SRC_URI = "http://sourceforge.net/projects/linuxptp/files/v${PV}/linuxptp-${PV}.tgz \ | 5 | SRC_URI = "http://sourceforge.net/projects/linuxptp/files/v${PV}/linuxptp-${PV}.tgz \ |
6 | file://build-Allow-CC-and-prefix-to-be-overriden.patch" | 6 | file://build-Allow-CC-and-prefix-to-be-overriden.patch \ |
7 | file://no-incdefs-using-host-headers.patch" | ||
7 | 8 | ||
8 | SRC_URI[md5sum] = "6aa15d83f5a35f1fd076ba9adc4e7285" | 9 | SRC_URI[md5sum] = "6aa15d83f5a35f1fd076ba9adc4e7285" |
9 | SRC_URI[sha256sum] = "e7fd16a9f235b059be527bd512e86f0c1d9f2e7c36736e6d6d9727a4427ac14c" | 10 | SRC_URI[sha256sum] = "e7fd16a9f235b059be527bd512e86f0c1d9f2e7c36736e6d6d9727a4427ac14c" |
10 | 11 | ||
11 | EXTRA_OEMAKE = "ARCH=${TARGET_ARCH} \ | 12 | EXTRA_OEMAKE = "ARCH=${TARGET_ARCH} \ |
12 | EXTRA_CFLAGS='-D_GNU_SOURCE -DHAVE_CLOCK_ADJTIME -DHAVE_ONESTEP_SYNC ${CFLAGS}'" | 13 | EXTRA_CFLAGS='-D_GNU_SOURCE -DHAVE_CLOCK_ADJTIME -DHAVE_POSIX_SPAWN -DHAVE_ONESTEP_SYNC ${CFLAGS}'" |
13 | 14 | ||
14 | do_install () { | 15 | do_install () { |
15 | install -d ${D}/${bindir} | 16 | install -d ${D}/${bindir} |