diff options
author | Tim Orling <timothy.t.orling@linux.intel.com> | 2017-08-27 16:29:42 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-08-31 10:18:33 +0200 |
commit | fe477f0c981e80b99ac28fcd460d40b4d5d3007e (patch) | |
tree | f92295d47e856d2fbced10d2a7d374041b7b2f35 | |
parent | e975dd7786bdb55c6db34fcaf685df49fc4ba080 (diff) | |
download | meta-openembedded-fe477f0c981e80b99ac28fcd460d40b4d5d3007e.tar.gz |
libmodule-build-perl: upgrade to v0.4224
* Use COPYRIGHT excerpt from README for license check
- Remains the same perl5 license
- LICENSE contents is unhelpful "FULLTEXT"
* Correct copy-paste error in SUMMARY
* Author is now LEONT instead of KWILLIAMS
* Update HOMEPAGE
* Add interpreter fix from meta-cpan for lib/Module/Build/Base.pm
Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-perl/recipes-perl/libmodule/libmodule-build-perl_0.31.bb | 27 | ||||
-rw-r--r-- | meta-perl/recipes-perl/libmodule/libmodule-build-perl_0.4224.bb | 34 |
2 files changed, 34 insertions, 27 deletions
diff --git a/meta-perl/recipes-perl/libmodule/libmodule-build-perl_0.31.bb b/meta-perl/recipes-perl/libmodule/libmodule-build-perl_0.31.bb deleted file mode 100644 index c0fa06d08..000000000 --- a/meta-perl/recipes-perl/libmodule/libmodule-build-perl_0.31.bb +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | SUMMARY = "Module::Build::Tiny - A tiny replacement for Module::Build" | ||
2 | DESCRIPTION = "Many Perl distributions use a Build.PL file instead of a \ | ||
3 | Makefile.PL file to drive distribution configuration, build, test and \ | ||
4 | installation. Traditionally, Build.PL uses Module::Build as the underlying \ | ||
5 | build system. This module provides a simple, lightweight, drop-in replacement. \ | ||
6 | Whereas Module::Build has over 6,700 lines of code; this module has less than \ | ||
7 | 120, yet supports the features needed by most distributions." | ||
8 | SECTION = "libs" | ||
9 | |||
10 | HOMEPAGE = "http://search.cpan.org/~kwilliams/Module-Build-0.31/" | ||
11 | |||
12 | LICENSE = "Artistic-1.0 | GPL-1.0+" | ||
13 | LIC_FILES_CHKSUM = "file://LICENSE;md5=43339d8f9d3a956ee9eceb07717ee95e" | ||
14 | |||
15 | SRC_URI = "${CPAN_MIRROR}/authors/id/K/KW/KWILLIAMS/Module-Build-${PV}.tar.gz" | ||
16 | SRC_URI[md5sum] = "3d4fdffe58f6236253767e5a71edf29b" | ||
17 | SRC_URI[sha256sum] = "e2f723be8d6c70b4ddbca3b5e32e52e6e98eae8f43e34d7ede87efcb1796bbb5" | ||
18 | |||
19 | S = "${WORKDIR}/Module-Build-${PV}" | ||
20 | |||
21 | inherit cpan_build | ||
22 | |||
23 | do_install () { | ||
24 | cpan_build_do_install | ||
25 | } | ||
26 | |||
27 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-perl/recipes-perl/libmodule/libmodule-build-perl_0.4224.bb b/meta-perl/recipes-perl/libmodule/libmodule-build-perl_0.4224.bb new file mode 100644 index 000000000..d523a7a0c --- /dev/null +++ b/meta-perl/recipes-perl/libmodule/libmodule-build-perl_0.4224.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | SUMMARY = "Module::Build - Build and install Perl modules" | ||
2 | DESCRIPTION = "Many Perl distributions use a Build.PL file instead of a \ | ||
3 | Makefile.PL file to drive distribution configuration, build, test and \ | ||
4 | installation. Traditionally, Build.PL uses Module::Build as the underlying \ | ||
5 | build system. This module provides a simple, lightweight, drop-in replacement. \ | ||
6 | Whereas Module::Build has over 6,700 lines of code; this module has less than \ | ||
7 | 120, yet supports the features needed by most distributions." | ||
8 | |||
9 | SECTION = "libs" | ||
10 | |||
11 | HOMEPAGE = "https://metacpan.org/release/Module-Build" | ||
12 | |||
13 | LICENSE = "Artistic-1.0 | GPL-1.0+" | ||
14 | LIC_FILES_CHKSUM = "file://README;beginline=960;endline=965;md5=624c06db56a2af4d70cf9edc29fcae1b" | ||
15 | |||
16 | SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/Module-Build-${PV}.tar.gz" | ||
17 | SRC_URI[md5sum] = "b74c2f6e84b60aad3a3defd30b6f0f4d" | ||
18 | SRC_URI[sha256sum] = "a6ca15d78244a7b50fdbf27f85c85f4035aa799ce7dd018a0d98b358ef7bc782" | ||
19 | |||
20 | S = "${WORKDIR}/Module-Build-${PV}" | ||
21 | |||
22 | inherit cpan_build | ||
23 | |||
24 | # From: | ||
25 | # https://github.com/rehsack/meta-cpan/blob/master/recipes-devel/module-build-perl/module-build-perl_0.4216.bb | ||
26 | # | ||
27 | do_patch_module_build () { | ||
28 | cd ${S} | ||
29 | sed -i -e 's,my $interpreter = $self->{properties}{perl};,my $interpreter = "${bindir}/perl";,g' lib/Module/Build/Base.pm | ||
30 | } | ||
31 | |||
32 | do_patch[postfuncs] += "do_patch_module_build" | ||
33 | |||
34 | BBCLASSEXTEND = "native" | ||