diff options
author | Khem Raj <raj.khem@gmail.com> | 2020-08-13 19:45:36 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-08-13 22:37:48 -0700 |
commit | f5b604706fa947cb83c9dcb897cd3311070a78a0 (patch) | |
tree | 8970d37766c47ef930f05e61682054a7ea40b6c4 | |
parent | e77bdb0e694a61aea116cd3ac2efc4521ad16e89 (diff) | |
download | meta-openembedded-f5b604706fa947cb83c9dcb897cd3311070a78a0.tar.gz |
ifplugd: Fix build with gcc10/-fno-common
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-connectivity/ifplugd/ifplugd/0001-src-interface.h-Make-declarations-as-extern.patch | 31 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/ifplugd/ifplugd_0.28.bb | 4 |
2 files changed, 34 insertions, 1 deletions
diff --git a/meta-oe/recipes-connectivity/ifplugd/ifplugd/0001-src-interface.h-Make-declarations-as-extern.patch b/meta-oe/recipes-connectivity/ifplugd/ifplugd/0001-src-interface.h-Make-declarations-as-extern.patch new file mode 100644 index 000000000..77de9e6c5 --- /dev/null +++ b/meta-oe/recipes-connectivity/ifplugd/ifplugd/0001-src-interface.h-Make-declarations-as-extern.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From b990146a149e1729c12e4541a67e32ed1dd6e578 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 13 Aug 2020 19:41:08 -0700 | ||
4 | Subject: [PATCH] src/interface.h: Make declarations as extern | ||
5 | |||
6 | Fixed build with -fno-common | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | src/interface.h | 4 ++-- | ||
12 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/src/interface.h b/src/interface.h | ||
15 | index d223b1f..fd4a5f4 100644 | ||
16 | --- a/src/interface.h | ||
17 | +++ b/src/interface.h | ||
18 | @@ -21,8 +21,8 @@ | ||
19 | * Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA. | ||
20 | */ | ||
21 | |||
22 | -int interface_auto_up; | ||
23 | -int interface_do_message; | ||
24 | +extern int interface_auto_up; | ||
25 | +extern int interface_do_message; | ||
26 | |||
27 | typedef enum { IFSTATUS_UP, IFSTATUS_DOWN, IFSTATUS_ERR } interface_status_t; | ||
28 | |||
29 | -- | ||
30 | 2.28.0 | ||
31 | |||
diff --git a/meta-oe/recipes-connectivity/ifplugd/ifplugd_0.28.bb b/meta-oe/recipes-connectivity/ifplugd/ifplugd_0.28.bb index 0b5c5a6ce..7dc83e85f 100644 --- a/meta-oe/recipes-connectivity/ifplugd/ifplugd_0.28.bb +++ b/meta-oe/recipes-connectivity/ifplugd/ifplugd_0.28.bb | |||
@@ -6,7 +6,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=94d55d512a9ba36caa9b7df079bae19f" | |||
6 | 6 | ||
7 | DEPENDS = "libdaemon" | 7 | DEPENDS = "libdaemon" |
8 | 8 | ||
9 | SRC_URI = "http://0pointer.de/lennart/projects/ifplugd/ifplugd-${PV}.tar.gz" | 9 | SRC_URI = "http://0pointer.de/lennart/projects/ifplugd/ifplugd-${PV}.tar.gz \ |
10 | file://0001-src-interface.h-Make-declarations-as-extern.patch \ | ||
11 | " | ||
10 | 12 | ||
11 | SRC_URI_append_libc-musl = " file://Fix-build-with-musl.patch" | 13 | SRC_URI_append_libc-musl = " file://Fix-build-with-musl.patch" |
12 | 14 | ||