summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-08-06 20:59:31 -0700
committerKhem Raj <raj.khem@gmail.com>2019-08-08 10:01:45 -0700
commite839371c3554e7d7c7311e352fefbdb23957d80c (patch)
tree7a27ea68542bfbb11c9a4fea9482067a27552690
parent2cb6ed738ebfe27336be64e09214e4bf34c3a39a (diff)
downloadmeta-openembedded-e839371c3554e7d7c7311e352fefbdb23957d80c.tar.gz
graphviz: Do not build tcl support for target
tclpkg looks for tclsh on buildhost and if we try to use the native version then it groks the paths from the native sysroot and builds and installs the target tcl packages into the same path, in the end it ends up being wrongly packaged. Therefore its best to disable tcl Secondly, package python and perl pieces into independent packages so the runtime dependencies are also set accordingly. Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/graphviz/graphviz/0001-Set-use_tcl-to-be-empty-string-if-tcl-is-disabled.patch33
-rw-r--r--meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb19
2 files changed, 51 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/graphviz/graphviz/0001-Set-use_tcl-to-be-empty-string-if-tcl-is-disabled.patch b/meta-oe/recipes-graphics/graphviz/graphviz/0001-Set-use_tcl-to-be-empty-string-if-tcl-is-disabled.patch
new file mode 100644
index 000000000..21bf1bcd5
--- /dev/null
+++ b/meta-oe/recipes-graphics/graphviz/graphviz/0001-Set-use_tcl-to-be-empty-string-if-tcl-is-disabled.patch
@@ -0,0 +1,33 @@
1From 564901ab78da2b2b1bed92351dc3c102dc0a8154 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 6 Aug 2019 17:51:39 -0700
4Subject: [PATCH] Set use_tcl to be empty string if tcl is disabled
5
6Upstream-Status: Inappropriate [Cross-compile specific]
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 configure.ac | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12--- a/configure.ac
13+++ b/configure.ac
14@@ -1676,7 +1676,7 @@ AC_ARG_ENABLE(tcl,
15 [], [enable_tcl=yes])
16
17 if test "x$enable_tcl" != "xyes"; then
18- use_tcl="No (disabled)"
19+ use_tcl=""
20 fi
21
22 if test "x$use_tcl" = "x"; then
23--- a/Makefile.am
24+++ b/Makefile.am
25@@ -19,7 +19,7 @@ pkginclude_HEADERS = $(top_builddir)/gra
26 man_MANS = graphviz.7
27
28 # $(subdirs) contains the list from: AC_CONFIG_SUBDIRS
29-SUBDIRS = $(subdirs) lib plugin cmd tclpkg doc contrib share graphs rtest tests
30+SUBDIRS = $(subdirs) lib plugin cmd doc contrib share graphs rtest tests
31
32 .PHONY: doxygen
33 doxygen:
diff --git a/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb b/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb
index fb8ea2a5b..176cf4498 100644
--- a/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb
+++ b/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb
@@ -29,7 +29,10 @@ SRC_URI = "https://gitlab.com/graphviz/graphviz/-/archive/stable_release_${PV}/g
29 file://0001-plugin-pango-Include-freetype-headers-explicitly.patch \ 29 file://0001-plugin-pango-Include-freetype-headers-explicitly.patch \
30" 30"
31# Use native mkdefs 31# Use native mkdefs
32SRC_URI_append_class-target = " file://0001-Use-native-mkdefs.patch" 32SRC_URI_append_class-target = "\
33 file://0001-Use-native-mkdefs.patch \
34 file://0001-Set-use_tcl-to-be-empty-string-if-tcl-is-disabled.patch \
35"
33SRC_URI[md5sum] = "2acf30ca8e6cc8b001b0334db65fd072" 36SRC_URI[md5sum] = "2acf30ca8e6cc8b001b0334db65fd072"
34SRC_URI[sha256sum] = "e6c3f8dbfde1c4523055403927bef29f97f9fc12715c1042b5dcf648a2c1c62a" 37SRC_URI[sha256sum] = "e6c3f8dbfde1c4523055403927bef29f97f9fc12715c1042b5dcf648a2c1c62a"
35 38
@@ -40,6 +43,7 @@ EXTRA_OECONF_class-target = "\
40 --with-expatlibdir=${STAGING_LIBDIR} \ 43 --with-expatlibdir=${STAGING_LIBDIR} \
41 --without-included-ltdl \ 44 --without-included-ltdl \
42 --disable-java \ 45 --disable-java \
46 --disable-tcl \
43 --disable-r \ 47 --disable-r \
44 --disable-sharp \ 48 --disable-sharp \
45 " 49 "
@@ -55,6 +59,19 @@ do_install_append_class-native() {
55 install -m755 ${B}/lib/gvpr/mkdefs ${D}${bindir} 59 install -m755 ${B}/lib/gvpr/mkdefs ${D}${bindir}
56} 60}
57 61
62PACKAGES =+ "${PN}-python ${PN}-perl ${PN}-demo"
63
64FILES_${PN}-python += "${libdir}/python*/site-packages/ ${libdir}/graphviz/python/"
65FILES_${PN}-perl += "${libdir}/perl5/*/vendor_perl/ ${libdir}/graphviz/perl/"
66FILES_${PN}-demo += "${datadir}/graphviz/demo/"
67
68RDEPENDS_${PN}-perl += "perl"
69RDEPENDS_${PN}-python += "python"
70RDEPENDS_${PN}-demo += "python perl"
71
72INSANE_SKIP_${PN}-perl = "dev-so"
73INSANE_SKIP_${PN}-python = "dev-so"
74
58FILES_SOLIBSDEV_append = " ${libdir}/graphviz/lib*${SOLIBSDEV}" 75FILES_SOLIBSDEV_append = " ${libdir}/graphviz/lib*${SOLIBSDEV}"
59 76
60BBCLASSEXTEND = "native" 77BBCLASSEXTEND = "native"