diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-07-12 15:31:36 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-07-13 23:28:06 -0700 |
commit | e71751bf3cd209f07b986bb2c6289902546d3666 (patch) | |
tree | ca4f86c5ffcca20548e35bc2f36b56b1286071ee | |
parent | 225a74195232941fa48dfc9f55a73281212e1eed (diff) | |
download | meta-openembedded-e71751bf3cd209f07b986bb2c6289902546d3666.tar.gz |
wvdial: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-connectivity/wvdial/wvdial/musl-support.patch | 25 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb | 6 |
2 files changed, 26 insertions, 5 deletions
diff --git a/meta-oe/recipes-connectivity/wvdial/wvdial/musl-support.patch b/meta-oe/recipes-connectivity/wvdial/wvdial/musl-support.patch new file mode 100644 index 000000000..b5ad4823a --- /dev/null +++ b/meta-oe/recipes-connectivity/wvdial/wvdial/musl-support.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | Drop support for glibc < 2.10, in master we are at 2.28 | ||
2 | in process get it working with musl as well. | ||
3 | |||
4 | Upstream-Status: Inappropriate [No upstream] | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- a/wvmodemscan.cc | ||
8 | +++ b/wvmodemscan.cc | ||
9 | @@ -495,16 +495,8 @@ static int fileselect(const struct diren | ||
10 | // (no internal ISDN support) || !strncmp(e->d_name, "ttyI", 4); | ||
11 | } | ||
12 | |||
13 | -#if defined(__GLIBC__) && __GLIBC_PREREQ(2, 10) | ||
14 | static int filesort(const dirent **e1, const dirent **e2) | ||
15 | -#else | ||
16 | -static int filesort(const void *_e1, const void *_e2) | ||
17 | -#endif | ||
18 | { | ||
19 | -#if !(defined(__GLIBC__) && __GLIBC_PREREQ(2, 10)) | ||
20 | - dirent const * const *e1 = (dirent const * const *)_e1; | ||
21 | - dirent const * const *e2 = (dirent const * const *)_e2; | ||
22 | -#endif | ||
23 | const char *p1, *p2; | ||
24 | int diff; | ||
25 | |||
diff --git a/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb b/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb index 515420817..36580952f 100644 --- a/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb +++ b/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb | |||
@@ -11,8 +11,8 @@ RDEPENDS_${PN} = "ppp" | |||
11 | 11 | ||
12 | SRC_URI = "http://${BPN}.googlecode.com/files/${BP}.tar.bz2 \ | 12 | SRC_URI = "http://${BPN}.googlecode.com/files/${BP}.tar.bz2 \ |
13 | file://typo_pon.wvdial.1.patch \ | 13 | file://typo_pon.wvdial.1.patch \ |
14 | file://musl-support.patch \ | ||
14 | " | 15 | " |
15 | |||
16 | SRC_URI[md5sum] = "37e9a2d664effe4efd44c0e1a20136de" | 16 | SRC_URI[md5sum] = "37e9a2d664effe4efd44c0e1a20136de" |
17 | SRC_URI[sha256sum] = "99906d9560cbdbc97e1855e7b0a7169f1e11983be3ac539140423f09debced82" | 17 | SRC_URI[sha256sum] = "99906d9560cbdbc97e1855e7b0a7169f1e11983be3ac539140423f09debced82" |
18 | 18 | ||
@@ -21,8 +21,6 @@ export WVLINK="${LD}" | |||
21 | 21 | ||
22 | PARALLEL_MAKE = "" | 22 | PARALLEL_MAKE = "" |
23 | 23 | ||
24 | BUILD_CPPFLAGS += "-I${STAGING_INCDIR}/wvstreams" | ||
25 | |||
26 | do_configure() { | 24 | do_configure() { |
27 | sed -i 's/LDFLAGS+=-luniconf/LIBS+=-luniconf/' ${S}/Makefile | 25 | sed -i 's/LDFLAGS+=-luniconf/LIBS+=-luniconf/' ${S}/Makefile |
28 | } | 26 | } |
@@ -30,5 +28,3 @@ do_configure() { | |||
30 | do_install() { | 28 | do_install() { |
31 | oe_runmake prefix=${D}/usr PPPDIR=${D}/etc/ppp/peers install | 29 | oe_runmake prefix=${D}/usr PPPDIR=${D}/etc/ppp/peers install |
32 | } | 30 | } |
33 | # http://errors.yoctoproject.org/Errors/Details/186959/ | ||
34 | EXCLUDE_FROM_WORLD_libc-musl = "1" | ||