diff options
author | Khem Raj <raj.khem@gmail.com> | 2016-10-18 22:38:30 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-10-26 10:28:39 +0200 |
commit | cc5414c232ef5679f180adbc16f0f67a997179a2 (patch) | |
tree | de2b6965d4167f05f8cf0986a0e6bcebc018ac0a | |
parent | b8ecf243e2bd9c1f068fb22e988ae5a3ad65b3c6 (diff) | |
download | meta-openembedded-cc5414c232ef5679f180adbc16f0f67a997179a2.tar.gz |
glcompbench: Demand c++11 explicitly
Helps in fixing build issues when default std of C++
compiler is older
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-graphics/glcompbench/glcompbench/0001-build-Specify-std-c-11-on-cmdline.patch | 45 | ||||
-rwxr-xr-x | meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb | 4 |
2 files changed, 48 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/glcompbench/glcompbench/0001-build-Specify-std-c-11-on-cmdline.patch b/meta-oe/recipes-graphics/glcompbench/glcompbench/0001-build-Specify-std-c-11-on-cmdline.patch new file mode 100644 index 000000000..ffbc297f0 --- /dev/null +++ b/meta-oe/recipes-graphics/glcompbench/glcompbench/0001-build-Specify-std-c-11-on-cmdline.patch | |||
@@ -0,0 +1,45 @@ | |||
1 | From 47bfef0dd83ed2e10ec4c615908ec926c4d5fe2e Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 19 Oct 2016 00:56:54 +0000 | ||
4 | Subject: [PATCH] build: Specify -std=c++11 on cmdline | ||
5 | |||
6 | We use c++11 features so demand it explicitly from compiler | ||
7 | |||
8 | Fixes | ||
9 | | ../src/libmatrix/shader-source.cc:37:10: error: no member named 'unique_ptr' in namespace 'std' | ||
10 | | std::unique_ptr<std::istream> is_ptr(Util::get_resource(filename)); | ||
11 | | ~~~~~^ | ||
12 | | ../src/libmatrix/shader-source.cc:37:33: error: expected '(' for function-style cast or type construction | ||
13 | | std::unique_ptr<std::istream> is_ptr(Util::get_resource(filename)); | ||
14 | | ~~~~~~~~~~~~^ | ||
15 | | ../src/libmatrix/shader-source.cc:37:35: error: use of undeclared identifier 'is_ptr' | ||
16 | | std::unique_ptr<std::istream> is_ptr(Util::get_resource(filename)); | ||
17 | | ^ | ||
18 | | ../src/libmatrix/shader-source.cc:38:30: error: use of undeclared identifier 'is_ptr' | ||
19 | | std::istream& inputFile(*is_ptr); | ||
20 | | ^ | ||
21 | | 4 errors generated. | ||
22 | |||
23 | Upstream-Status: Pending | ||
24 | |||
25 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
26 | --- | ||
27 | wscript | 2 +- | ||
28 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
29 | |||
30 | diff --git a/wscript b/wscript | ||
31 | index dcaf298..485a9fb 100644 | ||
32 | --- a/wscript | ||
33 | +++ b/wscript | ||
34 | @@ -79,7 +79,7 @@ def configure(ctx): | ||
35 | ctx.check_cfg(package = pkg, uselib_store = uselib, args = '--cflags --libs', | ||
36 | mandatory = True) | ||
37 | |||
38 | - ctx.env.append_unique('CXXFLAGS', '-Wall -Werror -Wextra'.split(' ')) | ||
39 | + ctx.env.append_unique('CXXFLAGS', '-Wall -Werror -std=c++11 -Wextra'.split(' ')) | ||
40 | |||
41 | # Prepend -O# and -g flags so that they can be overriden by the CFLAGS environment variable | ||
42 | if Options.options.opt: | ||
43 | -- | ||
44 | 1.9.1 | ||
45 | |||
diff --git a/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb b/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb index 35fb4adb3..7cf9692f6 100755 --- a/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb +++ b/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb | |||
@@ -9,7 +9,9 @@ SRC_URI = "https://launchpad.net/glcompbench/trunk/${PV}/+download/${BPN}-${PV}. | |||
9 | file://glbench-compile-fix.patch \ | 9 | file://glbench-compile-fix.patch \ |
10 | file://Fix-configure-for-sqrt-check.patch \ | 10 | file://Fix-configure-for-sqrt-check.patch \ |
11 | file://Fix_space_issues.patch \ | 11 | file://Fix_space_issues.patch \ |
12 | file://Fix_auto_ptr_deprecated.patch" | 12 | file://Fix_auto_ptr_deprecated.patch \ |
13 | file://0001-build-Specify-std-c-11-on-cmdline.patch \ | ||
14 | " | ||
13 | 15 | ||
14 | SRC_URI[md5sum] = "c939d9156fe940960098f38707fea827" | 16 | SRC_URI[md5sum] = "c939d9156fe940960098f38707fea827" |
15 | SRC_URI[sha256sum] = "b04b738cec06c6786ceafa86e4735fd8b971c078265754854ef356b0379542ee" | 17 | SRC_URI[sha256sum] = "b04b738cec06c6786ceafa86e4735fd8b971c078265754854ef356b0379542ee" |