summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-07-27 14:09:10 -0700
committerKhem Raj <raj.khem@gmail.com>2018-07-30 01:34:10 -0700
commita001e465293b36c03d4ca4500857fe0a67d13e20 (patch)
treea9625ca6585f89abfd440a2e4dbef18a34cbab29
parent5a9a62ee69d487b5aecc441b22b3773d4f51f2f1 (diff)
downloadmeta-openembedded-a001e465293b36c03d4ca4500857fe0a67d13e20.tar.gz
samba: Update to 4.8.3
LDB 1.4.0 breaks Samba < 4.9 therefore use internal version Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/samba/samba/0001-ldb-Refuse-to-build-Samba-against-a-newer-minor-vers.patch86
-rw-r--r--meta-networking/recipes-connectivity/samba/samba/0001-packaging-Avoid-timeout-for-nmbd-if-started-offline-.patch32
-rw-r--r--meta-networking/recipes-connectivity/samba/samba/0006-avoid-using-colon-in-the-checking-msg.patch32
-rw-r--r--meta-networking/recipes-connectivity/samba/samba/samba-4.3.9-remove-getpwent_r.patch36
-rw-r--r--meta-networking/recipes-connectivity/samba/samba/samba-pam.patch21
-rw-r--r--meta-networking/recipes-connectivity/samba/samba/smb.conf254
-rw-r--r--meta-networking/recipes-connectivity/samba/samba/smb_conf-4.7.0.patch17
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.8.3.bb (renamed from meta-networking/recipes-connectivity/samba/samba_4.7.8.bb)21
8 files changed, 400 insertions, 99 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba/0001-ldb-Refuse-to-build-Samba-against-a-newer-minor-vers.patch b/meta-networking/recipes-connectivity/samba/samba/0001-ldb-Refuse-to-build-Samba-against-a-newer-minor-vers.patch
new file mode 100644
index 000000000..4c94831d7
--- /dev/null
+++ b/meta-networking/recipes-connectivity/samba/samba/0001-ldb-Refuse-to-build-Samba-against-a-newer-minor-vers.patch
@@ -0,0 +1,86 @@
1From 0bc8bc4143a58f91f6d7ce228b6763f377fdf45a Mon Sep 17 00:00:00 2001
2From: Andrew Bartlett <abartlet@samba.org>
3Date: Thu, 12 Jul 2018 12:34:56 +1200
4Subject: [PATCH] ldb: Refuse to build Samba against a newer minor version of
5 ldb
6
7Samba is not compatible with new versions of ldb (except release versions)
8
9Other users would not notice the breakages, but Samba makes many
10more assuptions about the LDB internals than any other package.
11
12(Specifically, LDB 1.2 and 1.4 broke builds against released
13Samba versions)
14
15BUG: https://bugzilla.samba.org/show_bug.cgi?id=13519
16
17Signed-off-by: Andrew Bartlett <abartlet@samba.org>
18Reviewed-by: Gary Lockyer <gary@catalyst.net.nz>
19(cherry picked from commit 52efa796538ae004ca62ea32fc8c833472991be6)
20---
21 lib/ldb/wscript | 32 ++++++++++++++++++++++----------
22 1 file changed, 22 insertions(+), 10 deletions(-)
23
24diff --git a/lib/ldb/wscript b/lib/ldb/wscript
25index d94086b..2bb0832 100644
26--- a/lib/ldb/wscript
27+++ b/lib/ldb/wscript
28@@ -62,23 +62,33 @@ def configure(conf):
29 conf.env.standalone_ldb = conf.IN_LAUNCH_DIR()
30
31 if not conf.env.standalone_ldb:
32+ max_ldb_version = [int(x) for x in VERSION.split(".")]
33+ max_ldb_version[2] = 999
34+ max_ldb_version_dots = "%d.%d.%d" % tuple(max_ldb_version)
35+
36 if conf.env.disable_python:
37- if conf.CHECK_BUNDLED_SYSTEM_PKG('ldb', minversion=VERSION,
38- onlyif='talloc tdb tevent',
39- implied_deps='replace talloc tdb tevent'):
40+ if conf.CHECK_BUNDLED_SYSTEM_PKG('ldb',
41+ minversion=VERSION,
42+ maxversion=max_ldb_version_dots,
43+ onlyif='talloc tdb tevent',
44+ implied_deps='replace talloc tdb tevent'):
45 conf.define('USING_SYSTEM_LDB', 1)
46 else:
47 using_system_pyldb_util = True
48- if not conf.CHECK_BUNDLED_SYSTEM_PKG('pyldb-util', minversion=VERSION,
49- onlyif='talloc tdb tevent',
50- implied_deps='replace talloc tdb tevent ldb'):
51+ if not conf.CHECK_BUNDLED_SYSTEM_PKG('pyldb-util',
52+ minversion=VERSION,
53+ maxversion=max_ldb_version_dots,
54+ onlyif='talloc tdb tevent',
55+ implied_deps='replace talloc tdb tevent ldb'):
56 using_system_pyldb_util = False
57
58 # We need to get a pyldb-util for all the python versions
59 # we are building for
60 if conf.env['EXTRA_PYTHON']:
61 name = 'pyldb-util' + conf.all_envs['extrapython']['PYTHON_SO_ABI_FLAG']
62- if not conf.CHECK_BUNDLED_SYSTEM_PKG(name, minversion=VERSION,
63+ if not conf.CHECK_BUNDLED_SYSTEM_PKG(name,
64+ minversion=VERSION,
65+ maxversion=max_ldb_version_dots,
66 onlyif='talloc tdb tevent',
67 implied_deps='replace talloc tdb tevent ldb'):
68 using_system_pyldb_util = False
69@@ -86,9 +96,11 @@ def configure(conf):
70 if using_system_pyldb_util:
71 conf.define('USING_SYSTEM_PYLDB_UTIL', 1)
72
73- if conf.CHECK_BUNDLED_SYSTEM_PKG('ldb', minversion=VERSION,
74- onlyif='talloc tdb tevent pyldb-util',
75- implied_deps='replace talloc tdb tevent'):
76+ if conf.CHECK_BUNDLED_SYSTEM_PKG('ldb',
77+ minversion=VERSION,
78+ maxversion=max_ldb_version_dots,
79+ onlyif='talloc tdb tevent pyldb-util',
80+ implied_deps='replace talloc tdb tevent'):
81 conf.define('USING_SYSTEM_LDB', 1)
82
83 if conf.CONFIG_SET('USING_SYSTEM_LDB'):
84--
852.18.0
86
diff --git a/meta-networking/recipes-connectivity/samba/samba/0001-packaging-Avoid-timeout-for-nmbd-if-started-offline-.patch b/meta-networking/recipes-connectivity/samba/samba/0001-packaging-Avoid-timeout-for-nmbd-if-started-offline-.patch
deleted file mode 100644
index 0e89a9be0..000000000
--- a/meta-networking/recipes-connectivity/samba/samba/0001-packaging-Avoid-timeout-for-nmbd-if-started-offline-.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1Upstream-Status: Submitted [https://github.com/samba-team/samba/pull/70]
2
3Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
4
5From 50eac4fd30944e5e1d83060757633fe0ed572723 Mon Sep 17 00:00:00 2001
6From: Andreas Oberritter <obi@opendreambox.org>
7Date: Wed, 30 Nov 2016 16:25:06 +0100
8Subject: [PATCH] packaging: Avoid timeout for nmbd if started offline with
9 systemd
10
11If no network connection appears within DefaultTimeoutStartSec
12(~ 90s) after startup, nmbd fails to notify systemd and will
13therefore get killed.
14
15Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
16
17---
18 packaging/systemd/nmb.service | 1 +
19 1 file changed, 1 insertion(+)
20
21diff --git a/packaging/systemd/nmb.service b/packaging/systemd/nmb.service
22index 71c93d6..f3d2fc2 100644
23--- a/packaging/systemd/nmb.service
24+++ b/packaging/systemd/nmb.service
25@@ -10,6 +10,7 @@ EnvironmentFile=-/etc/sysconfig/samba
26 ExecStart=/usr/sbin/nmbd --foreground --no-process-group $NMBDOPTIONS
27 ExecReload=/usr/bin/kill -HUP $MAINPID
28 LimitCORE=infinity
29+TimeoutStartSec=0
30
31 [Install]
32 WantedBy=multi-user.target
diff --git a/meta-networking/recipes-connectivity/samba/samba/0006-avoid-using-colon-in-the-checking-msg.patch b/meta-networking/recipes-connectivity/samba/samba/0006-avoid-using-colon-in-the-checking-msg.patch
deleted file mode 100644
index cdf7a38c1..000000000
--- a/meta-networking/recipes-connectivity/samba/samba/0006-avoid-using-colon-in-the-checking-msg.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From 5413f97290d3126262eb309ecbcf7769509f2a11 Mon Sep 17 00:00:00 2001
2From: Jackie Huang <jackie.huang@windriver.com>
3Date: Tue, 10 Nov 2015 00:48:35 -0500
4Subject: [PATCH 6/7] avoid using colon in the checking msg
5
6Upstream-Status: Pending
7
8colon is used as the separator when parse from
9a answers file, the colon here makes it never
10get the right answer.
11
12Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
13---
14 wscript_configure_system_mitkrb5 | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/wscript_configure_system_mitkrb5 b/wscript_configure_system_mitkrb5
18index a62d00b..a2d89f0 100644
19--- a/wscript_configure_system_mitkrb5
20+++ b/wscript_configure_system_mitkrb5
21@@ -240,7 +240,7 @@ conf.CHECK_CODE('''
22 ''',
23 'HAVE_WRFILE_KEYTAB',
24 headers='krb5.h', lib='krb5', execute=True,
25- msg="Checking whether the WRFILE:-keytab is supported");
26+ msg="Checking whether the WRFILE -keytab is supported");
27 # Check for KRB5_DEPRECATED handling
28 conf.CHECK_CODE('''#define KRB5_DEPRECATED 1
29 #include <krb5.h>''',
30--
311.9.1
32
diff --git a/meta-networking/recipes-connectivity/samba/samba/samba-4.3.9-remove-getpwent_r.patch b/meta-networking/recipes-connectivity/samba/samba/samba-4.3.9-remove-getpwent_r.patch
index 71db99c5d..a75ac2bba 100644
--- a/meta-networking/recipes-connectivity/samba/samba/samba-4.3.9-remove-getpwent_r.patch
+++ b/meta-networking/recipes-connectivity/samba/samba/samba-4.3.9-remove-getpwent_r.patch
@@ -1,15 +1,23 @@
1Musl does not have _r versions of getent() and getpwent() APIs 1From 02e0b14d8fa025a5db410d60a7c0dfebd536aaeb Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 6 Nov 2016 23:40:54 -0800
4Subject: [PATCH] Musl does not have _r versions of getent() and getpwent()
5 APIs
2 6
3Taken from gentoo 7Taken from gentoo
4http://data.gpo.zugaina.org/musl/net-fs/samba/files/samba-4.3.9-remove-getpwent_r.patch 8http://data.gpo.zugaina.org/musl/net-fs/samba/files/samba-4.3.9-remove-getpwent_r.patch
5 9
6Signed-off-by: Khem Raj <raj.khem@gmail.com> 10Signed-off-by: Khem Raj <raj.khem@gmail.com>
7 11
8Index: samba-4.4.5/source4/torture/local/nss_tests.c 12---
9=================================================================== 13 source4/torture/local/nss_tests.c | 13 ++++++++-----
10--- samba-4.4.5.orig/source4/torture/local/nss_tests.c 14 1 file changed, 8 insertions(+), 5 deletions(-)
11+++ samba-4.4.5/source4/torture/local/nss_tests.c 15
12@@ -247,7 +247,6 @@ static bool test_getgrnam_r(struct tortu 16diff --git a/source4/torture/local/nss_tests.c b/source4/torture/local/nss_tests.c
17index 2cd6122..04f13c6 100644
18--- a/source4/torture/local/nss_tests.c
19+++ b/source4/torture/local/nss_tests.c
20@@ -247,7 +247,6 @@ static bool test_getgrnam_r(struct torture_context *tctx,
13 return true; 21 return true;
14 } 22 }
15 23
@@ -17,7 +25,7 @@ Index: samba-4.4.5/source4/torture/local/nss_tests.c
17 static bool test_getgrgid(struct torture_context *tctx, 25 static bool test_getgrgid(struct torture_context *tctx,
18 gid_t gid, 26 gid_t gid,
19 struct group *grp_p) 27 struct group *grp_p)
20@@ -333,6 +332,7 @@ static bool test_enum_passwd(struct tort 28@@ -333,6 +332,7 @@ static bool test_enum_passwd(struct torture_context *tctx,
21 return true; 29 return true;
22 } 30 }
23 31
@@ -25,7 +33,7 @@ Index: samba-4.4.5/source4/torture/local/nss_tests.c
25 static bool test_enum_r_passwd(struct torture_context *tctx, 33 static bool test_enum_r_passwd(struct torture_context *tctx,
26 struct passwd **pwd_array_p, 34 struct passwd **pwd_array_p,
27 size_t *num_pwd_p) 35 size_t *num_pwd_p)
28@@ -381,6 +381,7 @@ static bool test_enum_r_passwd(struct to 36@@ -381,6 +381,7 @@ static bool test_enum_r_passwd(struct torture_context *tctx,
29 37
30 return true; 38 return true;
31 } 39 }
@@ -33,7 +41,7 @@ Index: samba-4.4.5/source4/torture/local/nss_tests.c
33 41
34 static bool torture_assert_passwd_equal(struct torture_context *tctx, 42 static bool torture_assert_passwd_equal(struct torture_context *tctx,
35 const struct passwd *p1, 43 const struct passwd *p1,
36@@ -432,7 +433,7 @@ static bool test_passwd_r(struct torture 44@@ -432,7 +433,7 @@ static bool test_passwd_r(struct torture_context *tctx)
37 struct passwd *pwd, pwd1, pwd2; 45 struct passwd *pwd, pwd1, pwd2;
38 size_t num_pwd; 46 size_t num_pwd;
39 47
@@ -42,7 +50,7 @@ Index: samba-4.4.5/source4/torture/local/nss_tests.c
42 "failed to enumerate passwd"); 50 "failed to enumerate passwd");
43 51
44 for (i=0; i < num_pwd; i++) { 52 for (i=0; i < num_pwd; i++) {
45@@ -460,7 +461,7 @@ static bool test_passwd_r_cross(struct t 53@@ -460,7 +461,7 @@ static bool test_passwd_r_cross(struct torture_context *tctx)
46 struct passwd *pwd, pwd1, pwd2, pwd3, pwd4; 54 struct passwd *pwd, pwd1, pwd2, pwd3, pwd4;
47 size_t num_pwd; 55 size_t num_pwd;
48 56
@@ -51,7 +59,7 @@ Index: samba-4.4.5/source4/torture/local/nss_tests.c
51 "failed to enumerate passwd"); 59 "failed to enumerate passwd");
52 60
53 for (i=0; i < num_pwd; i++) { 61 for (i=0; i < num_pwd; i++) {
54@@ -531,6 +532,7 @@ static bool test_enum_group(struct tortu 62@@ -531,6 +532,7 @@ static bool test_enum_group(struct torture_context *tctx,
55 return true; 63 return true;
56 } 64 }
57 65
@@ -59,7 +67,7 @@ Index: samba-4.4.5/source4/torture/local/nss_tests.c
59 static bool test_enum_r_group(struct torture_context *tctx, 67 static bool test_enum_r_group(struct torture_context *tctx,
60 struct group **grp_array_p, 68 struct group **grp_array_p,
61 size_t *num_grp_p) 69 size_t *num_grp_p)
62@@ -579,6 +581,7 @@ static bool test_enum_r_group(struct tor 70@@ -579,6 +581,7 @@ static bool test_enum_r_group(struct torture_context *tctx,
63 71
64 return true; 72 return true;
65 } 73 }
@@ -67,7 +75,7 @@ Index: samba-4.4.5/source4/torture/local/nss_tests.c
67 75
68 static bool torture_assert_group_equal(struct torture_context *tctx, 76 static bool torture_assert_group_equal(struct torture_context *tctx,
69 const struct group *g1, 77 const struct group *g1,
70@@ -635,7 +638,7 @@ static bool test_group_r(struct torture_ 78@@ -635,7 +638,7 @@ static bool test_group_r(struct torture_context *tctx)
71 struct group *grp, grp1, grp2; 79 struct group *grp, grp1, grp2;
72 size_t num_grp; 80 size_t num_grp;
73 81
@@ -76,7 +84,7 @@ Index: samba-4.4.5/source4/torture/local/nss_tests.c
76 "failed to enumerate group"); 84 "failed to enumerate group");
77 85
78 for (i=0; i < num_grp; i++) { 86 for (i=0; i < num_grp; i++) {
79@@ -663,7 +666,7 @@ static bool test_group_r_cross(struct to 87@@ -663,7 +666,7 @@ static bool test_group_r_cross(struct torture_context *tctx)
80 struct group *grp, grp1, grp2, grp3, grp4; 88 struct group *grp, grp1, grp2, grp3, grp4;
81 size_t num_grp; 89 size_t num_grp;
82 90
diff --git a/meta-networking/recipes-connectivity/samba/samba/samba-pam.patch b/meta-networking/recipes-connectivity/samba/samba/samba-pam.patch
index 0cbacb6c0..27b40f215 100644
--- a/meta-networking/recipes-connectivity/samba/samba/samba-pam.patch
+++ b/meta-networking/recipes-connectivity/samba/samba/samba-pam.patch
@@ -1,14 +1,21 @@
1Lifted from gentoo and ported to 4.4.5 1From 54a5279cb33abd23ef7c094d51f16078ece2da0c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 6 Nov 2016 23:40:54 -0800
4Subject: [PATCH] Lifted from gentoo and ported to 4.4.5
2 5
3http://data.gpo.zugaina.org/musl/net-fs/samba/files/samba-4.2.7-pam.patch 6http://data.gpo.zugaina.org/musl/net-fs/samba/files/samba-4.2.7-pam.patch
4 7
5Signed-off-by: Khem Raj <raj.khem@gmail.com> 8Signed-off-by: Khem Raj <raj.khem@gmail.com>
6 9
7Index: samba-4.7.0/source3/wscript 10---
8=================================================================== 11 source3/wscript | 13 ++++++++++++-
9--- samba-4.7.0.orig/source3/wscript 12 1 file changed, 12 insertions(+), 1 deletion(-)
10+++ samba-4.7.0/source3/wscript 13
11@@ -875,7 +875,7 @@ msg.msg_accrightslen = sizeof(fd); 14diff --git a/source3/wscript b/source3/wscript
15index 5436db2..864f614 100644
16--- a/source3/wscript
17+++ b/source3/wscript
18@@ -879,7 +879,7 @@ msg.msg_accrightslen = sizeof(fd);
12 if conf.env.with_iconv: 19 if conf.env.with_iconv:
13 conf.DEFINE('HAVE_ICONV', 1) 20 conf.DEFINE('HAVE_ICONV', 1)
14 21
@@ -17,7 +24,7 @@ Index: samba-4.7.0/source3/wscript
17 use_pam=True 24 use_pam=True
18 conf.CHECK_HEADERS('security/pam_appl.h pam/pam_appl.h') 25 conf.CHECK_HEADERS('security/pam_appl.h pam/pam_appl.h')
19 if not conf.CONFIG_SET('HAVE_SECURITY_PAM_APPL_H') and not conf.CONFIG_SET('HAVE_PAM_PAM_APPL_H'): 26 if not conf.CONFIG_SET('HAVE_SECURITY_PAM_APPL_H') and not conf.CONFIG_SET('HAVE_PAM_PAM_APPL_H'):
20@@ -952,6 +952,17 @@ int i; i = PAM_RADIO_TYPE; 27@@ -956,6 +956,17 @@ int i; i = PAM_RADIO_TYPE;
21 "or headers not found. Use --without-pam to disable " 28 "or headers not found. Use --without-pam to disable "
22 "PAM support."); 29 "PAM support.");
23 30
diff --git a/meta-networking/recipes-connectivity/samba/samba/smb.conf b/meta-networking/recipes-connectivity/samba/samba/smb.conf
new file mode 100644
index 000000000..a0b87c373
--- /dev/null
+++ b/meta-networking/recipes-connectivity/samba/samba/smb.conf
@@ -0,0 +1,254 @@
1#
2# Sample configuration file for the Samba suite for Debian GNU/Linux.
3#
4#
5# This is the main Samba configuration file. You should read the
6# smb.conf(5) manual page in order to understand the options listed
7# here. Samba has a huge number of configurable options most of which
8# are not shown in this example
9#
10# Some options that are often worth tuning have been included as
11# commented-out examples in this file.
12# - When such options are commented with ";", the proposed setting
13# differs from the default Samba behaviour
14# - When commented with "#", the proposed setting is the default
15# behaviour of Samba but the option is considered important
16# enough to be mentioned here
17#
18# NOTE: Whenever you modify this file you should run the command
19# "testparm" to check that you have not made any basic syntactic
20# errors.
21
22#======================= Global Settings =======================
23
24[global]
25
26## Browsing/Identification ###
27
28# Change this to the workgroup/NT-domain name your Samba server will part of
29 workgroup = WORKGROUP
30
31# Windows Internet Name Serving Support Section:
32# WINS Support - Tells the NMBD component of Samba to enable its WINS Server
33# wins support = no
34
35# WINS Server - Tells the NMBD components of Samba to be a WINS Client
36# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
37; wins server = w.x.y.z
38
39# This will prevent nmbd to search for NetBIOS names through DNS.
40 dns proxy = no
41
42#### Networking ####
43
44# The specific set of interfaces / networks to bind to
45# This can be either the interface name or an IP address/netmask;
46# interface names are normally preferred
47; interfaces = 127.0.0.0/8 eth0
48
49# Only bind to the named interfaces and/or networks; you must use the
50# 'interfaces' option above to use this.
51# It is recommended that you enable this feature if your Samba machine is
52# not protected by a firewall or is a firewall itself. However, this
53# option cannot handle dynamic or non-broadcast interfaces correctly.
54; bind interfaces only = yes
55
56
57
58#### Debugging/Accounting ####
59
60# This tells Samba to use a separate log file for each machine
61# that connects
62 log file = /var/log/samba/log.%m
63
64# Cap the size of the individual log files (in KiB).
65 max log size = 1000
66
67# If you want Samba to only log through syslog then set the following
68# parameter to 'yes'.
69# syslog only = no
70
71# We want Samba to log a minimum amount of information to syslog. Everything
72# should go to /var/log/samba/log.{smbd,nmbd} instead. If you want to log
73# through syslog you should set the following parameter to something higher.
74 syslog = 0
75
76# Do something sensible when Samba crashes: mail the admin a backtrace
77 panic action = /usr/share/samba/panic-action %d
78
79
80####### Authentication #######
81
82# Server role. Defines in which mode Samba will operate. Possible
83# values are "standalone server", "member server", "classic primary
84# domain controller", "classic backup domain controller", "active
85# directory domain controller".
86#
87# Most people will want "standalone server" or "member server".
88# Running as "active directory domain controller" will require first
89# running "samba-tool domain provision" to wipe databases and create a
90# new domain.
91 server role = standalone server
92
93# If you are using encrypted passwords, Samba will need to know what
94# password database type you are using.
95 passdb backend = tdbsam
96
97 obey pam restrictions = yes
98
99# This boolean parameter controls whether Samba attempts to sync the Unix
100# password with the SMB password when the encrypted SMB password in the
101# passdb is changed.
102 unix password sync = yes
103
104# For Unix password sync to work on a Debian GNU/Linux system, the following
105# parameters must be set (thanks to Ian Kahan <<kahan@informatik.tu-muenchen.de> for
106# sending the correct chat script for the passwd program in Debian Sarge).
107 passwd program = /usr/bin/passwd %u
108 passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
109
110# This boolean controls whether PAM will be used for password changes
111# when requested by an SMB client instead of the program listed in
112# 'passwd program'. The default is 'no'.
113 pam password change = yes
114
115# This option controls how unsuccessful authentication attempts are mapped
116# to anonymous connections
117 map to guest = bad user
118
119########## Domains ###########
120
121#
122# The following settings only takes effect if 'server role = primary
123# classic domain controller', 'server role = backup domain controller'
124# or 'domain logons' is set
125#
126
127# It specifies the location of the user's
128# profile directory from the client point of view) The following
129# required a [profiles] share to be setup on the samba server (see
130# below)
131; logon path = \\%N\profiles\%U
132# Another common choice is storing the profile in the user's home directory
133# (this is Samba's default)
134# logon path = \\%N\%U\profile
135
136# The following setting only takes effect if 'domain logons' is set
137# It specifies the location of a user's home directory (from the client
138# point of view)
139; logon drive = H:
140# logon home = \\%N\%U
141
142# The following setting only takes effect if 'domain logons' is set
143# It specifies the script to run during logon. The script must be stored
144# in the [netlogon] share
145# NOTE: Must be store in 'DOS' file format convention
146; logon script = logon.cmd
147
148# This allows Unix users to be created on the domain controller via the SAMR
149# RPC pipe. The example command creates a user account with a disabled Unix
150# password; please adapt to your needs
151; add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u
152
153# This allows machine accounts to be created on the domain controller via the
154# SAMR RPC pipe.
155# The following assumes a "machines" group exists on the system
156; add machine script = /usr/sbin/useradd -g machines -c "%u machine account" -d /var/lib/samba -s /bin/false %u
157
158# This allows Unix groups to be created on the domain controller via the SAMR
159# RPC pipe.
160; add group script = /usr/sbin/addgroup --force-badname %g
161
162############ Misc ############
163
164# Using the following line enables you to customise your configuration
165# on a per machine basis. The %m gets replaced with the netbios name
166# of the machine that is connecting
167; include = /home/samba/etc/smb.conf.%m
168
169# Some defaults for winbind (make sure you're not using the ranges
170# for something else.)
171; idmap uid = 10000-20000
172; idmap gid = 10000-20000
173; template shell = /bin/bash
174
175# Setup usershare options to enable non-root users to share folders
176# with the net usershare command.
177
178# Maximum number of usershare. 0 (default) means that usershare is disabled.
179; usershare max shares = 100
180
181# Allow users who've been granted usershare privileges to create
182# public shares, not just authenticated ones
183 usershare allow guests = yes
184
185#======================= Share Definitions =======================
186
187[homes]
188 comment = Home Directories
189 browseable = no
190
191# By default, the home directories are exported read-only. Change the
192# next parameter to 'no' if you want to be able to write to them.
193 read only = yes
194
195# File creation mask is set to 0700 for security reasons. If you want to
196# create files with group=rw permissions, set next parameter to 0775.
197 create mask = 0700
198
199# Directory creation mask is set to 0700 for security reasons. If you want to
200# create dirs. with group=rw permissions, set next parameter to 0775.
201 directory mask = 0700
202
203# By default, \\server\username shares can be connected to by anyone
204# with access to the samba server.
205# The following parameter makes sure that only "username" can connect
206# to \\server\username
207# This might need tweaking when using external authentication schemes
208 valid users = %S
209
210# Un-comment the following and create the netlogon directory for Domain Logons
211# (you need to configure Samba to act as a domain controller too.)
212;[netlogon]
213; comment = Network Logon Service
214; path = /home/samba/netlogon
215; guest ok = yes
216; read only = yes
217
218# Un-comment the following and create the profiles directory to store
219# users profiles (see the "logon path" option above)
220# (you need to configure Samba to act as a domain controller too.)
221# The path below should be writable by all users so that their
222# profile directory may be created the first time they log on
223;[profiles]
224; comment = Users profiles
225; path = /home/samba/profiles
226; guest ok = no
227; browseable = no
228; create mask = 0600
229; directory mask = 0700
230
231[printers]
232 comment = All Printers
233 browseable = no
234 path = /var/spool/samba
235 printable = yes
236 guest ok = no
237 read only = yes
238 create mask = 0700
239
240# Windows clients look for this share name as a source of downloadable
241# printer drivers
242[print$]
243 comment = Printer Drivers
244 path = /var/lib/samba/printers
245 browseable = yes
246 read only = yes
247 guest ok = no
248# Uncomment to allow remote administration of Windows print drivers.
249# You may need to replace 'lpadmin' with the name of the group your
250# admin users are members of.
251# Please note that you also need to set appropriate Unix permissions
252# to the drivers directory for these users to have write rights in it
253; write list = root, @lpadmin
254
diff --git a/meta-networking/recipes-connectivity/samba/samba/smb_conf-4.7.0.patch b/meta-networking/recipes-connectivity/samba/samba/smb_conf-4.7.0.patch
index 77c8b3626..6ae292835 100644
--- a/meta-networking/recipes-connectivity/samba/samba/smb_conf-4.7.0.patch
+++ b/meta-networking/recipes-connectivity/samba/samba/smb_conf-4.7.0.patch
@@ -1,4 +1,7 @@
1samba: correct log files location 1From f99b6a8617df6a46f41fb68ffafb2608dbb6681e Mon Sep 17 00:00:00 2001
2From: Joe Slater <joe.slater@windriver.com>
3Date: Wed, 8 Nov 2017 11:58:05 -0800
4Subject: [PATCH] samba: correct log files location
2 5
3We use /var/log/samba. 6We use /var/log/samba.
4 7
@@ -6,9 +9,15 @@ Upstream-Status: Pending
6 9
7Signed-off-by: Joe Slater <joe.slater@windriver.com> 10Signed-off-by: Joe Slater <joe.slater@windriver.com>
8 11
9--- a/packaging/RHEL/setup/smb.conf 12---
10+++ b/packaging/RHEL/setup/smb.conf 13 examples/smb.conf.default | 2 +-
11@@ -63,7 +63,7 @@ 14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/examples/smb.conf.default b/examples/smb.conf.default
17index 2f20720..44c1aa8 100644
18--- a/examples/smb.conf.default
19+++ b/examples/smb.conf.default
20@@ -52,7 +52,7 @@
12 21
13 # this tells Samba to use a separate log file for each machine 22 # this tells Samba to use a separate log file for each machine
14 # that connects 23 # that connects
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.7.8.bb b/meta-networking/recipes-connectivity/samba/samba_4.8.3.bb
index fc1a2e0fd..d244e61f6 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.7.8.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.8.3.bb
@@ -13,33 +13,33 @@ ${SAMBA_MIRROR} http://www.mirrorservice.org/sites/ftp.samba.org \n \
13" 13"
14 14
15SRC_URI = "${SAMBA_MIRROR}/stable/samba-${PV}.tar.gz \ 15SRC_URI = "${SAMBA_MIRROR}/stable/samba-${PV}.tar.gz \
16 file://smb.conf \
16 file://16-do-not-check-xsltproc-manpages.patch \ 17 file://16-do-not-check-xsltproc-manpages.patch \
17 file://20-do-not-import-target-module-while-cross-compile.patch \ 18 file://20-do-not-import-target-module-while-cross-compile.patch \
18 file://21-add-config-option-without-valgrind.patch \ 19 file://21-add-config-option-without-valgrind.patch \
19 file://0001-packaging-Avoid-timeout-for-nmbd-if-started-offline-.patch \
20 file://0006-avoid-using-colon-in-the-checking-msg.patch \
21 file://netdb_defines.patch \ 20 file://netdb_defines.patch \
22 file://glibc_only.patch \ 21 file://glibc_only.patch \
23 file://iconv-4.7.0.patch \ 22 file://iconv-4.7.0.patch \
24 file://dnsserver-4.7.0.patch \ 23 file://dnsserver-4.7.0.patch \
25 file://smb_conf-4.7.0.patch \ 24 file://smb_conf-4.7.0.patch \
26 file://volatiles.03_samba \ 25 file://volatiles.03_samba \
27 " 26 file://0001-ldb-Refuse-to-build-Samba-against-a-newer-minor-vers.patch \
27 "
28SRC_URI_append_libc-musl = " \ 28SRC_URI_append_libc-musl = " \
29 file://samba-pam.patch \ 29 file://samba-pam.patch \
30 file://samba-4.3.9-remove-getpwent_r.patch \ 30 file://samba-4.3.9-remove-getpwent_r.patch \
31 " 31 "
32 32
33SRC_URI[md5sum] = "16b70fda54cf84521ed976a0856430cc" 33SRC_URI[md5sum] = "67f271ed6b793c2acfe014b5b8f0cca8"
34SRC_URI[sha256sum] = "ca6fca9d7e248bcaa55c54bdcc115eeed10660074da5c54a2b78dd3cccc604de" 34SRC_URI[sha256sum] = "e0569a8a605d5dfb49f1fdd11db796f4d36fe0351c4a7f21387ef253010b82ed"
35 35
36UPSTREAM_CHECK_REGEX = "samba\-(?P<pver>4\.7(\.\d+)+).tar.gz" 36UPSTREAM_CHECK_REGEX = "samba\-(?P<pver>4\.8(\.\d+)+).tar.gz"
37 37
38inherit systemd waf-samba cpan-base perlnative update-rc.d 38inherit systemd waf-samba cpan-base perlnative update-rc.d
39# remove default added RDEPENDS on perl 39# remove default added RDEPENDS on perl
40RDEPENDS_${PN}_remove = "perl" 40RDEPENDS_${PN}_remove = "perl"
41 41
42DEPENDS += "readline virtual/libiconv zlib popt libtalloc libtdb libtevent libldb libbsd libaio libpam" 42DEPENDS += "readline virtual/libiconv zlib popt libtalloc libtdb libtevent libbsd libaio libpam"
43 43
44inherit distro_features_check 44inherit distro_features_check
45REQUIRED_DISTRO_FEATURES = "pam" 45REQUIRED_DISTRO_FEATURES = "pam"
@@ -104,7 +104,7 @@ SAMBA4_MODULES="${SAMBA4_IDMAP_MODULES},${SAMBA4_PDB_MODULES},${SAMBA4_AUTH_MODU
104# .so files so there will not be a conflict. This is not done consistantly, so be very careful 104# .so files so there will not be a conflict. This is not done consistantly, so be very careful
105# when adding to this list. 105# when adding to this list.
106# 106#
107SAMBA4_LIBS="heimdal,cmocka,NONE" 107SAMBA4_LIBS="heimdal,cmocka,ldb,pyldb-util,NONE"
108 108
109EXTRA_OECONF += "--enable-fhs \ 109EXTRA_OECONF += "--enable-fhs \
110 --with-piddir=/run \ 110 --with-piddir=/run \
@@ -135,7 +135,7 @@ do_install_append() {
135 done 135 done
136 136
137 install -d ${D}${systemd_system_unitdir} 137 install -d ${D}${systemd_system_unitdir}
138 install -m 0644 packaging/systemd/*.service ${D}${systemd_system_unitdir} 138 install -m 0644 ${S}/bin/default/packaging/systemd/*.service ${D}${systemd_system_unitdir}/
139 sed -e 's,\(ExecReload=\).*\(/kill\),\1${base_bindir}\2,' \ 139 sed -e 's,\(ExecReload=\).*\(/kill\),\1${base_bindir}\2,' \
140 -e 's,/etc/sysconfig/samba,${sysconfdir}/default/samba,' \ 140 -e 's,/etc/sysconfig/samba,${sysconfdir}/default/samba,' \
141 -i ${D}${systemd_system_unitdir}/*.service 141 -i ${D}${systemd_system_unitdir}/*.service
@@ -159,7 +159,7 @@ do_install_append() {
159 159
160 install -d ${D}${sysconfdir}/samba 160 install -d ${D}${sysconfdir}/samba
161 echo "127.0.0.1 localhost" > ${D}${sysconfdir}/samba/lmhosts 161 echo "127.0.0.1 localhost" > ${D}${sysconfdir}/samba/lmhosts
162 install -m644 packaging/RHEL/setup/smb.conf ${D}${sysconfdir}/samba/smb.conf 162 install -m644 ${WORKDIR}/smb.conf ${D}${sysconfdir}/samba/smb.conf
163 install -D -m 644 ${WORKDIR}/volatiles.03_samba ${D}${sysconfdir}/default/volatiles/03_samba 163 install -D -m 644 ${WORKDIR}/volatiles.03_samba ${D}${sysconfdir}/default/volatiles/03_samba
164 164
165 install -d ${D}${sysconfdir}/default 165 install -d ${D}${sysconfdir}/default
@@ -268,6 +268,7 @@ FILES_winbind = "${sbindir}/winbindd \
268 ${libdir}/samba/idmap \ 268 ${libdir}/samba/idmap \
269 ${libdir}/samba/nss_info \ 269 ${libdir}/samba/nss_info \
270 ${libdir}/winbind_krb5_locator.so \ 270 ${libdir}/winbind_krb5_locator.so \
271 ${libdir}/winbind-krb5-localauth.so \
271 ${sysconfdir}/init.d/winbind \ 272 ${sysconfdir}/init.d/winbind \
272 ${systemd_system_unitdir}/winbind.service" 273 ${systemd_system_unitdir}/winbind.service"
273 274