diff options
author | Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> | 2019-08-08 19:24:13 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-08-09 08:09:28 -0700 |
commit | 7de19639d04799b20b6f440787a8f9f747066330 (patch) | |
tree | 7f650e67171915f4a2d8d8b5472755483b012023 | |
parent | 9472d02c7c29bf4b9ca3bb20dc2cf1940ee80aeb (diff) | |
download | meta-openembedded-7de19639d04799b20b6f440787a8f9f747066330.tar.gz |
dnf-plugin-tui: new recipe
This dnf plugin aims to supply a tui interface for user to manage
packages. It has features as following:
1. Add new command dnf tui --init to make dnf work on host.
2. Text-based user interface for dnf.
3. Manage SPDX files.
4. Manage SRPM files.
5. Add installation samples for dnf.
More details please refer to https://github.com/ubinux/dnf-plugin-tui.
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-devtools/dnf-plugin-tui/dnf-plugin-tui_git.bb | 38 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/dnf-plugin-tui/files/oe-remote.repo.sample | 5 |
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/dnf-plugin-tui/dnf-plugin-tui_git.bb b/meta-oe/recipes-devtools/dnf-plugin-tui/dnf-plugin-tui_git.bb new file mode 100644 index 000000000..e891868cd --- /dev/null +++ b/meta-oe/recipes-devtools/dnf-plugin-tui/dnf-plugin-tui_git.bb | |||
@@ -0,0 +1,38 @@ | |||
1 | SUMMARY = "A text-based user interface plugin of dnf for user to manage packages. " | ||
2 | LICENSE = "GPLv2" | ||
3 | |||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
5 | |||
6 | SRC_URI = "git://github.com/ubinux/dnf-plugin-tui.git;branch=master " | ||
7 | SRCREV = "31d6866d5eda02be9a6bfb1fca9e9095b12eecd1" | ||
8 | PV = "1.0" | ||
9 | |||
10 | SRC_URI_append_class-target = "file://oe-remote.repo.sample" | ||
11 | |||
12 | inherit distutils3-base | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | do_install_append() { | ||
17 | install -d ${D}${datadir}/dnf | ||
18 | install -m 0755 ${S}/samples/* ${D}${datadir}/dnf | ||
19 | install -d ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins/mkimg | ||
20 | install -m 0755 ${S}/dnf-plugins/mkimg/* ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins/mkimg | ||
21 | for file in $(ls ${S}/dnf-plugins/ | grep -v mkimg); do | ||
22 | install -m 0755 ${S}/dnf-plugins/$file ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins | ||
23 | done | ||
24 | } | ||
25 | |||
26 | do_install_append_class-target() { | ||
27 | install -d ${D}${sysconfdir}/yum.repos.d | ||
28 | install -m 0644 ${WORKDIR}/oe-remote.repo.sample ${D}${sysconfdir}/yum.repos.d | ||
29 | } | ||
30 | |||
31 | FILES_${PN} += "${datadir}/dnf" | ||
32 | |||
33 | RDEPENDS_${PN} += " \ | ||
34 | dnf \ | ||
35 | libnewt-python \ | ||
36 | " | ||
37 | |||
38 | BBCLASSEXTEND = "nativesdk" | ||
diff --git a/meta-oe/recipes-devtools/dnf-plugin-tui/files/oe-remote.repo.sample b/meta-oe/recipes-devtools/dnf-plugin-tui/files/oe-remote.repo.sample new file mode 100644 index 000000000..6c4502e17 --- /dev/null +++ b/meta-oe/recipes-devtools/dnf-plugin-tui/files/oe-remote.repo.sample | |||
@@ -0,0 +1,5 @@ | |||
1 | [base] | ||
2 | name=myrepo | ||
3 | baseurl=http://127.0.0.1/oe_repo/ | ||
4 | enabled=1 | ||
5 | gpgcheck=0 | ||