diff options
author | Derek Straka <derek@asterius.io> | 2017-02-08 18:04:20 -0500 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-02-13 18:43:34 +0100 |
commit | 773200a1858e27b3b918072fe22406dc4407687d (patch) | |
tree | 1ac98d1bc4a05fdad4a72308c5a00000a842eb91 | |
parent | 4d5e97e8b4c51409cfce66cf0721c7f8e2377a72 (diff) | |
download | meta-openembedded-773200a1858e27b3b918072fe22406dc4407687d.tar.gz |
python-sqlalchemy: update to version 1.1.5
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python-sqlalchemy.inc | 14 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-sqlalchemy_1.1.5.bb (renamed from meta-python/recipes-devtools/python/python-sqlalchemy_1.1.4.bb) | 0 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.4.bb | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.5.bb | 5 |
4 files changed, 15 insertions, 6 deletions
diff --git a/meta-python/recipes-devtools/python/python-sqlalchemy.inc b/meta-python/recipes-devtools/python/python-sqlalchemy.inc index 471c109f9..ec6433e65 100644 --- a/meta-python/recipes-devtools/python/python-sqlalchemy.inc +++ b/meta-python/recipes-devtools/python/python-sqlalchemy.inc | |||
@@ -2,12 +2,18 @@ DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \ | |||
2 | application developers the full power and flexibility of SQL" | 2 | application developers the full power and flexibility of SQL" |
3 | HOMEPAGE = "http://www.sqlalchemy.org/" | 3 | HOMEPAGE = "http://www.sqlalchemy.org/" |
4 | LICENSE = "MIT" | 4 | LICENSE = "MIT" |
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d7dba1721bc8ce05d421f7279cb87971" | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=452f4b8adb0feba42e5be5f1fbfbf538" |
6 | 6 | ||
7 | PYPI_PACKAGE = "SQLAlchemy" | 7 | PYPI_PACKAGE = "SQLAlchemy" |
8 | inherit pypi | 8 | inherit pypi |
9 | 9 | ||
10 | SRC_URI[md5sum] = "be5af1bebe595206b71b513a14836e4f" | 10 | SRC_URI[md5sum] = "50685d97dca4b91945ae6309d03ab8c9" |
11 | SRC_URI[sha256sum] = "701b57d628b9fa1cfb82f10665e7214d5d2db23251ca6f23b91c5f56fcdbdeb5" | 11 | SRC_URI[sha256sum] = "68fb40049690e567ebda7b270176f5abf0d53d9fbd515fec4e43326f601119b6" |
12 | 12 | ||
13 | RDEPENDS_${PN} += "${PYTHON_PN}-numbers" | 13 | RDEPENDS_${PN} += " \ |
14 | ${PYTHON_PN}-json \ | ||
15 | ${PYTHON_PN}-pickle \ | ||
16 | ${PYTHON_PN}-netclient \ | ||
17 | ${PYTHON_PN}-numbers \ | ||
18 | ${PYTHON_PN}-threading \ | ||
19 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-sqlalchemy_1.1.4.bb b/meta-python/recipes-devtools/python/python-sqlalchemy_1.1.5.bb index 53c8fecf7..53c8fecf7 100644 --- a/meta-python/recipes-devtools/python/python-sqlalchemy_1.1.4.bb +++ b/meta-python/recipes-devtools/python/python-sqlalchemy_1.1.5.bb | |||
diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.4.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.4.bb deleted file mode 100644 index 86cf9edde..000000000 --- a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.4.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-sqlalchemy.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.5.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.5.bb new file mode 100644 index 000000000..01f1e97ec --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.5.bb | |||
@@ -0,0 +1,5 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-sqlalchemy.inc | ||
3 | |||
4 | # Requires _pydecimal.py which is in misc | ||
5 | RDEPENDS_${PN} += "${PYTHON_PN}-enum ${PYTHON_PN}-misc" | ||