diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2014-05-06 00:08:45 -0300 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-05-09 14:57:58 +0200 |
commit | 6d81b79fd1b0b76df2b5be1b80b871c798db647c (patch) | |
tree | 75809ce4e940fd45368960c0c3d39786b9d19a0a | |
parent | 1162d9d1b5bd1893e1d8f725b636dc2639183c9f (diff) | |
download | meta-openembedded-6d81b79fd1b0b76df2b5be1b80b871c798db647c.tar.gz |
v4l-utils: Update to 1.0.1
This updates to last stable release and, as a plus, fix an out of tree
build failure.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
3 files changed, 26 insertions, 77 deletions
diff --git a/meta-oe/recipes-multimedia/v4l2apps/files/openat.patch b/meta-oe/recipes-multimedia/v4l2apps/files/openat.patch deleted file mode 100644 index 6cbd528d4..000000000 --- a/meta-oe/recipes-multimedia/v4l2apps/files/openat.patch +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | From ac8eb4d8e1c16b907e795da123a032869c77c56f Mon Sep 17 00:00:00 2001 | ||
2 | From: Riku Voipio <riku.voipio@linaro.org> | ||
3 | Date: Tue, 22 Jan 2013 12:44:48 +0200 | ||
4 | Subject: [PATCH] libv4lsyscall-priv.h: use openat when available | ||
5 | |||
6 | New architectures such as 64-Bit arm build kernels without legacy | ||
7 | system calls - Such as the the no-at system calls. Thus, use | ||
8 | SYS_openat whenever it is available. | ||
9 | |||
10 | Signed-off-by: Riku Voipio <riku.voipio@linaro.org> | ||
11 | Signed-off-by: Mauro Carvalho Chehab <mchehab@redhat.com> | ||
12 | |||
13 | Upstream-status: backport | ||
14 | --- | ||
15 | lib/libv4lconvert/libv4lsyscall-priv.h | 5 +++++ | ||
16 | 1 file changed, 5 insertions(+) | ||
17 | |||
18 | diff --git a/lib/libv4lconvert/libv4lsyscall-priv.h b/lib/libv4lconvert/libv4lsyscall-priv.h | ||
19 | index 2dac49a..cdd38bc 100644 | ||
20 | --- a/lib/libv4lconvert/libv4lsyscall-priv.h | ||
21 | +++ b/lib/libv4lconvert/libv4lsyscall-priv.h | ||
22 | @@ -72,8 +72,13 @@ typedef off_t __off_t; | ||
23 | |||
24 | #ifndef CONFIG_SYS_WRAPPER | ||
25 | |||
26 | +#ifdef SYS_openat | ||
27 | +#define SYS_OPEN(file, oflag, mode) \ | ||
28 | + syscall(SYS_openat, AT_FDCWD, (const char *)(file), (int)(oflag), (mode_t)(mode)) | ||
29 | +#else | ||
30 | #define SYS_OPEN(file, oflag, mode) \ | ||
31 | syscall(SYS_open, (const char *)(file), (int)(oflag), (mode_t)(mode)) | ||
32 | +#endif | ||
33 | #define SYS_CLOSE(fd) \ | ||
34 | syscall(SYS_close, (int)(fd)) | ||
35 | #define SYS_IOCTL(fd, cmd, arg) \ | ||
36 | -- | ||
37 | 1.7.10.4 | ||
38 | |||
diff --git a/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_0.8.8.bb b/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_0.8.8.bb deleted file mode 100644 index 485a4162d..000000000 --- a/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_0.8.8.bb +++ /dev/null | |||
@@ -1,39 +0,0 @@ | |||
1 | SUMMARY = "v4l2 and IR applications" | ||
2 | LICENSE = "GPLv2 & LGPLv2.1" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=48da9957849056017dc568bbc43d8975 \ | ||
4 | file://COPYING.LIB;md5=d749e86a105281d7a44c2328acebc4b0" | ||
5 | |||
6 | PR = "r2" | ||
7 | |||
8 | DEPENDS = "jpeg virtual/libx11" | ||
9 | |||
10 | inherit autotools gettext | ||
11 | |||
12 | # libv4l was absorbed into this, let OE know that | ||
13 | PROVIDES = "libv4l" | ||
14 | |||
15 | SRC_URI = "git://linuxtv.org/v4l-utils.git \ | ||
16 | file://openat.patch \ | ||
17 | " | ||
18 | # 54f16ca8183dd8ae8bf4ccc07949795aff0301f5 -> v0.8.8 tag | ||
19 | SRCREV = "0298efdcd1153b8f719b9164548a3f0546f0cb7c" | ||
20 | |||
21 | S = "${WORKDIR}/git" | ||
22 | |||
23 | EXTRA_OECONF = "--disable-qv4l2 --enable-shared --with-udevdir=${base_libdir}/udev" | ||
24 | |||
25 | do_configure() { | ||
26 | # autotools_do_configure fails with: | ||
27 | # | configure.ac:139: error: required file 'build-aux/config.rpath' not found | ||
28 | autoreconf -vfi | ||
29 | oe_runconf | ||
30 | } | ||
31 | |||
32 | PACKAGES =+ "rc-keymaps libv4l libv4l-dbg libv4l-dev" | ||
33 | |||
34 | FILES_rc-keymaps = "${sysconfdir}/rc* ${base_libdir}/udev/rc*" | ||
35 | FILES_${PN} = "${bindir} ${sbindir} ${base_libdir}/udev/rules.d/70-infrared.rules" | ||
36 | FILES_libv4l += "${libdir}/libv4l/* ${libdir}/*.so.*" | ||
37 | FILES_libv4l-dbg += "${libdir}/libv4l/.debug" | ||
38 | FILES_libv4l-dev += "${libdir}/*.so ${includedir}/lib* ${libdir}/pkgconfig/lib*" | ||
39 | |||
diff --git a/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.0.1.bb b/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.0.1.bb new file mode 100644 index 000000000..6c25c9068 --- /dev/null +++ b/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.0.1.bb | |||
@@ -0,0 +1,26 @@ | |||
1 | SUMMARY = "v4l2 and IR applications" | ||
2 | LICENSE = "GPLv2 & LGPLv2.1" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=48da9957849056017dc568bbc43d8975 \ | ||
4 | file://COPYING.libv4l;md5=d749e86a105281d7a44c2328acebc4b0" | ||
5 | |||
6 | DEPENDS = "jpeg virtual/libx11" | ||
7 | |||
8 | inherit autotools gettext | ||
9 | |||
10 | # libv4l was absorbed into this, let OE know that | ||
11 | PROVIDES = "libv4l" | ||
12 | |||
13 | SRC_URI = "http://linuxtv.org/downloads/v4l-utils/v4l-utils-${PV}.tar.bz2" | ||
14 | SRC_URI[md5sum] = "b06ea8b15e27cff352b4536e835448bc" | ||
15 | SRC_URI[sha256sum] = "fc0132e82a18dfad9619be3abf50c206e2f449b1c14440cde36f25874fdce7df" | ||
16 | |||
17 | EXTRA_OECONF = "--disable-qv4l2 --enable-shared --with-udevdir=${base_libdir}/udev" | ||
18 | |||
19 | PACKAGES =+ "rc-keymaps libv4l libv4l-dbg libv4l-dev" | ||
20 | |||
21 | FILES_rc-keymaps = "${sysconfdir}/rc* ${base_libdir}/udev/rc*" | ||
22 | FILES_${PN} = "${bindir} ${sbindir} ${base_libdir}/udev/rules.d/70-infrared.rules" | ||
23 | FILES_libv4l += "${libdir}/libv4l*${SOLIBS} ${libdir}/libv4l/*.so ${libdir}/libv4l/plugins/*.so \ | ||
24 | ${libdir}/libv4l/*-decomp" | ||
25 | FILES_libv4l-dbg += "${libdir}/libv4l/.debug ${libdir}/libv4l/plugins/.debug" | ||
26 | FILES_libv4l-dev += "${libdir}/v4l*${SOLIBSDEV} ${libdir}/libv4l/*.la ${libdir}/libv4l/plugins/*.la" | ||