diff options
author | Andrey Zhizhikin <andrey.z@gmail.com> | 2020-01-27 21:04:13 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-01-27 13:10:31 -0800 |
commit | 51bff30e032a29bfcea5b1307a8f1087f19d1ff8 (patch) | |
tree | 078937dfa81f559fcfca3cb254c77938dd372c1a | |
parent | 7cb54068b3994569b80841d685667a55823e7075 (diff) | |
download | meta-openembedded-51bff30e032a29bfcea5b1307a8f1087f19d1ff8.tar.gz |
libteam: update recipe to use python3
Update recipe to use python3 since python2 is EOL and has been dropped
from OE-Core.
Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
3 files changed, 31 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/libteam/libteam/0001-team_basic_test.py-use-python3-interpreter.patch b/meta-oe/recipes-support/libteam/libteam/0001-team_basic_test.py-use-python3-interpreter.patch new file mode 100644 index 000000000..e27e4f329 --- /dev/null +++ b/meta-oe/recipes-support/libteam/libteam/0001-team_basic_test.py-use-python3-interpreter.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From 571c141b434dff13494c6a3afe621f63a8e610e9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andrey Zhizhikin <andrey.z@gmail.com> | ||
3 | Date: Mon, 27 Jan 2020 14:29:34 +0000 | ||
4 | Subject: [PATCH] team_basic_test.py: use python3 interpreter | ||
5 | |||
6 | Use python3 since python2 is EOL and has been removed from several | ||
7 | distributions. | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | |||
11 | Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> | ||
12 | --- | ||
13 | scripts/team_basic_test.py | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/scripts/team_basic_test.py b/scripts/team_basic_test.py | ||
17 | index b05be9e..ad980e8 100755 | ||
18 | --- a/scripts/team_basic_test.py | ||
19 | +++ b/scripts/team_basic_test.py | ||
20 | @@ -1,4 +1,4 @@ | ||
21 | -#! /usr/bin/env python | ||
22 | +#! /usr/bin/env python3 | ||
23 | """ | ||
24 | Basic test. | ||
25 | |||
26 | -- | ||
27 | 2.17.1 | ||
28 | |||
diff --git a/meta-oe/recipes-support/libteam/libteam/run-ptest b/meta-oe/recipes-support/libteam/libteam/run-ptest index 4ba5acf05..b5c6f4ebb 100644 --- a/meta-oe/recipes-support/libteam/libteam/run-ptest +++ b/meta-oe/recipes-support/libteam/libteam/run-ptest | |||
@@ -1,3 +1,3 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | 2 | ||
3 | python $(dirname $0)/team_basic_test.py | 3 | python3 $(dirname $0)/team_basic_test.py |
diff --git a/meta-oe/recipes-support/libteam/libteam_1.29.bb b/meta-oe/recipes-support/libteam/libteam_1.29.bb index 821ca1938..4ccc280da 100644 --- a/meta-oe/recipes-support/libteam/libteam_1.29.bb +++ b/meta-oe/recipes-support/libteam/libteam_1.29.bb | |||
@@ -11,6 +11,7 @@ SRC_URI = "git://github.com/jpirko/libteam \ | |||
11 | file://0001-include-sys-select.h-for-fd_set-definition.patch \ | 11 | file://0001-include-sys-select.h-for-fd_set-definition.patch \ |
12 | file://0002-teamd-Re-adjust-include-header-order.patch \ | 12 | file://0002-teamd-Re-adjust-include-header-order.patch \ |
13 | file://0001-team_basic_test.py-disable-RedHat-specific-test.patch \ | 13 | file://0001-team_basic_test.py-disable-RedHat-specific-test.patch \ |
14 | file://0001-team_basic_test.py-use-python3-interpreter.patch \ | ||
14 | file://run-ptest \ | 15 | file://run-ptest \ |
15 | " | 16 | " |
16 | SRCREV = "e897f02bf2403d4859a99e090e34ea768b4c0540" | 17 | SRCREV = "e897f02bf2403d4859a99e090e34ea768b4c0540" |
@@ -32,7 +33,7 @@ FILES_${PN}-utils = "${bindir}/bond2team \ | |||
32 | " | 33 | " |
33 | 34 | ||
34 | RDEPENDS_${PN}-utils = "bash" | 35 | RDEPENDS_${PN}-utils = "bash" |
35 | RDEPENDS_${PN}-ptest = "python" | 36 | RDEPENDS_${PN}-ptest = "python3-core" |
36 | 37 | ||
37 | do_install_ptest() { | 38 | do_install_ptest() { |
38 | install ${S}/scripts/team_basic_test.py ${D}${PTEST_PATH}/ | 39 | install ${S}/scripts/team_basic_test.py ${D}${PTEST_PATH}/ |