diff options
author | Bhargava Sreekantappa Gayathri <bhargava.sreekantappa-gayathri@xilinx.com> | 2018-02-20 16:07:23 -0800 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-03-01 16:12:55 -0800 |
commit | 3e0ec54b8cfe994a0c5a23780fa036d851cd90a4 (patch) | |
tree | 6e3aa0cfd75bc3f0a0ccfa3d82d3f54e9fa80c5d | |
parent | 00909ae7322dac4ddd0a28b21df29191cc53f6d9 (diff) | |
download | meta-openembedded-3e0ec54b8cfe994a0c5a23780fa036d851cd90a4.tar.gz |
] python-oauthlib: Add python-oauthlib and python3-oauthlib.
This patch adds python-oauthlib and python3-oauthlib.
Signed-off-by: Bhargava Sreekantappa Gayathri <bhargava.sreekantappa-gayathri@xilinx.com>
Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com>
Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandr@xilinx.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
3 files changed, 31 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-oauthlib.inc b/meta-python/recipes-devtools/python/python-oauthlib.inc new file mode 100644 index 000000000..c5de8a091 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-oauthlib.inc | |||
@@ -0,0 +1,25 @@ | |||
1 | SUMMARY = "A generic, spec-compliant, thorough implementation of the OAuth request-signing logic" | ||
2 | HOMEPAGE = "https://github.com/idan/oauthlib" | ||
3 | |||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5ba9ce41463615e082609806255bce1b" | ||
6 | |||
7 | SRC_URI = "https://pypi.python.org/packages/a5/8a/212e9b47fb54be109f3ff0684165bb38c51117f34e175c379fce5c7df754/oauthlib-${PV}.tar.gz" | ||
8 | SRC_URI[md5sum] = "277a9a966cc8c72e492b4eeb41332445" | ||
9 | SRC_URI[sha256sum] = "ce57b501e906ff4f614e71c36a3ab9eacbb96d35c24d1970d2539bbc3ec70ce1" | ||
10 | |||
11 | S = "${WORKDIR}/oauthlib-${PV}" | ||
12 | |||
13 | # The following configs & dependencies are from setuptools extras_require. | ||
14 | # These dependencies are optional, hence can be controlled via PACKAGECONFIG. | ||
15 | # The upstream names may not correspond exactly to bitbake package names. | ||
16 | # | ||
17 | # Uncomment this line to enable all the optional features. | ||
18 | #PACKAGECONFIG ?= "test signedtoken signals rsa" | ||
19 | PACKAGECONFIG[test] = ",,,${PYTHON_PN}-blinker ${PYTHON_PN}-cryptography ${PYTHON_PN}-nose ${PYTHON_PN}-pyjwt" | ||
20 | PACKAGECONFIG[signedtoken] = ",,,${PYTHON_PN}-cryptography ${PYTHON_PN}-pyjwt" | ||
21 | PACKAGECONFIG[signals] = ",,,${PYTHON_PN}-blinker" | ||
22 | PACKAGECONFIG[rsa] = ",,,${PYTHON_PN}-cryptography" | ||
23 | |||
24 | RDEPENDS_${PN} += "${PYTHON_PN}-core ${PYTHON_PN}-crypt ${PYTHON_PN}-datetime ${PYTHON_PN}-json ${PYTHON_PN}-logging ${PYTHON_PN}-math ${PYTHON_PN}-netclient ${PYTHON_PN}-unittest" | ||
25 | |||
diff --git a/meta-python/recipes-devtools/python/python-oauthlib_2.0.6.bb b/meta-python/recipes-devtools/python/python-oauthlib_2.0.6.bb new file mode 100644 index 000000000..4329d21a1 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-oauthlib_2.0.6.bb | |||
@@ -0,0 +1,4 @@ | |||
1 | inherit setuptools | ||
2 | require python-oauthlib.inc | ||
3 | |||
4 | RDEPENDS_${PN} += "${PYTHON_PN}-re ${PYTHON_PN}-lang" | ||
diff --git a/meta-python/recipes-devtools/python/python3-oauthlib_2.0.6.bb b/meta-python/recipes-devtools/python/python3-oauthlib_2.0.6.bb new file mode 100644 index 000000000..da13b55d8 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-oauthlib_2.0.6.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-oauthlib.inc | ||