diff options
author | Jackie Huang <jackie.huang@windriver.com> | 2017-07-24 14:49:22 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-08-13 13:19:00 +0200 |
commit | 369b9f4421971a3feb496b63a3ce1d35363e860c (patch) | |
tree | 0c3b7fe14794f851317debe72113b9a0d01c2185 | |
parent | 3ec1e79aa06341df462aefad05fccb048c79d8cc (diff) | |
download | meta-openembedded-369b9f4421971a3feb496b63a3ce1d35363e860c.tar.gz |
pam-ssh-agent-auth: add new recipe
A PAM module which permits authentication via ssh-agent.
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb | 46 |
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb b/meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb new file mode 100644 index 000000000..42b648e8b --- /dev/null +++ b/meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb | |||
@@ -0,0 +1,46 @@ | |||
1 | SUMMARY = "pam-ssh-agent-auth" | ||
2 | DESCRIPTION = "A PAM module which permits authentication via ssh-agent." | ||
3 | HOMEPAGE = "http://sourceforge.net/projects/pamsshagentauth/" | ||
4 | SECTION = "libs" | ||
5 | LICENSE = "openssl & BSD" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE.OpenSSL;md5=8ab01146141ded59b75f8ba7811ed05a \ | ||
7 | file://OPENSSH_LICENSE;md5=7ae09218173be1643c998a4b71027f9b \ | ||
8 | " | ||
9 | |||
10 | SRC_URI = "http://sourceforge.net/projects/pamsshagentauth/files/pam_ssh_agent_auth/v${PV}/pam_ssh_agent_auth-${PV}.tar.bz2" | ||
11 | SRC_URI[md5sum] = "8dbe90ab3625e545036333e6f51ccf1d" | ||
12 | SRC_URI[sha256sum] = "3c53d358d6eaed1b211239df017c27c6f9970995d14102ae67bae16d4f47a763" | ||
13 | |||
14 | DEPENDS += "libpam openssl" | ||
15 | |||
16 | # This gets us ssh-agent, which we are almost certain to want. | ||
17 | # | ||
18 | RDEPENDS_${PN} += "openssh-misc" | ||
19 | |||
20 | # Kind of unfortunate to have underscores in the name. | ||
21 | # | ||
22 | S = "${WORKDIR}/pam_ssh_agent_auth-${PV}" | ||
23 | |||
24 | inherit autotools-brokensep | ||
25 | |||
26 | # Avoid autoreconf. Override the --libexec oe_runconf specifies so that | ||
27 | # the module is put with the other pam modules. Because it cannot, in general, | ||
28 | # do a runtime test, configure wants to use rpl_malloc() and rpl_realloc() | ||
29 | # instead of malloc() and realloc(). We set variables to tell it not to because | ||
30 | # these functions do not exist. | ||
31 | # | ||
32 | do_configure () { | ||
33 | oe_runconf --without-openssl-header-check --libexecdir=${base_libdir}/security \ | ||
34 | ac_cv_func_malloc_0_nonnull=yes ac_cv_func_realloc_0_nonnull=yes | ||
35 | } | ||
36 | |||
37 | # Link with CC. Configure cannot figure out the correct AR. | ||
38 | # | ||
39 | do_compile () { | ||
40 | oe_runmake LD="${CC}" AR="${AR}" | ||
41 | } | ||
42 | |||
43 | # This stuff is not any place looked at by default. | ||
44 | # | ||
45 | FILES_${PN} += "${base_libdir}/security/pam*" | ||
46 | FILES_${PN}-dbg += "${base_libdir}/security/.debug" | ||