diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2012-06-10 21:46:50 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-07-16 09:39:06 +0200 |
commit | 365d5ec941347f54744b9f5fbb7b06cc3949e14a (patch) | |
tree | 322e21d7d6a98669598f40d51f89e4d8e048c273 | |
parent | a55a93180733f769d676d9e66f74bf10d5da6ff0 (diff) | |
download | meta-openembedded-365d5ec941347f54744b9f5fbb7b06cc3949e14a.tar.gz |
gateone: move systemd support to meta-systemd
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
-rw-r--r-- | meta-oe/recipes-connectivity/gateone/gateone_git.bb | 9 | ||||
-rw-r--r-- | meta-systemd/meta-oe/recipes-connectivity/gateone/gateone/gateone.service (renamed from meta-oe/recipes-connectivity/gateone/gateone/gateone.service) | 0 | ||||
-rw-r--r-- | meta-systemd/meta-oe/recipes-connectivity/gateone/gateone_git.bbappend | 11 |
3 files changed, 13 insertions, 7 deletions
diff --git a/meta-oe/recipes-connectivity/gateone/gateone_git.bb b/meta-oe/recipes-connectivity/gateone/gateone_git.bb index 12f4e5107..f6aa3776d 100644 --- a/meta-oe/recipes-connectivity/gateone/gateone_git.bb +++ b/meta-oe/recipes-connectivity/gateone/gateone_git.bb | |||
@@ -2,19 +2,18 @@ DESCRIPTION = "HTML5 (plugin-free) web-based terminal emulator and SSH client" | |||
2 | LICENSE = "AGPLv3" | 2 | LICENSE = "AGPLv3" |
3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ee5b168fc7de89a0cadc49e27830aa2c" | 3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ee5b168fc7de89a0cadc49e27830aa2c" |
4 | 4 | ||
5 | PR = "r7" | 5 | PR = "r8" |
6 | 6 | ||
7 | PV = "1.1" | 7 | PV = "1.1" |
8 | SRCREV = "bb74e1095adb66b04b51ed6ff10ae0aa96afdd46" | 8 | SRCREV = "bb74e1095adb66b04b51ed6ff10ae0aa96afdd46" |
9 | SRC_URI = "git://github.com/liftoff/GateOne.git \ | 9 | SRC_URI = "git://github.com/liftoff/GateOne.git \ |
10 | file://gateone-avahi.service \ | 10 | file://gateone-avahi.service \ |
11 | file://gateone.service \ | ||
12 | file://server.conf \ | 11 | file://server.conf \ |
13 | " | 12 | " |
14 | 13 | ||
15 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
16 | 15 | ||
17 | inherit distutils allarch systemd | 16 | inherit distutils allarch |
18 | 17 | ||
19 | export prefix = "${localstatedir}/lib" | 18 | export prefix = "${localstatedir}/lib" |
20 | 19 | ||
@@ -27,10 +26,6 @@ do_install_append() { | |||
27 | install -m 0644 ${WORKDIR}/server.conf ${D}/var/lib/gateone/server.conf | 26 | install -m 0644 ${WORKDIR}/server.conf ${D}/var/lib/gateone/server.conf |
28 | } | 27 | } |
29 | 28 | ||
30 | NATIVE_SYSTEMD_SUPPORT = "1" | ||
31 | SYSTEMD_PACKAGES = "${PN}" | ||
32 | SYSTEMD_SERVICE = "gateone.service" | ||
33 | |||
34 | FILES_${PN} = "${localstatedir}/lib ${localstatedir}/log ${base_libdir} ${sysconfdir}" | 29 | FILES_${PN} = "${localstatedir}/lib ${localstatedir}/log ${base_libdir} ${sysconfdir}" |
35 | RDEPENDS_${PN} = "file \ | 30 | RDEPENDS_${PN} = "file \ |
36 | mime-support \ | 31 | mime-support \ |
diff --git a/meta-oe/recipes-connectivity/gateone/gateone/gateone.service b/meta-systemd/meta-oe/recipes-connectivity/gateone/gateone/gateone.service index 7ff60020a..7ff60020a 100644 --- a/meta-oe/recipes-connectivity/gateone/gateone/gateone.service +++ b/meta-systemd/meta-oe/recipes-connectivity/gateone/gateone/gateone.service | |||
diff --git a/meta-systemd/meta-oe/recipes-connectivity/gateone/gateone_git.bbappend b/meta-systemd/meta-oe/recipes-connectivity/gateone/gateone_git.bbappend new file mode 100644 index 000000000..dd5fea1a9 --- /dev/null +++ b/meta-systemd/meta-oe/recipes-connectivity/gateone/gateone_git.bbappend | |||
@@ -0,0 +1,11 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | PRINC := "${@int(PRINC) + 1}" | ||
4 | |||
5 | inherit systemd | ||
6 | |||
7 | SRC_URI += "file://gateone.service" | ||
8 | |||
9 | NATIVE_SYSTEMD_SUPPORT = "1" | ||
10 | SYSTEMD_PACKAGES = "${PN}" | ||
11 | SYSTEMD_SERVICE = "gateone.service" | ||