diff options
author | Qi.Chen@windriver.com <Qi.Chen@windriver.com> | 2017-12-26 13:50:46 +0800 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2017-12-30 12:32:49 -0800 |
commit | 303fd6d589250c4a2ef23342d639348464e1a593 (patch) | |
tree | b3f08454d0d7cae775ea7b57345f7c88f45effe1 | |
parent | e170ac2818e6c031b09d21a7f459d6b1c1ade245 (diff) | |
download | meta-openembedded-303fd6d589250c4a2ef23342d639348464e1a593.tar.gz |
hwloc: fix multilib problem
Use libhwloc instead of lib${PN} to fix problem in case of multilib.
Otherwise, when installing lib32-hwloc into image, we would have the
following error at do_rootfs.
- nothing provides lib32-liblib32-hwloc = 1.11.5-r0 needed by lib32-hwloc-1.11.5-r0.corei7_32
Also, fix FILES variable for libhwloc to not contain .so link file.
This would fix the QA issue, and the INSANE_SKIP line is no longer needed.
Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r-- | meta-oe/recipes-extended/hwloc/hwloc_1.11.5.bb | 9 |
1 files changed, 3 insertions, 6 deletions
diff --git a/meta-oe/recipes-extended/hwloc/hwloc_1.11.5.bb b/meta-oe/recipes-extended/hwloc/hwloc_1.11.5.bb index d7fdd823c..5a335b924 100644 --- a/meta-oe/recipes-extended/hwloc/hwloc_1.11.5.bb +++ b/meta-oe/recipes-extended/hwloc/hwloc_1.11.5.bb | |||
@@ -24,9 +24,6 @@ PACKAGECONFIG[x11] = "--with-x,--without-x,virtual/libx11 cairo,cairo" | |||
24 | PACKAGECONFIG[pci] = "--enable-pci,--disable-pci,libpciaccess,libpciaccess" | 24 | PACKAGECONFIG[pci] = "--enable-pci,--disable-pci,libpciaccess,libpciaccess" |
25 | 25 | ||
26 | # Split hwloc library into separate subpackage | 26 | # Split hwloc library into separate subpackage |
27 | PACKAGES_prepend = " lib${PN} " | 27 | PACKAGES_prepend = " libhwloc " |
28 | FILES_lib${PN} += "${libdir}/lib${PN}.so*" | 28 | FILES_libhwloc += "${libdir}/libhwloc.so.*" |
29 | RDEPENDS_${PN} += "lib${PN} (= ${EXTENDPKGV})" | 29 | RDEPENDS_${PN} += "libhwloc (= ${EXTENDPKGV})" |
30 | |||
31 | # XXX dev-so QA check doesn't like soname symlinks in non-dev packages | ||
32 | INSANE_SKIP_lib${PN} += "dev-so" | ||