diff options
author | Derek Straka <derek@asterius.io> | 2017-03-09 08:33:08 -0500 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-03-11 17:57:05 +0100 |
commit | 1a373a033f482981eb59ff8d9eb7a9437fa18cd4 (patch) | |
tree | cce261800b769e73a7a1b47eaed5398ed5467973 | |
parent | a4a1950e36a86bcc3e60fffdb0bbe5bc98d9daf0 (diff) | |
download | meta-openembedded-1a373a033f482981eb59ff8d9eb7a9437fa18cd4.tar.gz |
python-pyparsing: update to version 2.2.0
Fix the RDEPENDS and add a python3 version as well
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
4 files changed, 23 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyparsing.inc b/meta-python/recipes-devtools/python/python-pyparsing.inc new file mode 100644 index 000000000..033e0dbc0 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-pyparsing.inc | |||
@@ -0,0 +1,19 @@ | |||
1 | SUMMARY = "Python parsing module" | ||
2 | HOMEPAGE = "http://pyparsing.wikispaces.com/" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=fb46329938e6bc829b256e37d5c1e31a" | ||
5 | |||
6 | SRC_URI[md5sum] = "0214e42d63af850256962b6744c948d9" | ||
7 | SRC_URI[sha256sum] = "0832bcf47acd283788593e7a0f542407bd9550a55a8a8435214a1960e04bcb04" | ||
8 | |||
9 | inherit pypi | ||
10 | |||
11 | RDEPENDS_${PN} += " \ | ||
12 | ${PYTHON_PN}-datetime \ | ||
13 | ${PYTHON_PN}-debugger \ | ||
14 | ${PYTHON_PN}-json \ | ||
15 | ${PYTHON_PN}-netclient \ | ||
16 | ${PYTHON_PN}-pprint \ | ||
17 | ${PYTHON_PN}-stringold \ | ||
18 | ${PYTHON_PN}-threading \ | ||
19 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-pyparsing_2.1.10.bb b/meta-python/recipes-devtools/python/python-pyparsing_2.1.10.bb deleted file mode 100644 index 06f98457c..000000000 --- a/meta-python/recipes-devtools/python/python-pyparsing_2.1.10.bb +++ /dev/null | |||
@@ -1,9 +0,0 @@ | |||
1 | SUMMARY = "Python parsing module" | ||
2 | HOMEPAGE = "http://pyparsing.wikispaces.com/" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=fb46329938e6bc829b256e37d5c1e31a" | ||
5 | |||
6 | SRC_URI[md5sum] = "065908b92904e0d3634eb156f44cc80e" | ||
7 | SRC_URI[sha256sum] = "811c3e7b0031021137fc83e051795025fcb98674d07eb8fe922ba4de53d39188" | ||
8 | |||
9 | inherit pypi setuptools | ||
diff --git a/meta-python/recipes-devtools/python/python-pyparsing_2.2.0.bb b/meta-python/recipes-devtools/python/python-pyparsing_2.2.0.bb new file mode 100644 index 000000000..90217f3c3 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-pyparsing_2.2.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools | ||
2 | require python-pyparsing.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-pyparsing_2.2.0.bb b/meta-python/recipes-devtools/python/python3-pyparsing_2.2.0.bb new file mode 100644 index 000000000..0805fee3e --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pyparsing_2.2.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-pyparsing.inc | ||