summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2013-01-27 15:41:22 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-01-27 23:54:10 +0100
commit164caa34458ed2c145dfa2e4d2d207f8ce47a057 (patch)
treef32b81288339636fc58b15265d9e8ca312a9a6e3
parent09d7480892e5e483d80c1d1e3643668a1270b490 (diff)
downloadmeta-openembedded-164caa34458ed2c145dfa2e4d2d207f8ce47a057.tar.gz
python-smbus: add 3.0.3
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/python/python-smbus_3.0.3.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-smbus_3.0.3.bb b/meta-oe/recipes-devtools/python/python-smbus_3.0.3.bb
new file mode 100644
index 000000000..5ba24c6ef
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-smbus_3.0.3.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "Set of i2c tools for linux - Python module"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://smbusmodule.c;startline=1;endline=17;md5=fa24df321a520ff8e10f203425ab9fa8"
4
5SRC_URI = "http://dl.lm-sensors.org/i2c-tools/releases/i2c-tools-${PV}.tar.bz2 \
6 "
7SRC_URI[md5sum] = "511376eed04455cdb277ef19c5f73bb4"
8SRC_URI[sha256sum] = "23b28e474741834e3f1b35b0686528769a13adc92d2ff5603cbda1d6bd5e5629"
9
10DEPENDS = "i2c-tools"
11
12inherit distutils
13
14S = "${WORKDIR}/i2c-tools-${PV}/py-smbus/"
15
16do_configure_prepend() {
17 # Adjust for OE header rename
18 sed -i s:linux/i2c-dev.h:linux/i2c-dev-user.h: Module.mk
19 sed -i s:linux/i2c-dev.h:linux/i2c-dev-user.h: smbusmodule.c
20}