diff options
author | Khem Raj <raj.khem@gmail.com> | 2013-11-05 16:41:17 -0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-11-18 23:14:10 +0100 |
commit | 6c29faf02c9c5268eabd8c62e618cb1b3053eaa3 (patch) | |
tree | 29168d84ccc9ee1ac4505aec3773a254ce23aa23 | |
parent | 7295c2adf3015585acbf5298291888630da025fa (diff) | |
download | meta-openembedded-6c29faf02c9c5268eabd8c62e618cb1b3053eaa3.tar.gz |
vim: Disable parallel install, it has races
We end up with install errors when using high parallel factor like -j20
errors like
| mkdir: cannot create directory
`/``build/tmp-eglibc/work/ppce500v2-poky-linux-gnuspe/vim/7.4.27-r0/image/usr/share/vim/vim74':
File exists
| mkdir: cannot create directory
`/build/tmp-eglibc/work/ppce500v2-poky-linux-gnuspe/vim/7.4.27-r0/image/usr/share/vim/vim74':
File exists
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/vim/vim_7.4.27.bb | 4 |
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/vim/vim_7.4.27.bb b/meta-oe/recipes-support/vim/vim_7.4.27.bb index 77507d4c59..5cb933bfde 100644 --- a/meta-oe/recipes-support/vim/vim_7.4.27.bb +++ b/meta-oe/recipes-support/vim/vim_7.4.27.bb | |||
@@ -7,7 +7,7 @@ LICENSE = "vim" | |||
7 | LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;md5=b779e18be6ed77facc770691c967b8f8" | 7 | LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;md5=b779e18be6ed77facc770691c967b8f8" |
8 | 8 | ||
9 | SRC_URI = "hg://vim.googlecode.com/hg/;protocol=https;module=vim \ | 9 | SRC_URI = "hg://vim.googlecode.com/hg/;protocol=https;module=vim \ |
10 | file://configure.in_remove_CC_quotes.patch;patchdir=.." | 10 | file://configure.in_remove_CC_quotes.patch;patchdir=.." |
11 | SRCREV = "v7-4-027" | 11 | SRCREV = "v7-4-027" |
12 | 12 | ||
13 | S = "${WORKDIR}/${PN}/src" | 13 | S = "${WORKDIR}/${PN}/src" |
@@ -61,6 +61,8 @@ do_install_append() { | |||
61 | install -m 0644 ../runtime/vimrc_example.vim ${D}/${datadir}/${PN}/vimrc | 61 | install -m 0644 ../runtime/vimrc_example.vim ${D}/${datadir}/${PN}/vimrc |
62 | } | 62 | } |
63 | 63 | ||
64 | PARALLEL_MAKEINST = "" | ||
65 | |||
64 | PACKAGES =+ "${PN}-common ${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-data" | 66 | PACKAGES =+ "${PN}-common ${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-data" |
65 | FILES_${PN}-syntax = "${datadir}/${PN}/${VIMDIR}/syntax" | 67 | FILES_${PN}-syntax = "${datadir}/${PN}/${VIMDIR}/syntax" |
66 | FILES_${PN}-help = "${datadir}/${PN}/${VIMDIR}/doc" | 68 | FILES_${PN}-help = "${datadir}/${PN}/${VIMDIR}/doc" |