diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2014-11-26 11:47:33 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-12-09 11:18:42 +0100 |
commit | 0b3ee651161a234b07a6219234b82c4c8207246a (patch) | |
tree | 059ee48db17238aabab60abf27ae2d2626dcb3df | |
parent | af9aee6804dd56d45be1d83d612bfd4b40874534 (diff) | |
download | meta-openembedded-0b3ee651161a234b07a6219234b82c4c8207246a.tar.gz |
at: systemd support now in OE-Core
systemd support has already been added to the OE-Core at recipe based on
this file (in the dizzy branch).
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-systemd/oe-core/recipes-extended/at/at/atd.service | 9 | ||||
-rw-r--r-- | meta-systemd/oe-core/recipes-extended/at/at_%.bbappend | 12 |
2 files changed, 0 insertions, 21 deletions
diff --git a/meta-systemd/oe-core/recipes-extended/at/at/atd.service b/meta-systemd/oe-core/recipes-extended/at/at/atd.service deleted file mode 100644 index 64a9015500..0000000000 --- a/meta-systemd/oe-core/recipes-extended/at/at/atd.service +++ /dev/null | |||
@@ -1,9 +0,0 @@ | |||
1 | [Unit] | ||
2 | Description=Job spooling tools | ||
3 | After=syslog.target | ||
4 | |||
5 | [Service] | ||
6 | ExecStart=/usr/sbin/atd -f | ||
7 | |||
8 | [Install] | ||
9 | WantedBy=multi-user.target | ||
diff --git a/meta-systemd/oe-core/recipes-extended/at/at_%.bbappend b/meta-systemd/oe-core/recipes-extended/at/at_%.bbappend index 3a22fe3bda..181b8784dd 100644 --- a/meta-systemd/oe-core/recipes-extended/at/at_%.bbappend +++ b/meta-systemd/oe-core/recipes-extended/at/at_%.bbappend | |||
@@ -1,16 +1,4 @@ | |||
1 | inherit systemd | ||
2 | |||
3 | # look for files in the layer first | ||
4 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
5 | |||
6 | SRC_URI += "file://atd.service" | ||
7 | |||
8 | RPROVIDES_${PN} += "${PN}-systemd" | 1 | RPROVIDES_${PN} += "${PN}-systemd" |
9 | RREPLACES_${PN} += "${PN}-systemd" | 2 | RREPLACES_${PN} += "${PN}-systemd" |
10 | RCONFLICTS_${PN} += "${PN}-systemd" | 3 | RCONFLICTS_${PN} += "${PN}-systemd" |
11 | SYSTEMD_SERVICE_${PN} = "atd.service" | ||
12 | do_install_append() { | ||
13 | install -d ${D}${systemd_unitdir}/system | ||
14 | install -m 0644 ${WORKDIR}/atd.service ${D}${systemd_unitdir}/system | ||
15 | } | ||
16 | 4 | ||