summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-11-09 12:26:29 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-04 14:50:23 +0100
commit6c4cb0fb00c9b8e68ed39c87370c841deec30acf (patch)
treed64323b896cab45d097ac9bef335d9d53d9b6a40
parent220b31d536cf15e68c11980e0c721a7050313db1 (diff)
downloadmeta-openembedded-6c4cb0fb00c9b8e68ed39c87370c841deec30acf.tar.gz
ktap: add libelf PACKAGECONFIG also to ktap-module
* building ktap-module without elfutils fails with: ktap-module/0.4-r0/git/Makefile:107: No libelf found, disables symbol resolving, please install elfutils-libelf-devel/libelf-dev Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap-module_git.bb5
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap.inc12
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap_git.bb10
3 files changed, 14 insertions, 13 deletions
diff --git a/meta-oe/recipes-kernel/ktap/ktap-module_git.bb b/meta-oe/recipes-kernel/ktap/ktap-module_git.bb
index e3c94e3dc..cb913271f 100644
--- a/meta-oe/recipes-kernel/ktap/ktap-module_git.bb
+++ b/meta-oe/recipes-kernel/ktap/ktap-module_git.bb
@@ -9,11 +9,8 @@ inherit module
9# See https://github.com/ktap/ktap/issues/80 9# See https://github.com/ktap/ktap/issues/80
10PNBLACKLIST[ktap-module] ?= "Not compatible with 3.19 kernel" 10PNBLACKLIST[ktap-module] ?= "Not compatible with 3.19 kernel"
11 11
12# Available package configs: ffi (only supported on x86_64)
13PACKAGECONFIG ?= ""
14
15# Only build the module 12# Only build the module
16MAKE_TARGETS = "${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} mod" 13MAKE_TARGETS = "mod"
17 14
18# Kernel module packages MUST begin with 'kernel-module-', otherwise 15# Kernel module packages MUST begin with 'kernel-module-', otherwise
19# multilib image generation can fail. 16# multilib image generation can fail.
diff --git a/meta-oe/recipes-kernel/ktap/ktap.inc b/meta-oe/recipes-kernel/ktap/ktap.inc
index 2c94a08d6..e2e498f9f 100644
--- a/meta-oe/recipes-kernel/ktap/ktap.inc
+++ b/meta-oe/recipes-kernel/ktap/ktap.inc
@@ -11,4 +11,16 @@ SRC_URI = "git://github.com/ktap/ktap.git"
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
12 12
13# Package config is abused as a general compile time configuration tool. 13# Package config is abused as a general compile time configuration tool.
14
15# Only supports x86_64 for now!. Needs to be enabled for ktap-module too.
14PACKAGECONFIG[ffi] = "" 16PACKAGECONFIG[ffi] = ""
17
18# Needed to resolve symbols in DSO and for sdt
19PACKAGECONFIG[libelf] = ",,elfutils"
20
21PACKAGECONFIG ?= "libelf"
22
23EXTRA_OEMAKE = " \
24 ${@base_contains('PACKAGECONFIG', 'libelf', '', 'NO_LIBELF=1', d)} \
25 ${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} \
26"
diff --git a/meta-oe/recipes-kernel/ktap/ktap_git.bb b/meta-oe/recipes-kernel/ktap/ktap_git.bb
index 1379c4833..248e7bdd6 100644
--- a/meta-oe/recipes-kernel/ktap/ktap_git.bb
+++ b/meta-oe/recipes-kernel/ktap/ktap_git.bb
@@ -6,17 +6,9 @@ SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
6DEPENDS = "ktap-module" 6DEPENDS = "ktap-module"
7 7
8PNBLACKLIST[ktap] ?= "Depends on blacklisted kernel-module-ktapvm" 8PNBLACKLIST[ktap] ?= "Depends on blacklisted kernel-module-ktapvm"
9#Available package configs:
10# libelf - needed to resolve symbols in DSO and for sdt
11# ffi - only supports x86_64 for now!. Needs to be enabled for ktap-module too.
12PACKAGECONFIG ?= "libelf"
13
14PACKAGECONFIG[libelf] = ",,elfutils"
15 9
16# Only build the userspace app 10# Only build the userspace app
17EXTRA_OEMAKE = "${@base_contains('PACKAGECONFIG', 'libelf', '', 'NO_LIBELF=1', d)} \ 11EXTRA_OEMAKE += "ktap"
18 ${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} \
19 ktap"
20 12
21do_install() { 13do_install() {
22 install -d ${D}${bindir} 14 install -d ${D}${bindir}