summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-04-23 13:11:14 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-10-26 21:43:09 +0100
commit692b646456ec508a1004fe56f3b6c0d2b42cd65b (patch)
treefb188344eed25a43146635ff274e238f5e961297
parentceecb1b63e31b942479cbf2b5e7206252b512abe (diff)
downloadmeta-openembedded-692b646456ec508a1004fe56f3b6c0d2b42cd65b.tar.gz
ntp: uprev to 4.2.8p2
ntp 4.2.8p2 has more CVE fixes, like CVE-2015-1799, CVE-2015-1798; and remove ntp-4.2.8-ntp-keygen-no-openssl.patch which 4.2.8p2 has integrated 4.2.8.p1 included CVE-2014-9297, CVE-2014-9298 (ak). Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-support/ntp/ntp/ntp-4.2.8-ntp-keygen-no-openssl.patch168
-rw-r--r--meta-networking/recipes-support/ntp/ntp_4.2.8p2.bb (renamed from meta-networking/recipes-support/ntp/ntp_4.2.8.bb)7
2 files changed, 3 insertions, 172 deletions
diff --git a/meta-networking/recipes-support/ntp/ntp/ntp-4.2.8-ntp-keygen-no-openssl.patch b/meta-networking/recipes-support/ntp/ntp/ntp-4.2.8-ntp-keygen-no-openssl.patch
deleted file mode 100644
index 9b9af63ca..000000000
--- a/meta-networking/recipes-support/ntp/ntp/ntp-4.2.8-ntp-keygen-no-openssl.patch
+++ /dev/null
@@ -1,168 +0,0 @@
1Fix ntp-keygen build without OpenSSL
2
3Patch borrowed from Gentoo, originally from upstream
4Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
5Upstream-Status: Backport
6
7Upstream commit:
8http://bk1.ntp.org/ntp-stable/?PAGE=patch&REV=5497b345z5MNTuNvJWuqPSje25NQTg
9Gentoo bugzilla: https://bugs.gentoo.org/show_bug.cgi?id=533238
10
11Signed-off-by: Markos Chandras <hwoarang@gentoo.org>
12Index: ntp-4.2.8/Makefile.am
13===================================================================
14--- ntp-4.2.8.orig/Makefile.am
15+++ ntp-4.2.8/Makefile.am
16@@ -2,7 +2,10 @@ ACLOCAL_AMFLAGS = -I sntp/m4 -I sntp/lib
17
18 NULL =
19
20+# moved sntp first to get libtool and libevent built.
21+
22 SUBDIRS = \
23+ sntp \
24 scripts \
25 include \
26 libntp \
27@@ -17,7 +20,6 @@ SUBDIRS = \
28 clockstuff \
29 kernel \
30 util \
31- sntp \
32 tests \
33 $(NULL)
34
35@@ -64,7 +66,6 @@ BUILT_SOURCES = \
36 .gcc-warning \
37 'libtool \
38 html/.datecheck \
39- sntp/built-sources-only \
40 $(srcdir)/COPYRIGHT \
41 $(srcdir)/.checkChangeLog \
42 $(NULL)
43Index: ntp-4.2.8/configure.ac
44===================================================================
45--- ntp-4.2.8.orig/configure.ac
46+++ ntp-4.2.8/configure.ac
47@@ -102,7 +102,7 @@ esac
48 enable_nls=no
49 LIBOPTS_CHECK_NOBUILD([sntp/libopts])
50
51-NTP_ENABLE_LOCAL_LIBEVENT
52+NTP_LIBEVENT_CHECK_NOBUILD([2], [sntp/libevent])
53
54 NTP_LIBNTP
55
56@@ -771,6 +771,10 @@ esac
57
58 ####
59
60+AC_CHECK_FUNCS([arc4random_buf])
61+
62+####
63+
64 saved_LIBS="$LIBS"
65 LIBS="$LIBS $LDADD_LIBNTP"
66 AC_CHECK_FUNCS([daemon])
67Index: ntp-4.2.8/libntp/ntp_crypto_rnd.c
68===================================================================
69--- ntp-4.2.8.orig/libntp/ntp_crypto_rnd.c
70+++ ntp-4.2.8/libntp/ntp_crypto_rnd.c
71@@ -24,6 +24,21 @@
72 int crypto_rand_init = 0;
73 #endif
74
75+#ifndef HAVE_ARC4RANDOM_BUF
76+static void
77+arc4random_buf(void *buf, size_t nbytes);
78+
79+void
80+evutil_secure_rng_get_bytes(void *buf, size_t nbytes);
81+
82+static void
83+arc4random_buf(void *buf, size_t nbytes)
84+{
85+ evutil_secure_rng_get_bytes(buf, nbytes);
86+ return;
87+}
88+#endif
89+
90 /*
91 * As of late 2014, here's how we plan to provide cryptographic-quality
92 * random numbers:
93Index: ntp-4.2.8/sntp/configure.ac
94===================================================================
95--- ntp-4.2.8.orig/sntp/configure.ac
96+++ ntp-4.2.8/sntp/configure.ac
97@@ -97,11 +97,14 @@ esac
98 enable_nls=no
99 LIBOPTS_CHECK
100
101-AM_COND_IF(
102- [BUILD_SNTP],
103- [NTP_LIBEVENT_CHECK],
104- [NTP_LIBEVENT_CHECK_NOBUILD]
105-)
106+# From when we only used libevent for sntp:
107+#AM_COND_IF(
108+# [BUILD_SNTP],
109+# [NTP_LIBEVENT_CHECK],
110+# [NTP_LIBEVENT_CHECK_NOBUILD]
111+#)
112+
113+NTP_LIBEVENT_CHECK([2])
114
115 # Checks for libraries.
116
117Index: ntp-4.2.8/sntp/m4/ntp_libevent.m4
118===================================================================
119--- ntp-4.2.8.orig/sntp/m4/ntp_libevent.m4
120+++ ntp-4.2.8/sntp/m4/ntp_libevent.m4
121@@ -1,4 +1,25 @@
122-dnl NTP_ENABLE_LOCAL_LIBEVENT -*- Autoconf -*-
123+# SYNOPSIS -*- Autoconf -*-
124+#
125+# NTP_ENABLE_LOCAL_LIBEVENT
126+# NTP_LIBEVENT_CHECK([MINVERSION [, DIR]])
127+# NTP_LIBEVENT_CHECK_NOBUILD([MINVERSION [, DIR]])
128+#
129+# DESCRIPTION
130+#
131+# AUTHOR
132+#
133+# Harlan Stenn
134+#
135+# LICENSE
136+#
137+# This file is Copyright (c) 2014 Network Time Foundation
138+#
139+# Copying and distribution of this file, with or without modification, are
140+# permitted in any medium without royalty provided the copyright notice,
141+# author attribution and this notice are preserved. This file is offered
142+# as-is, without any warranty.
143+
144+dnl NTP_ENABLE_LOCAL_LIBEVENT
145 dnl
146 dnl Provide only the --enable-local-libevent command-line option.
147 dnl
148@@ -29,7 +50,7 @@ dnl If NOBUILD is provided as the 3rd ar
149 dnl but DO NOT invoke DIR/configure if we are going to use our bundled
150 dnl version. This may be the case for nested packages.
151 dnl
152-dnl provide --enable-local-libevent .
153+dnl provides --enable-local-libevent .
154 dnl
155 dnl Examples:
156 dnl
157Index: ntp-4.2.8/util/Makefile.am
158===================================================================
159--- ntp-4.2.8.orig/util/Makefile.am
160+++ ntp-4.2.8/util/Makefile.am
161@@ -19,6 +19,7 @@ AM_LDFLAGS = $(LDFLAGS_NTP)
162 LDADD= ../libntp/libntp.a $(LDADD_LIBNTP) $(LIBM) $(PTHREAD_LIBS)
163 tg2_LDADD= ../libntp/libntp.a $(LDADD_LIBNTP) $(LIBM)
164 ntp_keygen_LDADD = version.o $(LIBOPTS_LDADD) ../libntp/libntp.a
165+ntp_keygen_LDADD += $(LDADD_LIBEVENT)
166 ntp_keygen_LDADD += $(LDADD_LIBNTP) $(PTHREAD_LIBS) $(LDADD_NTP) $(LIBM)
167 ntp_keygen_SOURCES = ntp-keygen.c ntp-keygen-opts.c ntp-keygen-opts.h
168
diff --git a/meta-networking/recipes-support/ntp/ntp_4.2.8.bb b/meta-networking/recipes-support/ntp/ntp_4.2.8p2.bb
index e802ee700..693bdbbf0 100644
--- a/meta-networking/recipes-support/ntp/ntp_4.2.8.bb
+++ b/meta-networking/recipes-support/ntp/ntp_4.2.8p2.bb
@@ -6,7 +6,7 @@ or satellite receiver or modem."
6HOMEPAGE = "http://support.ntp.org" 6HOMEPAGE = "http://support.ntp.org"
7SECTION = "console/network" 7SECTION = "console/network"
8LICENSE = "NTP" 8LICENSE = "NTP"
9LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=ebe123f74017224947c78d472407c10f" 9LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=f41fedb22dffefcbfafecc85b0f79cfa"
10 10
11DEPENDS = "pps-tools libevent" 11DEPENDS = "pps-tools libevent"
12 12
@@ -21,11 +21,10 @@ SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ntp-${PV}.tar.g
21 file://sntp.service \ 21 file://sntp.service \
22 file://sntp \ 22 file://sntp \
23 file://ntpd.list \ 23 file://ntpd.list \
24 file://ntp-4.2.8-ntp-keygen-no-openssl.patch \
25" 24"
26 25
27SRC_URI[md5sum] = "6972a626be6150db8cfbd0b63d8719e7" 26SRC_URI[md5sum] = "fa37049383316322d060ec9061ac23a9"
28SRC_URI[sha256sum] = "2e920df8b6a5a410567a73767fa458c00c7f0acec3213e69ed0134414a50d8ee" 27SRC_URI[sha256sum] = "0d69bc0e95caad43ea04fdad410e756bae1a71e67b1c2bd799b76b55e04c9b31"
29 28
30inherit autotools update-rc.d useradd systemd pkgconfig 29inherit autotools update-rc.d useradd systemd pkgconfig
31 30