summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 13:58:20 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:22:03 +0200
commiteb0e685982643787b5c4787a2640a1b92102b35e (patch)
tree547d9ab1a4a13f5219a39a7a99886b6f6b3808b2
parent17c747d85e155f3eb2fab97c5a1ad66a68d809bc (diff)
downloadmeta-openembedded-eb0e685982643787b5c4787a2640a1b92102b35e.tar.gz
cloud9: move systemd support from meta-systemd back to meta-oe
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/cloud9/cloud9/cloud9.service (renamed from meta-systemd/meta-oe/recipes-devtools/cloud9/cloud9/cloud9.service)0
-rw-r--r--meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb13
-rw-r--r--meta-systemd/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bbappend20
3 files changed, 12 insertions, 21 deletions
diff --git a/meta-systemd/meta-oe/recipes-devtools/cloud9/cloud9/cloud9.service b/meta-oe/recipes-devtools/cloud9/cloud9/cloud9.service
index 495b131ff..495b131ff 100644
--- a/meta-systemd/meta-oe/recipes-devtools/cloud9/cloud9/cloud9.service
+++ b/meta-oe/recipes-devtools/cloud9/cloud9/cloud9.service
diff --git a/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb b/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb
index 0c07b128b..9ae25bb65 100644
--- a/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb
+++ b/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bb
@@ -3,11 +3,13 @@ HOMEPAGE = "http://c9.io"
3LICENSE = "GPLv3" 3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=4784c3bcff601fd8f9515f52a11e7018" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=4784c3bcff601fd8f9515f52a11e7018"
5 5
6PR = "r2" 6PR = "r4"
7 7
8# Nodejs-native for node-waf, nodejs4-native for the headers 8# Nodejs-native for node-waf, nodejs4-native for the headers
9DEPENDS = "libxml2 nodejs-native nodejs4-native" 9DEPENDS = "libxml2 nodejs-native nodejs4-native"
10 10
11inherit systemd
12
11SRC_URI = "git://github.com/ajaxorg/cloud9.git;name=cloud9ide \ 13SRC_URI = "git://github.com/ajaxorg/cloud9.git;name=cloud9ide \
12 git://github.com/ajaxorg/o3;destsuffix=o3;name=o3 \ 14 git://github.com/ajaxorg/o3;destsuffix=o3;name=o3 \
13 git://github.com/ajaxorg/ace.git;destsuffix=git/support/ace;name=ace \ 15 git://github.com/ajaxorg/ace.git;destsuffix=git/support/ace;name=ace \
@@ -33,6 +35,7 @@ SRC_URI = "git://github.com/ajaxorg/cloud9.git;name=cloud9ide \
33 git://github.com/ajaxorg/UglifyJS.git;destsuffix=git/support/uglify-js;name=uglify-js \ 35 git://github.com/ajaxorg/UglifyJS.git;destsuffix=git/support/uglify-js;name=uglify-js \
34 file://index.js \ 36 file://index.js \
35 file://cloud9-avahi.service \ 37 file://cloud9-avahi.service \
38 file://cloud9.service \
36 file://0001-ide-use-node-as-interpreter-for-sketches-instead-of-.patch \ 39 file://0001-ide-use-node-as-interpreter-for-sketches-instead-of-.patch \
37 " 40 "
38 41
@@ -97,6 +100,9 @@ do_install () {
97 100
98 install -m 0755 -d ${D}${sysconfdir}/avahi/services/ 101 install -m 0755 -d ${D}${sysconfdir}/avahi/services/
99 install -m 0644 ${WORKDIR}/cloud9-avahi.service ${D}${sysconfdir}/avahi/services/ 102 install -m 0644 ${WORKDIR}/cloud9-avahi.service ${D}${sysconfdir}/avahi/services/
103
104 install -d ${D}${systemd_unitdir}/system
105 install -m 0644 ${WORKDIR}/cloud9.service ${D}${systemd_unitdir}/system
100} 106}
101 107
102FILES_${PN}-dbg += "${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/.debug \ 108FILES_${PN}-dbg += "${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/.debug \
@@ -104,3 +110,8 @@ FILES_${PN}-dbg += "${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o
104 " 110 "
105 111
106RDEPENDS_${PN} = "nodejs4 nodejs gzip" 112RDEPENDS_${PN} = "nodejs4 nodejs gzip"
113
114RPROVIDES_${PN} += "${PN}-systemd"
115RREPLACES_${PN} += "${PN}-systemd"
116RCONFLICTS_${PN} += "${PN}-systemd"
117SYSTEMD_SERVICE_${PN} = "cloud9.service"
diff --git a/meta-systemd/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bbappend b/meta-systemd/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bbappend
deleted file mode 100644
index 50c6886fa..000000000
--- a/meta-systemd/meta-oe/recipes-devtools/cloud9/cloud9_0.6.bbappend
+++ /dev/null
@@ -1,20 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3PRINC := "${@int(PRINC) + 3}"
4
5inherit systemd
6
7SRC_URI += "file://cloud9.service"
8
9inherit systemd
10
11NATIVE_SYSTEMD_SUPPORT = "1"
12RPROVIDES_${PN} += "${PN}-systemd"
13RREPLACES_${PN} += "${PN}-systemd"
14RCONFLICTS_${PN} += "${PN}-systemd"
15SYSTEMD_SERVICE_${PN} = "cloud9.service"
16do_install_append() {
17 install -d ${D}${systemd_unitdir}/system
18 install -m 0644 ${WORKDIR}/cloud9.service ${D}${systemd_unitdir}/system
19}
20