summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-06-10 21:46:47 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-07-16 09:39:06 +0200
commitca89a235067f3328ceaa3c7a0a5bb599aaa4b428 (patch)
tree1f90a4a6a4596c1478a0f68ad6fb87017730bb86
parent9f2dd8c0ae46507989f4cb8f24edc87ed91bebac (diff)
downloadmeta-openembedded-ca89a235067f3328ceaa3c7a0a5bb599aaa4b428.tar.gz
atftp: move systemd support to meta-systemd
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
-rw-r--r--meta-oe/recipes-extended/atftp/atftp_0.7.bb10
-rw-r--r--meta-systemd/meta-oe/recipes-extended/atftp/atftp/atftpd.service (renamed from meta-oe/recipes-extended/atftp/files/atftpd.service)0
-rw-r--r--meta-systemd/meta-oe/recipes-extended/atftp/atftp_0.7.bbappend10
3 files changed, 13 insertions, 7 deletions
diff --git a/meta-oe/recipes-extended/atftp/atftp_0.7.bb b/meta-oe/recipes-extended/atftp/atftp_0.7.bb
index 1af4b6329..ff1e11dcf 100644
--- a/meta-oe/recipes-extended/atftp/atftp_0.7.bb
+++ b/meta-oe/recipes-extended/atftp/atftp_0.7.bb
@@ -3,19 +3,15 @@ SECTION = "network"
3HOMEPAGE = "http://packages.debian.org/atftp" 3HOMEPAGE = "http://packages.debian.org/atftp"
4LICENSE = "GPLv2" 4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=94d55d512a9ba36caa9b7df079bae19f" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=94d55d512a9ba36caa9b7df079bae19f"
6PR = "r3" 6PR = "r4"
7 7
8SRC_URI = "${DEBIAN_MIRROR}/main/a/atftp/atftp_${PV}.dfsg.orig.tar.gz;name=archive \ 8SRC_URI = "${DEBIAN_MIRROR}/main/a/atftp/atftp_${PV}.dfsg.orig.tar.gz;name=archive \
9 ${DEBIAN_MIRROR}/main/a/atftp/atftp_${PV}.dfsg-11.diff.gz;name=patch \ 9 ${DEBIAN_MIRROR}/main/a/atftp/atftp_${PV}.dfsg-11.diff.gz;name=patch \
10 file://atftpd.init \ 10 file://atftpd.init"
11 file://atftpd.service"
12 11
13S = "${WORKDIR}/atftp-${PV}.dfsg" 12S = "${WORKDIR}/atftp-${PV}.dfsg"
14 13
15inherit autotools update-rc.d systemd useradd 14inherit autotools update-rc.d useradd
16
17SYSTEMD_PACKAGES = "atftpd-systemd"
18SYSTEMD_SERVICE_atftpd-systemd = "atftpd.service"
19 15
20INITSCRIPT_PACKAGES = "${PN}d" 16INITSCRIPT_PACKAGES = "${PN}d"
21INITSCRIPT_NAME_${PN}d = "atftpd" 17INITSCRIPT_NAME_${PN}d = "atftpd"
diff --git a/meta-oe/recipes-extended/atftp/files/atftpd.service b/meta-systemd/meta-oe/recipes-extended/atftp/atftp/atftpd.service
index 480bc702e..480bc702e 100644
--- a/meta-oe/recipes-extended/atftp/files/atftpd.service
+++ b/meta-systemd/meta-oe/recipes-extended/atftp/atftp/atftpd.service
diff --git a/meta-systemd/meta-oe/recipes-extended/atftp/atftp_0.7.bbappend b/meta-systemd/meta-oe/recipes-extended/atftp/atftp_0.7.bbappend
new file mode 100644
index 000000000..3706d9f2b
--- /dev/null
+++ b/meta-systemd/meta-oe/recipes-extended/atftp/atftp_0.7.bbappend
@@ -0,0 +1,10 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3PRINC := "${@int(PRINC) + 1}"
4
5inherit systemd
6
7SRC_URI += "file://atftpd.service"
8
9SYSTEMD_PACKAGES = "atftpd-systemd"
10SYSTEMD_SERVICE_atftpd-systemd = "atftpd.service"