summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-11-15 11:44:46 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-11-16 16:20:21 +0100
commitb38e0815204007873116bb657d9943c7f0206fb2 (patch)
treecbdc017aec184516ac6ed3c46985758dfee7fc8f
parent7dccdaa8b699b2048f6701c427cf0d06b94cf25f (diff)
downloadmeta-openembedded-b38e0815204007873116bb657d9943c7f0206fb2.tar.gz
omgps: add patch to fix build with latest glib from oe-core
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-oe/recipes-navigation/omgps/omgps/fix.build.with.glib.2.34.patch122
-rw-r--r--meta-oe/recipes-navigation/omgps/omgps_svn.bb2
2 files changed, 124 insertions, 0 deletions
diff --git a/meta-oe/recipes-navigation/omgps/omgps/fix.build.with.glib.2.34.patch b/meta-oe/recipes-navigation/omgps/omgps/fix.build.with.glib.2.34.patch
new file mode 100644
index 000000000..e9536639d
--- /dev/null
+++ b/meta-oe/recipes-navigation/omgps/omgps/fix.build.with.glib.2.34.patch
@@ -0,0 +1,122 @@
1diff -uNr omgps.orig/src/dbus_intf.c omgps/src/dbus_intf.c
2--- omgps.orig/src/dbus_intf.c 2011-12-12 12:22:47.000000000 +0100
3+++ omgps/src/dbus_intf.c 2012-11-14 14:44:45.435381443 +0100
4@@ -171,7 +171,7 @@
5 gpsdata->svinfo_valid = TRUE;
6
7 int i, j;
8- GValueArray *val;
9+ GArray *val;
10 svinfo_channel_t *sv;
11
12 j = 0;
13@@ -179,16 +179,16 @@
14 val = satellites->pdata[i];
15
16 sv = &gpsdata->sv_channels[j];
17- sv->sv_id = g_value_get_uint(g_value_array_get_nth(val, 0));
18+ sv->sv_id = g_array_index(val, guint, 0);
19
20- if (g_value_get_boolean(g_value_array_get_nth(val, 1))) {
21+ if (g_array_index(val, gboolean, 1)) {
22 ++gpsdata->sv_in_use;
23 sv->flags = 0x01;
24 }
25
26- sv->elevation = (int)g_value_get_uint(g_value_array_get_nth(val, 2));
27- sv->azimuth = (int)g_value_get_uint(g_value_array_get_nth(val, 3));
28- sv->cno = g_value_get_uint(g_value_array_get_nth(val, 4));
29+ sv->elevation = (int)g_array_index(val, guint, 2);
30+ sv->azimuth = (int)g_array_index(val, guint, 3);
31+ sv->cno = g_array_index(val, guint, 4);
32 if (sv->cno > 0)
33 ++gpsdata->sv_get_signal;
34
35diff -uNr omgps.orig/src/main.c omgps/src/main.c
36--- omgps.orig/src/main.c 2011-12-12 12:22:47.000000000 +0100
37+++ omgps/src/main.c 2012-11-14 14:46:00.345402222 +0100
38@@ -489,9 +489,6 @@
39
40 g_type_init();
41
42- if (! g_thread_supported ())
43- g_thread_init(NULL);
44-
45 gdk_threads_init();
46
47 gdk_threads_enter();
48diff -uNr omgps.orig/src/tab_gpscfg.c omgps/src/tab_gpscfg.c
49--- omgps.orig/src/tab_gpscfg.c 2011-12-12 12:22:47.000000000 +0100
50+++ omgps/src/tab_gpscfg.c 2012-11-14 15:23:47.526925258 +0100
51@@ -222,7 +222,7 @@
52
53 static gboolean change_platform_model_cmd(void *model_id)
54 {
55- U1 model = (U1)(int) model_id;
56+ U1 model = (U1)GPOINTER_TO_INT(model_id);
57 int gps_dev_fd = 0;
58
59 /* non ubx means: we need open serial port
60@@ -269,7 +269,7 @@
61 static void change_platmodel_button_clicked(GtkWidget *widget, gpointer data)
62 {
63 int idx = gtk_combo_box_get_active(GTK_COMBO_BOX(platmodel_list));
64- char *model_id = (void *)(int)platmodel_values[idx];
65+ void *model_id = (void *)GINT_TO_POINTER(platmodel_values[idx]);
66
67 if (POLL_ENGINE_TEST(UBX)) {
68 gtk_widget_set_sensitive(change_platmodel_button, FALSE);
69diff -uNr omgps.orig/src/tab_menu.c omgps/src/tab_menu.c
70--- omgps.orig/src/tab_menu.c 2011-12-12 12:22:47.000000000 +0100
71+++ omgps/src/tab_menu.c 2012-11-14 15:25:08.217941513 +0100
72@@ -65,7 +65,7 @@
73
74 static void poll_button_clicked(GtkWidget *widget, gpointer data)
75 {
76- gboolean is_start_bt = (gboolean)data;
77+ gboolean is_start_bt = (gboolean) GPOINTER_TO_INT(data);
78
79 if (POLL_STATE_TEST(RUNNING) == is_start_bt)
80 return;
81diff -uNr omgps.orig/src/tab_tile.c omgps/src/tab_tile.c
82--- omgps.orig/src/tab_tile.c 2011-12-12 12:22:47.000000000 +0100
83+++ omgps/src/tab_tile.c 2012-11-14 15:25:30.392945800 +0100
84@@ -101,7 +101,7 @@
85 static gboolean set_bg_map(GtkTreeModel *model, GtkTreePath *path, GtkTreeIter *iter, gpointer data)
86 {
87 map_repo_t *repo;
88- gboolean clear = (gboolean)data;
89+ gboolean clear = (gboolean)GPOINTER_TO_INT(data);
90
91 int type;
92
93@@ -240,7 +240,7 @@
94
95 static void alpha_radio_toggled (GtkWidget *widget, gpointer user_data)
96 {
97- int idx = (int)user_data;
98+ int idx = (int)GPOINTER_TO_INT(user_data);
99
100 if (g_view.bg_alpha_idx == idx)
101 return;
102@@ -384,7 +384,7 @@
103
104 for (i=0; i<ALPHA_LEVELS; i++) {
105 g_signal_connect (G_OBJECT (alpha_radios[i]), "toggled",
106- G_CALLBACK (alpha_radio_toggled), (gpointer)i);
107+ G_CALLBACK (alpha_radio_toggled), GINT_TO_POINTER(i));
108 gtk_container_add(GTK_CONTAINER (alpha_hbox), alpha_radios[i]);
109 }
110
111diff -uNr omgps.orig/src/tab_view.c omgps/src/tab_view.c
112--- omgps.orig/src/tab_view.c 2011-12-12 12:22:47.000000000 +0100
113+++ omgps/src/tab_view.c 2012-11-14 15:25:47.018949453 +0100
114@@ -534,7 +534,7 @@
115
116 static void* change_zoom_routine(void *args)
117 {
118- gboolean is_zoom_in = (gboolean)args;
119+ gboolean is_zoom_in = (gboolean)GPOINTER_TO_INT(args);
120 stop = FALSE;
121
122 int hi = (is_zoom_in)?
diff --git a/meta-oe/recipes-navigation/omgps/omgps_svn.bb b/meta-oe/recipes-navigation/omgps/omgps_svn.bb
index 59fd9b0ad..0d788b61c 100644
--- a/meta-oe/recipes-navigation/omgps/omgps_svn.bb
+++ b/meta-oe/recipes-navigation/omgps/omgps_svn.bb
@@ -6,6 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
6DEPENDS = "gtk+ python-pygobject dbus-glib" 6DEPENDS = "gtk+ python-pygobject dbus-glib"
7SRCREV = "109" 7SRCREV = "109"
8PV = "0.1+svnr${SRCPV}" 8PV = "0.1+svnr${SRCPV}"
9PR = "r1"
9S = "${WORKDIR}/${PN}" 10S = "${WORKDIR}/${PN}"
10 11
11do_configure_prepend() { 12do_configure_prepend() {
@@ -18,6 +19,7 @@ SRC_URI = "svn://omgps.googlecode.com/svn/trunk;module=omgps;protocol=http \
18 file://sysfs.node.2.6.32.patch \ 19 file://sysfs.node.2.6.32.patch \
19 file://fix.capability.patch \ 20 file://fix.capability.patch \
20 file://use.unused.variable.patch \ 21 file://use.unused.variable.patch \
22 file://fix.build.with.glib.2.34.patch \
21" 23"
22 24
23inherit autotools 25inherit autotools