summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 14:50:30 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:22:05 +0200
commita61c15efe444c8917da50264817b44cdcb775fc9 (patch)
tree816aef1c3c69b17f7e6740f20c6cf5195236e0b4
parentfe76f1ab77c118e077d2c98f405b6b78ad35a124 (diff)
downloadmeta-openembedded-a61c15efe444c8917da50264817b44cdcb775fc9.tar.gz
zram: move systemd support from meta-systemd back to meta-oe
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-extended/zram/zram/zram.service (renamed from meta-systemd/meta-oe/recipes-extended/zram/zram/zram.service)0
-rw-r--r--meta-oe/recipes-extended/zram/zram_0.1.bb13
-rw-r--r--meta-systemd/meta-oe/recipes-extended/zram/zram_0.1.bbappend20
3 files changed, 11 insertions, 22 deletions
diff --git a/meta-systemd/meta-oe/recipes-extended/zram/zram/zram.service b/meta-oe/recipes-extended/zram/zram/zram.service
index 4a19367d9..4a19367d9 100644
--- a/meta-systemd/meta-oe/recipes-extended/zram/zram/zram.service
+++ b/meta-oe/recipes-extended/zram/zram/zram.service
diff --git a/meta-oe/recipes-extended/zram/zram_0.1.bb b/meta-oe/recipes-extended/zram/zram_0.1.bb
index 85262647c..115e6437f 100644
--- a/meta-oe/recipes-extended/zram/zram_0.1.bb
+++ b/meta-oe/recipes-extended/zram/zram_0.1.bb
@@ -2,22 +2,31 @@ DESCRIPTION = "Linux zram compressed in-memory swap"
2LICENSE = "MIT" 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" 3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
4 4
5inherit allarch update-rc.d 5inherit allarch update-rc.d systemd
6 6
7RDEPENDS_${PN} = "util-linux-swaponoff kmod kernel-module-zram" 7RDEPENDS_${PN} = "util-linux-swaponoff kmod kernel-module-zram"
8 8
9PR = "r0" 9PR = "r3"
10 10
11SRC_URI = " \ 11SRC_URI = " \
12 file://init \ 12 file://init \
13 file://zram.service \
13 " 14 "
14 15
15do_install () { 16do_install () {
16 # Sysvinit 17 # Sysvinit
17 install -d ${D}${sysconfdir}/init.d 18 install -d ${D}${sysconfdir}/init.d
18 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/zram 19 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/zram
20
21 install -d ${D}${systemd_unitdir}/system
22 install -m 0644 ${WORKDIR}/zram.service ${D}${systemd_unitdir}/system
19} 23}
20 24
21FILES_${PN} = "${sysconfdir}/init.d" 25FILES_${PN} = "${sysconfdir}/init.d"
22INITSCRIPT_NAME = "zram" 26INITSCRIPT_NAME = "zram"
23INITSCRIPT_PARAMS = "start 05 2 3 4 5 . stop 22 0 1 6 ." 27INITSCRIPT_PARAMS = "start 05 2 3 4 5 . stop 22 0 1 6 ."
28
29RPROVIDES_${PN} += "${PN}-systemd"
30RREPLACES_${PN} += "${PN}-systemd"
31RCONFLICTS_${PN} += "${PN}-systemd"
32SYSTEMD_SERVICE_${PN} = "zram.service"
diff --git a/meta-systemd/meta-oe/recipes-extended/zram/zram_0.1.bbappend b/meta-systemd/meta-oe/recipes-extended/zram/zram_0.1.bbappend
deleted file mode 100644
index 227c1c7c6..000000000
--- a/meta-systemd/meta-oe/recipes-extended/zram/zram_0.1.bbappend
+++ /dev/null
@@ -1,20 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3PRINC := "${@int(PRINC) + 2}"
4
5inherit systemd
6
7SRC_URI += " \
8 file://zram.service \
9"
10
11RPROVIDES_${PN} += "${PN}-systemd"
12RREPLACES_${PN} += "${PN}-systemd"
13RCONFLICTS_${PN} += "${PN}-systemd"
14SYSTEMD_SERVICE_${PN} = "zram.service"
15
16do_install_append() {
17 install -d ${D}${systemd_unitdir}/system
18 install -m 0644 ${WORKDIR}/zram.service ${D}${systemd_unitdir}/system
19}
20