summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-05-30 20:41:11 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-05-30 20:41:11 +0200
commit22c813fa4ba26f39f8814eaf32a030ee59a35f00 (patch)
treeae5460a5088d6d36da306fe78c5bd8efe7436173
parent2c5c9e005bbef135c0b674d3166da7fef856849d (diff)
downloadmeta-openembedded-22c813fa4ba26f39f8814eaf32a030ee59a35f00.tar.gz
systemd: fix postinst so u-a can run offline
otherwise we don't get an /sbin/init.... Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index ba57a0239..f6c675273 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -15,7 +15,7 @@ inherit gitpkgv
15PKGV = "v${GITPKGVTAG}" 15PKGV = "v${GITPKGVTAG}"
16 16
17PV = "git" 17PV = "git"
18PR = "r3" 18PR = "r4"
19 19
20inherit autotools vala update-alternatives 20inherit autotools vala update-alternatives
21 21
@@ -101,11 +101,12 @@ RRECOMMENDS_${PN} += "kbd kbd-consolefonts \
101# u-a for runlevel and telinit 101# u-a for runlevel and telinit
102 102
103pkg_postinst_${PN} () { 103pkg_postinst_${PN} () {
104# can't do this offline 104# can't do this offline, but we need the u-a bits
105if [ "x$D" != "x" ]; then 105if [ "x$D" != "x" ]; then
106 exit 1 106 echo "can't do addgroup offline"
107else
108 grep "^lock:" /etc/group > /dev/null || addgroup lock
107fi 109fi
108grep "^lock:" /etc/group > /dev/null || addgroup lock
109 110
110update-alternatives --install ${base_sbindir}/halt halt ${base_bindir}/systemctl 300 111update-alternatives --install ${base_sbindir}/halt halt ${base_bindir}/systemctl 300
111update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/systemctl 300 112update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/systemctl 300