summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 14:45:03 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:22:05 +0200
commit1e29c4586eaf7af68ec8ea4276114cc6aec05a11 (patch)
tree44b49eb9cc375c65fbfeb46b7ff732ec858972eb
parentfd84ec341f3224e1f79f185588f2cd844f464f86 (diff)
downloadmeta-openembedded-1e29c4586eaf7af68ec8ea4276114cc6aec05a11.tar.gz
gateone: move systemd support from meta-systemd back to meta-oe
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/gateone/gateone/gateone.service (renamed from meta-systemd/meta-oe/recipes-connectivity/gateone/gateone/gateone.service)0
-rw-r--r--meta-oe/recipes-connectivity/gateone/gateone_git.bb10
-rw-r--r--meta-systemd/meta-oe/recipes-connectivity/gateone/gateone_git.bbappend16
3 files changed, 8 insertions, 18 deletions
diff --git a/meta-systemd/meta-oe/recipes-connectivity/gateone/gateone/gateone.service b/meta-oe/recipes-connectivity/gateone/gateone/gateone.service
index 7ff60020a..7ff60020a 100644
--- a/meta-systemd/meta-oe/recipes-connectivity/gateone/gateone/gateone.service
+++ b/meta-oe/recipes-connectivity/gateone/gateone/gateone.service
diff --git a/meta-oe/recipes-connectivity/gateone/gateone_git.bb b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
index e9c182da5..355200978 100644
--- a/meta-oe/recipes-connectivity/gateone/gateone_git.bb
+++ b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
@@ -2,18 +2,19 @@ DESCRIPTION = "HTML5 (plugin-free) web-based terminal emulator and SSH client"
2LICENSE = "AGPLv3" 2LICENSE = "AGPLv3"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ee5b168fc7de89a0cadc49e27830aa2c" 3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ee5b168fc7de89a0cadc49e27830aa2c"
4 4
5PR = "r10" 5PR = "r13"
6 6
7PV = "1.1" 7PV = "1.1"
8SRCREV = "ea5db3dcb3bbbe445ae6d1a5611c1f8d547c57b9" 8SRCREV = "ea5db3dcb3bbbe445ae6d1a5611c1f8d547c57b9"
9SRC_URI = "git://github.com/liftoff/GateOne.git \ 9SRC_URI = "git://github.com/liftoff/GateOne.git \
10 file://gateone-avahi.service \ 10 file://gateone-avahi.service \
11 file://server.conf \ 11 file://server.conf \
12 file://gateone.service \
12 " 13 "
13 14
14S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
15 16
16inherit distutils allarch python-dir 17inherit distutils allarch python-dir systemd
17 18
18export prefix = "${localstatedir}/lib" 19export prefix = "${localstatedir}/lib"
19 20
@@ -24,6 +25,9 @@ do_install_append() {
24 install -m 0644 ${WORKDIR}/gateone-avahi.service ${D}${sysconfdir}/avahi/services/ 25 install -m 0644 ${WORKDIR}/gateone-avahi.service ${D}${sysconfdir}/avahi/services/
25 26
26 install -m 0644 ${WORKDIR}/server.conf ${D}/var/lib/gateone/server.conf 27 install -m 0644 ${WORKDIR}/server.conf ${D}/var/lib/gateone/server.conf
28
29 install -d ${D}${systemd_unitdir}/system
30 install -m 0644 ${WORKDIR}/gateone.service ${D}${systemd_unitdir}/system
27} 31}
28 32
29FILES_${PN} = "${localstatedir}/lib ${localstatedir}/log ${localstatedir}/volatile/log ${base_libdir} ${sysconfdir} ${PYTHON_SITEPACKAGES_DIR}" 33FILES_${PN} = "${localstatedir}/lib ${localstatedir}/log ${localstatedir}/volatile/log ${base_libdir} ${sysconfdir} ${PYTHON_SITEPACKAGES_DIR}"
@@ -57,3 +61,5 @@ RDEPENDS_${PN} = "file \
57 python-unixadmin \ 61 python-unixadmin \
58 python-xml \ 62 python-xml \
59 " 63 "
64
65SYSTEMD_SERVICE_${PN} = "gateone.service"
diff --git a/meta-systemd/meta-oe/recipes-connectivity/gateone/gateone_git.bbappend b/meta-systemd/meta-oe/recipes-connectivity/gateone/gateone_git.bbappend
deleted file mode 100644
index 8ec9dfafd..000000000
--- a/meta-systemd/meta-oe/recipes-connectivity/gateone/gateone_git.bbappend
+++ /dev/null
@@ -1,16 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3PRINC := "${@int(PRINC) + 2}"
4
5inherit systemd
6
7SRC_URI += "file://gateone.service"
8
9NATIVE_SYSTEMD_SUPPORT = "1"
10SYSTEMD_SERVICE_${PN} = "gateone.service"
11
12do_install_append() {
13 install -d ${D}${systemd_unitdir}/system
14 install -m 0644 ${WORKDIR}/gateone.service ${D}${systemd_unitdir}/system
15}
16