summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2013-10-01 23:34:10 +0000
committerEric Bénard <eric@eukrea.com>2013-10-02 11:05:50 +0200
commita108b2203a997634f87ac687e81712badaf3c546 (patch)
treea7bb1e351da86cccfdcf8223551826e9f21a72fa
parentd0141728c5b5f61598964947690da54d2f91f10b (diff)
downloadmeta-openembedded-a108b2203a997634f87ac687e81712badaf3c546.tar.gz
krb5: Add PACKAGECONFIG and new configure param to disable keyutils detection
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Eric Bénard <eric@eukrea.com>
-rw-r--r--meta-oe/recipes-connectivity/krb5/krb5/0001-aclocal-Add-parameter-to-disable-keyutils-detection.patch33
-rw-r--r--meta-oe/recipes-connectivity/krb5/krb5_1.11.bb3
2 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/krb5/krb5/0001-aclocal-Add-parameter-to-disable-keyutils-detection.patch b/meta-oe/recipes-connectivity/krb5/krb5/0001-aclocal-Add-parameter-to-disable-keyutils-detection.patch
new file mode 100644
index 000000000..f0c310c5e
--- /dev/null
+++ b/meta-oe/recipes-connectivity/krb5/krb5/0001-aclocal-Add-parameter-to-disable-keyutils-detection.patch
@@ -0,0 +1,33 @@
1From ecb62f3467f493cc0d679323f05367eebbf0fb67 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Tue, 1 Oct 2013 22:22:57 +0200
4Subject: [PATCH] aclocal: Add parameter to disable keyutils detection
5
6Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
7---
8 aclocal.m4 | 4 ++++
9 1 file changed, 4 insertions(+)
10
11diff --git a/aclocal.m4 b/aclocal.m4
12index 210c473..83b1f02 100644
13--- a/aclocal.m4
14+++ b/aclocal.m4
15@@ -1650,11 +1650,15 @@ fi
16 dnl
17 dnl If libkeyutils exists (on Linux) include it and use keyring ccache
18 AC_DEFUN(KRB5_AC_KEYRING_CCACHE,[
19+AC_ARG_ENABLE([keyutils],
20+AC_HELP_STRING([--disable-keyutils],don't enable using keyutils for keyring ccache @<:@enabled@:>@), , enable_keyutils=yes)
21+if test "$enable_keyutils" = yes; then
22 AC_CHECK_HEADERS([keyutils.h],
23 AC_CHECK_LIB(keyutils, add_key,
24 [dnl Pre-reqs were found
25 AC_DEFINE(USE_KEYRING_CCACHE, 1, [Define if the keyring ccache should be enabled])
26 LIBS="-lkeyutils $LIBS"
27 ]))
28+fi
29 ])dnl
30 dnl
31--
321.8.3.2
33
diff --git a/meta-oe/recipes-connectivity/krb5/krb5_1.11.bb b/meta-oe/recipes-connectivity/krb5/krb5_1.11.bb
index 63676fd2b..00ad9f97c 100644
--- a/meta-oe/recipes-connectivity/krb5/krb5_1.11.bb
+++ b/meta-oe/recipes-connectivity/krb5/krb5_1.11.bb
@@ -11,6 +11,7 @@ PR = "r2"
11 11
12SRC_URI = "http://web.mit.edu/kerberos/dist/${PN}/${PV}/${P}-signed.tar \ 12SRC_URI = "http://web.mit.edu/kerberos/dist/${PN}/${PV}/${P}-signed.tar \
13 file://055d1ffa81d0730e92aa3f1ed5045cd805c74957.patch \ 13 file://055d1ffa81d0730e92aa3f1ed5045cd805c74957.patch \
14 file://0001-aclocal-Add-parameter-to-disable-keyutils-detection.patch \
14" 15"
15SRC_URI[md5sum] = "1a13c53899806c4da99a798a04d25545" 16SRC_URI[md5sum] = "1a13c53899806c4da99a798a04d25545"
16SRC_URI[sha256sum] = "fe37fb93b398db98a1b23f814673ea2ae4b90138f85e1a4027ef639456a78651" 17SRC_URI[sha256sum] = "fe37fb93b398db98a1b23f814673ea2ae4b90138f85e1a4027ef639456a78651"
@@ -20,6 +21,7 @@ S = "${WORKDIR}/${P}/src/"
20PACKAGECONFIG ??= "openssl" 21PACKAGECONFIG ??= "openssl"
21PACKAGECONFIG[libedit] = "--with-libedit,--without-libedit,libedit" 22PACKAGECONFIG[libedit] = "--with-libedit,--without-libedit,libedit"
22PACKAGECONFIG[openssl] = "--with-pkinit-crypto-impl=openssl,,openssl" 23PACKAGECONFIG[openssl] = "--with-pkinit-crypto-impl=openssl,,openssl"
24PACKAGECONFIG[keyutils] = "--enable-keyutils,--disable-keyutils,keyutils"
23 25
24EXTRA_OECONF += " --without-tcl --with-system-et --disable-rpath" 26EXTRA_OECONF += " --without-tcl --with-system-et --disable-rpath"
25CACHED_CONFIGUREVARS += "krb5_cv_attr_constructor_destructor=yes ac_cv_func_regcomp=yes \ 27CACHED_CONFIGUREVARS += "krb5_cv_attr_constructor_destructor=yes ac_cv_func_regcomp=yes \
@@ -45,5 +47,6 @@ python do_unpack() {
45 47
46do_configure() { 48do_configure() {
47 gnu-configize --force 49 gnu-configize --force
50 autoreconf
48 oe_runconf 51 oe_runconf
49} 52}