summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJasper Orschulko <jasper@fancydomain.eu>2023-11-27 01:04:17 +0100
committerArmin Kuster <akuster808@gmail.com>2023-12-17 15:36:42 -0500
commita1c4d361ed9e5ef72c74bd2849d6f485939bbd4b (patch)
tree69d5ef07f946131730b1a66ad19a802150483245
parenta005377cdf1efd4aa6681e73bb663bb1c3ebfd4e (diff)
downloadmeta-openembedded-a1c4d361ed9e5ef72c74bd2849d6f485939bbd4b.tar.gz
nginx: Mitigate HTTP/2 Stream Resets Flood impact
Reduces the impact of HTTP/2 Stream Reset flooding in the nginx product (CVE-2023-44487). See: https://www.nginx.com/blog/http-2-rapid-reset-attack-impacting-f5-nginx-products/ This patch only reduces the impact and does not completely mitigate the CVE in question, the latter being due to a design flaw in the HTTP/2 protocol itself. For transparancy reasons I therefore opted to not mark the CVE as resolved, so that integrators can decide for themselves, wheither to enable HTTP/2 support or allow HTTP/1.1 connections only. Signed-off-by: Jasper Orschulko <jasper@fancydomain.eu> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-webserver/recipes-httpd/nginx/files/0001-HTTP-2-per-iteration-stream-handling-limit.patch92
-rw-r--r--meta-webserver/recipes-httpd/nginx/nginx_1.16.1.bb1
-rw-r--r--meta-webserver/recipes-httpd/nginx/nginx_1.17.8.bb2
3 files changed, 95 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/nginx/files/0001-HTTP-2-per-iteration-stream-handling-limit.patch b/meta-webserver/recipes-httpd/nginx/files/0001-HTTP-2-per-iteration-stream-handling-limit.patch
new file mode 100644
index 000000000..7dd1e721c
--- /dev/null
+++ b/meta-webserver/recipes-httpd/nginx/files/0001-HTTP-2-per-iteration-stream-handling-limit.patch
@@ -0,0 +1,92 @@
1From 2b9667f36551406169e3e2a6a774466ac70a83c0 Mon Sep 17 00:00:00 2001
2From: Maxim Dounin <mdounin@mdounin.ru>
3Date: Tue, 10 Oct 2023 15:13:39 +0300
4Subject: [PATCH] HTTP/2: per-iteration stream handling limit.
5
6To ensure that attempts to flood servers with many streams are detected
7early, a limit of no more than 2 * max_concurrent_streams new streams per one
8event loop iteration was introduced. This limit is applied even if
9max_concurrent_streams is not yet reached - for example, if corresponding
10streams are handled synchronously or reset.
11
12Further, refused streams are now limited to maximum of max_concurrent_streams
13and 100, similarly to priority_limit initial value, providing some tolerance
14to clients trying to open several streams at the connection start, yet
15low tolerance to flooding attempts.
16
17Upstream-Status: Backport
18[https://github.com/nginx/nginx/commit/6ceef192e7af1c507826ac38a2d43f08bf265fb9]
19
20Reduces the impact of HTTP/2 Stream Reset flooding in the nginx product
21(CVE-2023-44487).
22
23See: https://www.nginx.com/blog/http-2-rapid-reset-attack-impacting-f5-nginx-products/
24
25This patch only reduces the impact and does not completely mitigate the CVE
26in question, the latter being due to a design flaw in the HTTP/2 protocol
27itself. For transparancy reasons I therefore opted to not mark the
28CVE as resolved, so that integrators can decide for themselves, wheither to
29enable HTTP/2 support or allow HTTP/1.1 connections only.
30
31Signed-off-by: Jasper Orschulko <jasper@fancydomain.eu>
32---
33 src/http/v2/ngx_http_v2.c | 15 +++++++++++++++
34 src/http/v2/ngx_http_v2.h | 2 ++
35 2 files changed, 17 insertions(+)
36
37diff --git a/src/http/v2/ngx_http_v2.c b/src/http/v2/ngx_http_v2.c
38index 3611a2e50..291677aca 100644
39--- a/src/http/v2/ngx_http_v2.c
40+++ b/src/http/v2/ngx_http_v2.c
41@@ -361,6 +361,7 @@ ngx_http_v2_read_handler(ngx_event_t *rev)
42 ngx_log_debug0(NGX_LOG_DEBUG_HTTP, c->log, 0, "http2 read handler");
43
44 h2c->blocked = 1;
45+ h2c->new_streams = 0;
46
47 if (c->close) {
48 c->close = 0;
49@@ -1320,6 +1321,14 @@ ngx_http_v2_state_headers(ngx_http_v2_connection_t *h2c, u_char *pos,
50 goto rst_stream;
51 }
52
53+ if (h2c->new_streams++ >= 2 * h2scf->concurrent_streams) {
54+ ngx_log_error(NGX_LOG_INFO, h2c->connection->log, 0,
55+ "client sent too many streams at once");
56+
57+ status = NGX_HTTP_V2_REFUSED_STREAM;
58+ goto rst_stream;
59+ }
60+
61 if (!h2c->settings_ack
62 && !(h2c->state.flags & NGX_HTTP_V2_END_STREAM_FLAG)
63 && h2scf->preread_size < NGX_HTTP_V2_DEFAULT_WINDOW)
64@@ -1385,6 +1394,12 @@ ngx_http_v2_state_headers(ngx_http_v2_connection_t *h2c, u_char *pos,
65
66 rst_stream:
67
68+ if (h2c->refused_streams++ > ngx_max(h2scf->concurrent_streams, 100)) {
69+ ngx_log_error(NGX_LOG_INFO, h2c->connection->log, 0,
70+ "client sent too many refused streams");
71+ return ngx_http_v2_connection_error(h2c, NGX_HTTP_V2_NO_ERROR);
72+ }
73+
74 if (ngx_http_v2_send_rst_stream(h2c, h2c->state.sid, status) != NGX_OK) {
75 return ngx_http_v2_connection_error(h2c, NGX_HTTP_V2_INTERNAL_ERROR);
76 }
77diff --git a/src/http/v2/ngx_http_v2.h b/src/http/v2/ngx_http_v2.h
78index 349229711..6a7aaa62c 100644
79--- a/src/http/v2/ngx_http_v2.h
80+++ b/src/http/v2/ngx_http_v2.h
81@@ -125,6 +125,8 @@ struct ngx_http_v2_connection_s {
82 ngx_uint_t processing;
83 ngx_uint_t frames;
84 ngx_uint_t idle;
85+ ngx_uint_t new_streams;
86+ ngx_uint_t refused_streams;
87 ngx_uint_t priority_limit;
88
89 ngx_uint_t pushing;
90--
912.42.1
92
diff --git a/meta-webserver/recipes-httpd/nginx/nginx_1.16.1.bb b/meta-webserver/recipes-httpd/nginx/nginx_1.16.1.bb
index 07e9f6ddb..39cfd3a67 100644
--- a/meta-webserver/recipes-httpd/nginx/nginx_1.16.1.bb
+++ b/meta-webserver/recipes-httpd/nginx/nginx_1.16.1.bb
@@ -7,4 +7,5 @@ SRC_URI[sha256sum] = "f11c2a6dd1d3515736f0324857957db2de98be862461b5a542a3ac6188
7 7
8SRC_URI += "file://CVE-2019-20372.patch \ 8SRC_URI += "file://CVE-2019-20372.patch \
9 file://CVE-2022-41741-CVE-2022-41742.patch \ 9 file://CVE-2022-41741-CVE-2022-41742.patch \
10 file://0001-HTTP-2-per-iteration-stream-handling-limit.patch \
10 " 11 "
diff --git a/meta-webserver/recipes-httpd/nginx/nginx_1.17.8.bb b/meta-webserver/recipes-httpd/nginx/nginx_1.17.8.bb
index 3d2a5edd2..9fd6d7342 100644
--- a/meta-webserver/recipes-httpd/nginx/nginx_1.17.8.bb
+++ b/meta-webserver/recipes-httpd/nginx/nginx_1.17.8.bb
@@ -8,3 +8,5 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=52e384aaac868b755b93ad5535e2d075"
8 8
9SRC_URI[md5sum] = "29cd861a13aae69a058cbabaae86177b" 9SRC_URI[md5sum] = "29cd861a13aae69a058cbabaae86177b"
10SRC_URI[sha256sum] = "97d23ecf6d5150b30e284b40e8a6f7e3bb5be6b601e373a4d013768d5a25965b" 10SRC_URI[sha256sum] = "97d23ecf6d5150b30e284b40e8a6f7e3bb5be6b601e373a4d013768d5a25965b"
11
12SRC_URI += "file://0001-HTTP-2-per-iteration-stream-handling-limit.patch"