summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2023-11-20 23:32:18 +0100
committerArmin Kuster <akuster808@gmail.com>2023-12-17 15:36:42 -0500
commit91a1284a8ca86bb269087ecd6fcff1ff40534130 (patch)
treec66a872159aabad8940b05de1eb93d2437d16d3e
parenta7ead38b9ce2994b1864b48f350895eb6fd19a52 (diff)
downloadmeta-openembedded-91a1284a8ca86bb269087ecd6fcff1ff40534130.tar.gz
meta-python: Drop broken BBCLASSEXTEND variants
The command "bitbake universe -c fetch" currently throws a ton of warnings as there are many 'impossible' dependencies. In some cases these variants may never have worked and were just added by copy and paste of recipes. In some cases they once clearly did work but became broken somewhere along the way. Users may also be carrying local bbappend files which add further BBCLASSEXTEND. Having universe fetch work without warnings is desireable so clean up the broken variants. Anyone actually needing something dropped here can propose adding it and the correct functional dependencies back quite easily. This also then ensures we're not carrying or fixing things nobody uses. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit d4aa17dc436beb96a804860bc6d18cf72283709e) Backport: * Adapted paths to follow PV changes * Adapted modified recipes to the ones generating warnings Signed-off-by: Yoann Congal <yoann.congal@smile.fr> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-pint.inc2
-rw-r--r--meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-matplotlib_3.2.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow_6.2.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pyflakes_2.1.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb2
6 files changed, 0 insertions, 12 deletions
diff --git a/meta-python/recipes-devtools/python/python-pint.inc b/meta-python/recipes-devtools/python/python-pint.inc
index d022c41a5..5d880a039 100644
--- a/meta-python/recipes-devtools/python/python-pint.inc
+++ b/meta-python/recipes-devtools/python/python-pint.inc
@@ -14,8 +14,6 @@ SRC_URI[sha256sum] = "308f1070500e102f83b6adfca6db53debfce2ffc5d3cbe3f6c367da359
14 14
15DEPENDS += "python3-setuptools-scm-native" 15DEPENDS += "python3-setuptools-scm-native"
16 16
17BBCLASSEXTEND = "native nativesdk"
18
19SRC_URI += " \ 17SRC_URI += " \
20 file://run-ptest \ 18 file://run-ptest \
21" 19"
diff --git a/meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb b/meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb
index 803ca4a40..24e38cfb4 100644
--- a/meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb
+++ b/meta-python/recipes-devtools/python/python3-cmd2_0.9.23.bb
@@ -16,5 +16,3 @@ RDEPENDS_${PN} += "\
16 ${PYTHON_PN}-pyperclip \ 16 ${PYTHON_PN}-pyperclip \
17 ${PYTHON_PN}-wcwidth \ 17 ${PYTHON_PN}-wcwidth \
18" 18"
19
20BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib_3.2.1.bb b/meta-python/recipes-devtools/python/python3-matplotlib_3.2.1.bb
index 33f0efe84..57d38e60b 100644
--- a/meta-python/recipes-devtools/python/python3-matplotlib_3.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-matplotlib_3.2.1.bb
@@ -34,5 +34,3 @@ RDEPENDS_${PN} = "\
34 python3-pytz \ 34 python3-pytz \
35 python3-pillow \ 35 python3-pillow \
36" 36"
37
38BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-pillow_6.2.1.bb b/meta-python/recipes-devtools/python/python3-pillow_6.2.1.bb
index 35330cac6..eda0bd57d 100644
--- a/meta-python/recipes-devtools/python/python3-pillow_6.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pillow_6.2.1.bb
@@ -35,5 +35,3 @@ CVE_PRODUCT = "pillow"
35S = "${WORKDIR}/git" 35S = "${WORKDIR}/git"
36 36
37RPROVIDES_${PN} += "python3-imaging" 37RPROVIDES_${PN} += "python3-imaging"
38
39BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-pyflakes_2.1.1.bb b/meta-python/recipes-devtools/python/python3-pyflakes_2.1.1.bb
index c13882240..6636fda83 100644
--- a/meta-python/recipes-devtools/python/python3-pyflakes_2.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pyflakes_2.1.1.bb
@@ -12,5 +12,3 @@ RDEPENDS_${PN} += " \
12 ${PYTHON_PN}-prettytable \ 12 ${PYTHON_PN}-prettytable \
13 ${PYTHON_PN}-cmd2 \ 13 ${PYTHON_PN}-cmd2 \
14 ${PYTHON_PN}-pyparsing" 14 ${PYTHON_PN}-pyparsing"
15
16BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb b/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb
index b6de42f7c..60a26f58b 100644
--- a/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb
+++ b/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb
@@ -16,5 +16,3 @@ RDEPENDS_${PN} += " \
16 ${PYTHON_PN}-pyserial \ 16 ${PYTHON_PN}-pyserial \
17 ${PYTHON_PN}-robotframework \ 17 ${PYTHON_PN}-robotframework \
18" 18"
19
20BBCLASSEXTEND = "native nativesdk"