summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHitendra Prajapati <hprajapati@mvista.com>2024-01-10 10:40:57 +0530
committerArmin Kuster <akuster808@gmail.com>2024-03-03 16:38:27 -0500
commit84a84000f735ac54b8668161768563a9b32602a3 (patch)
tree23488f59f2ffd0f77827ac8d2b8d6a60a9b56fe8
parent10d8982782b32a3940d2b2b57927ae6978e0f472 (diff)
downloadmeta-openembedded-84a84000f735ac54b8668161768563a9b32602a3.tar.gz
wireshark: fix CVE-2024-0208 GVCP dissector crash
Upstream-Status: Backport from https://gitlab.com/wireshark/wireshark/-/commit/a8586fde3a6512466afb2a660538ef3fe712076b Signed-off-by: Hitendra Prajapati <hprajapati@mvista.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-support/wireshark/files/CVE-2024-0208.patch42
-rw-r--r--meta-networking/recipes-support/wireshark/wireshark_3.2.18.bb1
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/wireshark/files/CVE-2024-0208.patch b/meta-networking/recipes-support/wireshark/files/CVE-2024-0208.patch
new file mode 100644
index 000000000..c4dfb6c37
--- /dev/null
+++ b/meta-networking/recipes-support/wireshark/files/CVE-2024-0208.patch
@@ -0,0 +1,42 @@
1From a8586fde3a6512466afb2a660538ef3fe712076b Mon Sep 17 00:00:00 2001
2From: John Thacker <johnthacker@gmail.com>
3Date: Thu, 23 Nov 2023 13:47:51 -0500
4Subject: [PATCH] gvcp: Don't try to add a NULL string to a column
5
6This was caught as an invalid argument by g_strlcpy before 4.2,
7but it was never a good idea.
8
9Fix #19496
10
11Upstream-Status: Backport [https://gitlab.com/wireshark/wireshark/-/commit/a8586fde3a6512466afb2a660538ef3fe712076b]
12CVE: CVE-2024-0208
13Signed-off-by: Hitendra Prajapati <hprajapati@mvista.com>
14---
15 epan/dissectors/packet-gvcp.c | 7 ++-----
16 1 file changed, 2 insertions(+), 5 deletions(-)
17
18diff --git a/epan/dissectors/packet-gvcp.c b/epan/dissectors/packet-gvcp.c
19index 2de4552..b94ddea 100644
20--- a/epan/dissectors/packet-gvcp.c
21+++ b/epan/dissectors/packet-gvcp.c
22@@ -2222,15 +2222,12 @@ static void dissect_readreg_ack(proto_tree *gvcp_telegram_tree, tvbuff_t *tvb, p
23 if (addr_list_size > 0)
24 {
25 address_string = get_register_name_from_address(*((guint32*)wmem_array_index(gvcp_trans->addr_list, 0)), gvcp_info, &is_custom_register);
26+ col_append_str(pinfo->cinfo, COL_INFO, address_string);
27 }
28
29 if (num_registers)
30 {
31- col_append_fstr(pinfo->cinfo, COL_INFO, "%s Value=0x%08X", address_string, tvb_get_ntohl(tvb, offset));
32- }
33- else
34- {
35- col_append_str(pinfo->cinfo, COL_INFO, address_string);
36+ col_append_sep_fstr(pinfo->cinfo, COL_INFO, " ", "Value=0x%08X", tvb_get_ntohl(tvb, offset));
37 }
38 }
39 }
40--
412.25.1
42
diff --git a/meta-networking/recipes-support/wireshark/wireshark_3.2.18.bb b/meta-networking/recipes-support/wireshark/wireshark_3.2.18.bb
index 7d99a1438..b36a0acbf 100644
--- a/meta-networking/recipes-support/wireshark/wireshark_3.2.18.bb
+++ b/meta-networking/recipes-support/wireshark/wireshark_3.2.18.bb
@@ -21,6 +21,7 @@ SRC_URI = "https://1.eu.dl.wireshark.org/src/all-versions/wireshark-${PV}.tar.xz
21 file://CVE-2023-3649.patch \ 21 file://CVE-2023-3649.patch \
22 file://CVE-2022-0585-CVE-2023-2879.patch \ 22 file://CVE-2022-0585-CVE-2023-2879.patch \
23 file://CVE-2022-4345.patch \ 23 file://CVE-2022-4345.patch \
24 file://CVE-2024-0208.patch \
24 " 25 "
25UPSTREAM_CHECK_URI = "https://1.as.dl.wireshark.org/src" 26UPSTREAM_CHECK_URI = "https://1.as.dl.wireshark.org/src"
26 27