summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-07-01 07:23:21 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-07-08 10:35:57 +0200
commit830baf380ea86782a5a52fbe8762904840e05691 (patch)
tree3a6da23c5ef6f80540874e53478f5da3c3df297e
parent8d0528448b9b79437cf04cd12b7a0dc282df3c48 (diff)
downloadmeta-openembedded-830baf380ea86782a5a52fbe8762904840e05691.tar.gz
uhd: Fix compile errors
uhd would fail with wrong scope for uint8_t type errors. Signed-off-by: Khem Raj <raj.khem@gmail.com> CC: Philip Balister <philip@balister.org> Acked-by: Philip Balister <philip@balister.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/uhd/uhd/0001-use-uint8_t-from-boost-namespace.patch29
-rw-r--r--meta-oe/recipes-connectivity/uhd/uhd_git.bb3
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-oe/recipes-connectivity/uhd/uhd/0001-use-uint8_t-from-boost-namespace.patch b/meta-oe/recipes-connectivity/uhd/uhd/0001-use-uint8_t-from-boost-namespace.patch
new file mode 100644
index 000000000..8978ddcc4
--- /dev/null
+++ b/meta-oe/recipes-connectivity/uhd/uhd/0001-use-uint8_t-from-boost-namespace.patch
@@ -0,0 +1,29 @@
1From 317f6f08cedf005ce1f2d6f0d04cfb2659863423 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 30 Jun 2013 22:10:50 -0700
4Subject: [PATCH] use uint8_t from boost namespace
5
6Fixes errors like
7codec_ctrl.cpp:113:10: error: 'uint8_t' was not declared in this scope
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 host/lib/usrp/e100/codec_ctrl.cpp | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/host/lib/usrp/e100/codec_ctrl.cpp b/host/lib/usrp/e100/codec_ctrl.cpp
15index 13b3bc9..2c13176 100644
16--- a/host/lib/usrp/e100/codec_ctrl.cpp
17+++ b/host/lib/usrp/e100/codec_ctrl.cpp
18@@ -110,7 +110,7 @@ e100_codec_ctrl_impl::e100_codec_ctrl_impl(spi_iface::sptr iface){
19 //_ad9862_regs.dis2 = ad9862_regs_t::DIS2_DIS; needed for transmit
20
21 //write the register settings to the codec
22- for (uint8_t addr = 0; addr <= 25; addr++){
23+ for (boost::uint8_t addr = 0; addr <= 25; addr++){
24 this->send_reg(addr);
25 }
26
27--
281.7.9.5
29
diff --git a/meta-oe/recipes-connectivity/uhd/uhd_git.bb b/meta-oe/recipes-connectivity/uhd/uhd_git.bb
index 06d5effbd..180fd27c7 100644
--- a/meta-oe/recipes-connectivity/uhd/uhd_git.bb
+++ b/meta-oe/recipes-connectivity/uhd/uhd_git.bb
@@ -4,7 +4,8 @@ PV = "3.5.3"
4PR = "${INC_PR}.0" 4PR = "${INC_PR}.0"
5 5
6SRC_URI = "git://ettus.sourcerepo.com/ettus/uhd.git;branch=maint;protocol=git \ 6SRC_URI = "git://ettus.sourcerepo.com/ettus/uhd.git;branch=maint;protocol=git \
7" 7 file://0001-use-uint8_t-from-boost-namespace.patch;striplevel=2 \
8 "
8S = "${WORKDIR}/git/host" 9S = "${WORKDIR}/git/host"
9 10
10SRCREV = "f4c58120dc1e3674ee0228213f0f0011a0f80dcf" 11SRCREV = "f4c58120dc1e3674ee0228213f0f0011a0f80dcf"