summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2013-10-12 09:19:53 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-10-15 13:43:53 +0200
commitf8903f53db717294d63a8d79b5ef7ca34b3c189e (patch)
tree1ac9a0effdb7e9138c5f4320b24348fc514a83f8
parent0e2a691f78669e27a44c03b8a79bd0d0b2dfed0a (diff)
downloadmeta-openembedded-f8903f53db717294d63a8d79b5ef7ca34b3c189e.tar.gz
libhugetlbfs: install perl lib to directory perl instead of perl5
*libhugetlbfs depends on perl, and perl installs a directory 'perl' and make a symlink 'perl5' to it. So just install perl libs in libhugetlbfs to directory 'perl' instead of 'perl5'. This can avoid the following error: | CalledProcessError: Command 'tar -cf - -C .../perl/5.14.3-r1/sysroot-destdir | -ps . | tar -xf - -C .../tmp/sysroots/t4240qds' | returned non-zero exit status 2 with output | tar: ./usr/lib/perl5: Cannot create symlink to `perl': File exists | tar: Exiting with failure status due to previous errors Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/files/0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch39
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb4
2 files changed, 41 insertions, 2 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch
new file mode 100644
index 000000000..0b8d0e4d5
--- /dev/null
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch
@@ -0,0 +1,39 @@
1Upstream-Status: Inappropriate [oe-core specific]
2
3libhugetlbfs depends on perl, and perl installs a directory 'perl'
4and make a symlink 'perl5' to it. So just install perl libs in
5libhugetlbfs to directory 'perl' instead of 'perl5'. This can avoid
6the following error:
7| CalledProcessError: Command 'tar -cf - -C .../perl/5.14.3-r1/sysroot-destdir
8| -ps . | tar -xf - -C .../tmp/sysroots/t4240qds'
9| returned non-zero exit status 2 with output
10| tar: ./usr/lib/perl5: Cannot create symlink to `perl': File exists
11| tar: Exiting with failure status due to previous errors
12
13
14Signed-off-by: Ting Liu <b28495@freescale.com>
15
16--- a/Makefileold 2013-10-11 23:07:31.759421318 -0500
17+++ b/Makefile 2013-10-11 23:08:01.935571122 -0500
18@@ -173,17 +173,17 @@
19 DOCDIR = $(PREFIX)/share/doc/libhugetlbfs
20
21 ifdef CC32
22-PMDIR = $(PREFIX)/lib/perl5/TLBC
23+PMDIR = $(PREFIX)/lib/perl/TLBC
24 endif
25
26 ifdef CC64
27 ifeq ($(ARCH),x86_64)
28-PMDIR = $(PREFIX)/lib/perl5/TLBC
29+PMDIR = $(PREFIX)/lib/perl/TLBC
30 else
31 ifeq ($(ARCH),aarch64)
32-PMDIR = $(PREFIX)/lib/perl5/TLBC
33+PMDIR = $(PREFIX)/lib/perl/TLBC
34 else
35-PMDIR = $(PREFIX)/lib64/perl5/TLBC
36+PMDIR = $(PREFIX)/lib64/perl/TLBC
37 endif
38 endif
39 endif
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
index 5b871e988..24480c364 100644
--- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
@@ -15,6 +15,7 @@ SRC_URI = "git://git.code.sf.net/p/libhugetlbfs/code \
15 file://fix-lib64-can-not-be-shiped-in-64bit-target.patch \ 15 file://fix-lib64-can-not-be-shiped-in-64bit-target.patch \
16 file://tests-Makefile-install-static-4G-edge-testcases.patch \ 16 file://tests-Makefile-install-static-4G-edge-testcases.patch \
17 file://0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch \ 17 file://0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch \
18 file://0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch \
18" 19"
19 20
20S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
@@ -43,10 +44,9 @@ do_install() {
43 44
44PARALLEL_MAKE_pn-${PN} = "" 45PARALLEL_MAKE_pn-${PN} = ""
45 46
46PACKAGES =+ "${PN}-perl ${PN}-tests ${PN}-perl5" 47PACKAGES =+ "${PN}-perl ${PN}-tests "
47FILES_${PN}-dbg += "${libdir}/libhugetlbfs/tests/obj32/.debug ${libdir}/libhugetlbfs/tests/obj64/.debug" 48FILES_${PN}-dbg += "${libdir}/libhugetlbfs/tests/obj32/.debug ${libdir}/libhugetlbfs/tests/obj64/.debug"
48FILES_${PN}-perl = "${libdir}/perl" 49FILES_${PN}-perl = "${libdir}/perl"
49FILES_${PN}-perl5 = "${libdir}/perl5 "
50FILES_${PN}-tests += "/opt/libhugetlbfs/tests" 50FILES_${PN}-tests += "/opt/libhugetlbfs/tests"
51 51
52INHIBIT_PACKAGE_DEBUG_SPLIT = "1" 52INHIBIT_PACKAGE_DEBUG_SPLIT = "1"