summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2013-10-01 23:36:44 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-10-05 12:36:25 +0200
commitc9a41e656f5d8dc01eae6ce83ab9afe29b749826 (patch)
tree1577f82d84539940a832c1f0f3b7acf186ee410f
parenta5618c6f15415e4ab27f3ce1afb66276a7b808b0 (diff)
downloadmeta-openembedded-c9a41e656f5d8dc01eae6ce83ab9afe29b749826.tar.gz
krb5: Add PACKAGECONFIG and new configure param to disable keyutils detection
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/krb5/krb5/0001-aclocal-Add-parameter-to-disable-keyutils-detection.patch33
-rw-r--r--meta-oe/recipes-connectivity/krb5/krb5_1.11.3.bb6
2 files changed, 38 insertions, 1 deletions
diff --git a/meta-oe/recipes-connectivity/krb5/krb5/0001-aclocal-Add-parameter-to-disable-keyutils-detection.patch b/meta-oe/recipes-connectivity/krb5/krb5/0001-aclocal-Add-parameter-to-disable-keyutils-detection.patch
new file mode 100644
index 000000000..f0c310c5e
--- /dev/null
+++ b/meta-oe/recipes-connectivity/krb5/krb5/0001-aclocal-Add-parameter-to-disable-keyutils-detection.patch
@@ -0,0 +1,33 @@
1From ecb62f3467f493cc0d679323f05367eebbf0fb67 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Tue, 1 Oct 2013 22:22:57 +0200
4Subject: [PATCH] aclocal: Add parameter to disable keyutils detection
5
6Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
7---
8 aclocal.m4 | 4 ++++
9 1 file changed, 4 insertions(+)
10
11diff --git a/aclocal.m4 b/aclocal.m4
12index 210c473..83b1f02 100644
13--- a/aclocal.m4
14+++ b/aclocal.m4
15@@ -1650,11 +1650,15 @@ fi
16 dnl
17 dnl If libkeyutils exists (on Linux) include it and use keyring ccache
18 AC_DEFUN(KRB5_AC_KEYRING_CCACHE,[
19+AC_ARG_ENABLE([keyutils],
20+AC_HELP_STRING([--disable-keyutils],don't enable using keyutils for keyring ccache @<:@enabled@:>@), , enable_keyutils=yes)
21+if test "$enable_keyutils" = yes; then
22 AC_CHECK_HEADERS([keyutils.h],
23 AC_CHECK_LIB(keyutils, add_key,
24 [dnl Pre-reqs were found
25 AC_DEFINE(USE_KEYRING_CCACHE, 1, [Define if the keyring ccache should be enabled])
26 LIBS="-lkeyutils $LIBS"
27 ]))
28+fi
29 ])dnl
30 dnl
31--
321.8.3.2
33
diff --git a/meta-oe/recipes-connectivity/krb5/krb5_1.11.3.bb b/meta-oe/recipes-connectivity/krb5/krb5_1.11.3.bb
index 820a13515..d0dfc46bf 100644
--- a/meta-oe/recipes-connectivity/krb5/krb5_1.11.3.bb
+++ b/meta-oe/recipes-connectivity/krb5/krb5_1.11.3.bb
@@ -8,7 +8,9 @@ DEPENDS = "ncurses util-linux e2fsprogs e2fsprogs-native"
8inherit autotools binconfig perlnative 8inherit autotools binconfig perlnative
9 9
10SHRT_VER = "${@oe.utils.trim_version("${PV}", 2)}" 10SHRT_VER = "${@oe.utils.trim_version("${PV}", 2)}"
11SRC_URI = "http://web.mit.edu/kerberos/dist/${PN}/${SHRT_VER}/${P}-signed.tar" 11SRC_URI = "http://web.mit.edu/kerberos/dist/${PN}/${SHRT_VER}/${P}-signed.tar \
12 file://0001-aclocal-Add-parameter-to-disable-keyutils-detection.patch \
13"
12SRC_URI[md5sum] = "56f0ae274b285320b8a597cb89442449" 14SRC_URI[md5sum] = "56f0ae274b285320b8a597cb89442449"
13SRC_URI[sha256sum] = "9abd94bb94a70996da0f8d90408957154bb543271b097e86c63eb33e5f5751b5" 15SRC_URI[sha256sum] = "9abd94bb94a70996da0f8d90408957154bb543271b097e86c63eb33e5f5751b5"
14 16
@@ -17,6 +19,7 @@ S = "${WORKDIR}/${P}/src/"
17PACKAGECONFIG ??= "openssl" 19PACKAGECONFIG ??= "openssl"
18PACKAGECONFIG[libedit] = "--with-libedit,--without-libedit,libedit" 20PACKAGECONFIG[libedit] = "--with-libedit,--without-libedit,libedit"
19PACKAGECONFIG[openssl] = "--with-pkinit-crypto-impl=openssl,,openssl" 21PACKAGECONFIG[openssl] = "--with-pkinit-crypto-impl=openssl,,openssl"
22PACKAGECONFIG[keyutils] = "--enable-keyutils,--disable-keyutils,keyutils"
20 23
21EXTRA_OECONF += " --without-tcl --with-system-et --disable-rpath" 24EXTRA_OECONF += " --without-tcl --with-system-et --disable-rpath"
22CACHED_CONFIGUREVARS += "krb5_cv_attr_constructor_destructor=yes ac_cv_func_regcomp=yes \ 25CACHED_CONFIGUREVARS += "krb5_cv_attr_constructor_destructor=yes ac_cv_func_regcomp=yes \
@@ -42,5 +45,6 @@ python do_unpack() {
42 45
43do_configure() { 46do_configure() {
44 gnu-configize --force 47 gnu-configize --force
48 autoreconf
45 oe_runconf 49 oe_runconf
46} 50}