summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2013-10-11 08:09:00 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-10-14 14:27:37 +0200
commit9fede488dc6f1320f6000be93953a887ade52eb7 (patch)
tree8a0aad2ee05617c94d1a0caa84d8e247f6dc9eb4
parent0933085d534099ef7b355a3617bc8c220aa4b475 (diff)
downloadmeta-openembedded-9fede488dc6f1320f6000be93953a887ade52eb7.tar.gz
python-numpy: add config files for armeb architecture
Fix python-numpy build failure on armeb architecture. Signed-off-by: Anders Roxell <anders.roxell@linaro.org> Acked-by: Koen Kooi <koen.kooi@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy/armeb/config.h21
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy/armeb/numpyconfig.h17
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb5
3 files changed, 43 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-numpy/armeb/config.h b/meta-oe/recipes-devtools/python/python-numpy/armeb/config.h
new file mode 100644
index 000000000..17ef186d5
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-numpy/armeb/config.h
@@ -0,0 +1,21 @@
1/* ./src.linux-i686-2.5/numpy/core/include/numpy/config.h */
2/* #define SIZEOF_SHORT 2 */
3/* #define SIZEOF_INT 4 */
4/* #define SIZEOF_LONG 4 */
5/* #define SIZEOF_FLOAT 4 */
6/* #define SIZEOF_DOUBLE 8 */
7#define SIZEOF_LONG_DOUBLE 12
8#define SIZEOF_PY_INTPTR_T 4
9/* #define SIZEOF_LONG_LONG 8 */
10#define SIZEOF_PY_LONG_LONG 8
11/* #define CHAR_BIT 8 */
12#define MATHLIB m
13#define HAVE_FLOAT_FUNCS
14#define HAVE_LOG1P
15#define HAVE_EXPM1
16#define HAVE_INVERSE_HYPERBOLIC
17#define HAVE_INVERSE_HYPERBOLIC_FLOAT
18#define HAVE_ISNAN
19#define HAVE_ISINF
20#define HAVE_RINT
21
diff --git a/meta-oe/recipes-devtools/python/python-numpy/armeb/numpyconfig.h b/meta-oe/recipes-devtools/python/python-numpy/armeb/numpyconfig.h
new file mode 100644
index 000000000..c4bf6547f
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-numpy/armeb/numpyconfig.h
@@ -0,0 +1,17 @@
1/* cat ./src.linux-i686-2.5/numpy/core/include/numpy/numpyconfig.h */
2/*
3 * * This file is generated by numpy/core/setup.pyc. DO NOT EDIT
4 * */
5#define NPY_SIZEOF_SHORT 2
6#define NPY_SIZEOF_INT 4
7#define NPY_SIZEOF_LONG 4
8#define NPY_SIZEOF_FLOAT 4
9#define NPY_SIZEOF_DOUBLE 8
10#define NPY_SIZEOF_LONGDOUBLE 12
11#define NPY_SIZEOF_PY_INTPTR_T 4
12#define NPY_NO_SMP 0
13
14#define NPY_SIZEOF_LONGLONG 8
15#define NPY_SIZEOF_PY_LONG_LONG 8
16/* #define CHAR_BIT 8 */
17
diff --git a/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb b/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb
index 7d2f2e214..e6d328f94 100644
--- a/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb
+++ b/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb
@@ -2,6 +2,7 @@ DESCRIPTION = "A sophisticated Numeric Processing Package for Python"
2SECTION = "devel/python" 2SECTION = "devel/python"
3LICENSE = "PSF" 3LICENSE = "PSF"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f87832d854acbade6e9f5c601c8b30b1" 4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f87832d854acbade6e9f5c601c8b30b1"
5PR = "r1"
5 6
6SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \ 7SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \
7 ${CONFIGFILESURI} " 8 ${CONFIGFILESURI} "
@@ -16,6 +17,10 @@ CONFIGFILESURI_arm = " \
16 file://config.h \ 17 file://config.h \
17 file://numpyconfig.h \ 18 file://numpyconfig.h \
18" 19"
20CONFIGFILESURI_armeb = " \
21 file://config.h \
22 file://numpyconfig.h \
23"
19CONFIGFILESURI_mipsel = " \ 24CONFIGFILESURI_mipsel = " \
20 file://config.h \ 25 file://config.h \
21 file://numpyconfig.h \ 26 file://numpyconfig.h \