summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthieu CRAPET <Matthieu.CRAPET@ingenico.com>2014-03-20 13:33:49 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-04-20 15:38:26 +0200
commit6291199ee4c9dde2ac05e1d48372c667f92b14ff (patch)
treeda49248b5f706cb839f65a541ee6cb053dd7ed0a
parent40e0f371f3eb1628655c484feac0cebf810737b4 (diff)
downloadmeta-openembedded-6291199ee4c9dde2ac05e1d48372c667f92b14ff.tar.gz
bash-completion: fix 'files already exist' WARNING message
Some bash completion commands are already provided by util-linux recipe. Also disable parallel build because "symlinks" rule is buggy (see completions/Makefile.am). Signed-off-by: Matthieu CRAPET <Matthieu.CRAPET@ingenico.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/bash-completion/bash-completion_2.0.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/bash-completion/bash-completion_2.0.bb b/meta-oe/recipes-support/bash-completion/bash-completion_2.0.bb
index 411b9b7e1..014d122cb 100644
--- a/meta-oe/recipes-support/bash-completion/bash-completion_2.0.bb
+++ b/meta-oe/recipes-support/bash-completion/bash-completion_2.0.bb
@@ -5,6 +5,8 @@ BUGTRACKER = "https://alioth.debian.org/projects/bash-completion/"
5LICENSE = "GPLv2" 5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" 6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
7 7
8PR = "r1"
9
8SECTION = "console/utils" 10SECTION = "console/utils"
9 11
10SRC_URI="http://bash-completion.alioth.debian.org/files/${BPN}-${PV}.tar.bz2" 12SRC_URI="http://bash-completion.alioth.debian.org/files/${BPN}-${PV}.tar.bz2"
@@ -12,11 +14,19 @@ SRC_URI="http://bash-completion.alioth.debian.org/files/${BPN}-${PV}.tar.bz2"
12SRC_URI[md5sum] = "0d903f398be8c8f24bc5ffa6f86127f8" 14SRC_URI[md5sum] = "0d903f398be8c8f24bc5ffa6f86127f8"
13SRC_URI[sha256sum] = "e5a490a4301dfb228361bdca2ffca597958e47dd6056005ef9393a5852af5804" 15SRC_URI[sha256sum] = "e5a490a4301dfb228361bdca2ffca597958e47dd6056005ef9393a5852af5804"
14 16
17PARALLEL_MAKE = ""
18
15inherit allarch autotools 19inherit allarch autotools
16 20
17do_install_append() { 21do_install_append() {
18 install -d ${D}${sysconfdir}/bash_completion.d/ 22 install -d ${D}${sysconfdir}/bash_completion.d/
19 echo '. ${datadir}/${BPN}/bash_completion' >${D}${sysconfdir}/bash_completion 23 echo '. ${datadir}/${BPN}/bash_completion' >${D}${sysconfdir}/bash_completion
24
25 # Delete files already provided by util-linux
26 local i
27 for i in cal dmesg hwclock ionice look renice rtcwake; do
28 rm ${D}${datadir}/${BPN}/completions/$i
29 done
20} 30}
21 31
22RDEPENDS_${PN} = "bash" 32RDEPENDS_${PN} = "bash"