summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-12-27 03:15:13 -0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-01-04 11:58:30 +0100
commit0d8112b33d8424a19b0aaae107d18559e06db35a (patch)
treed353a3ffe3173a637fcc098e5293c75bd91bbe16
parenteb4563b83be0a57ede4269ab19688af6baa62cd2 (diff)
downloadmeta-openembedded-0d8112b33d8424a19b0aaae107d18559e06db35a.tar.gz
gdal: Add recipe for 1.10.1 version
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-navigation/gdal/gdal_1.10.1.bb105
1 files changed, 105 insertions, 0 deletions
diff --git a/meta-oe/recipes-navigation/gdal/gdal_1.10.1.bb b/meta-oe/recipes-navigation/gdal/gdal_1.10.1.bb
new file mode 100644
index 000000000..4632944fb
--- /dev/null
+++ b/meta-oe/recipes-navigation/gdal/gdal_1.10.1.bb
@@ -0,0 +1,105 @@
1DESCRIPTION = "GDAL is a translator library for raster geospatial data formats"
2HOMEPAGE = "http://www.gdal.org/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=b9bd75ae5af7ff87ab259be0121c4106"
5
6DEPENDS = "proj sqlite3"
7
8SRC_URI = "ftp://download.osgeo.org/gdal/${PV}/${P}.tar.xz"
9
10SRC_URI[md5sum] = "f354c614aea76e5630e4edbf06e5c292"
11SRC_URI[sha256sum] = "e6c9c6c4480228c943af29120d87435ddfe9ca460458bc60b91639fb8d443791"
12
13inherit autotools lib_package binconfig
14
15EXTRA_OECONF = "--without-perl \
16 --without-php \
17 --without-ruby \
18 --without-python \
19 \
20 --without-grass \
21 --without-libgrass \
22 --without-cfitsio \
23 --without-dds \
24 --without-gta \
25 --without-pcidsk \
26 --without-ogdi \
27 --without-fme \
28 --without-hdf4 \
29 --without-hdf5 \
30 --without-pg \
31 --without-jpeg12 \
32 --without-ogdi \
33 --without-netcdf \
34 --without-openjpeg \
35 --without-fgdb \
36 --without-ecw \
37 --without-kakadu \
38 --without-mrsid \
39 --without-jp2mrsid \
40 --without-mrsid_lidar \
41 --without-msg \
42 --without-bsb \
43 --without-grib \
44 --without-mysql \
45 --without-ingres \
46 --without-odbc \
47 --without-dods_root \
48 --without-xml2 \
49 --without-spatialite \
50 --without-pcre \
51 --without-dwgdirect \
52 --without-dwgdirect \
53 --without-idb \
54 --without-sde \
55 --without-sde-version \
56 --without-epsilon \
57 --without-webp \
58 --without-opencl \
59 --without-opencl-include \
60 --without-opencl-lib \
61 --without-freexl \
62 --without-pam \
63 --without-poppler \
64 --without-podofo \
65 --without-podofo-lib \
66 --without-podofo-extra-lib-for-test \
67 --without-static_proj4 \
68 --without-perl \
69 --without-php \
70 --without-ruby \
71 --without-python \
72 --without-java \
73 --without-mdb \
74 --without-jvm-lib \
75 --without-jvm-lib-add-rpath \
76 --without-rasdaman \
77 --without-armadillo \
78 \
79 --with-pcraster=internal \
80 --with-geotiff=internal \
81"
82
83EXTRA_OEMAKE += "INST_DATA="${datadir}/gdal""
84
85PACKAGECONFIG ?= "geos png jasper"
86PACKAGECONFIG[geos] = "--with-geos,--without-geos,geos"
87PACKAGECONFIG[lzma] = "--with-liblzma,--without-liblzma,xz"
88PACKAGECONFIG[png] = "--with-png,--without-png,libpng"
89PACKAGECONFIG[tiff] = "--with-libtiff,--without-tiff,tiff"
90PACKAGECONFIG[gif] = "--with-gif,--without-gif,giflib"
91PACKAGECONFIG[jpeg] = "--with-jpeg,--without-jpeg,jpeg"
92PACKAGECONFIG[z] = "--with-libz,--without-libz,zlib"
93PACKAGECONFIG[jasper] = "--with-jasper,--without-jasper,jasper"
94PACKAGECONFIG[curl] = "--with-curl,--without-curl,curl"
95
96do_configure_prepend () {
97 # The configure script has many hardcoded paths to search
98 # for the library headers when using external libraries,
99 # workaround it.
100 sed -e 's,/usr/include,NON_EXISTENT_DIR,g' \
101 -e 's,/usr/lib,NON_EXISTENT_DIR,g' \
102 -i ${S}/configure.in
103}
104
105FILES_${PN} += "${libdir}/gdalplugins"