diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-13 14:26:31 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:22:04 +0200 |
commit | 87259e3768de680a7cb39fc9e0959a4387fb57f2 (patch) | |
tree | e79752c46c5955fd8bab079a44af37cdf3add4c2 | |
parent | ab198bbcfae9239c761e412e800d497bdd8bedf4 (diff) | |
download | meta-openembedded-87259e3768de680a7cb39fc9e0959a4387fb57f2.tar.gz |
strongswan: move systemd support from meta-systemd back to meta-oe
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/strongswan/strongswan_5.0.0.bb | 13 | ||||
-rw-r--r-- | meta-systemd/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bbappend | 10 |
2 files changed, 8 insertions, 15 deletions
diff --git a/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bb b/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bb index efacc8ea4..2713f5b18 100644 --- a/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bb +++ b/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bb | |||
@@ -5,7 +5,7 @@ SECTION = "console/network" | |||
5 | LICENSE = "GPLv2" | 5 | LICENSE = "GPLv2" |
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
7 | DEPENDS = "gmp openssl flex-native flex bison-native" | 7 | DEPENDS = "gmp openssl flex-native flex bison-native" |
8 | PR = "r2" | 8 | PR = "r5" |
9 | 9 | ||
10 | SRC_URI = "http://download.strongswan.org/strongswan-${PV}.tar.bz2" | 10 | SRC_URI = "http://download.strongswan.org/strongswan-${PV}.tar.bz2" |
11 | SRC_URI[md5sum] = "c8b861305def7c0abae04f7bbefec212" | 11 | SRC_URI[md5sum] = "c8b861305def7c0abae04f7bbefec212" |
@@ -15,11 +15,9 @@ EXTRA_OECONF = "--disable-curl --disable-soup --disable-ldap \ | |||
15 | --enable-gmp --disable-mysql --disable-sqlite \ | 15 | --enable-gmp --disable-mysql --disable-sqlite \ |
16 | --enable-openssl" | 16 | --enable-openssl" |
17 | 17 | ||
18 | SYSTEMD_UNITDIR ??= "no" | 18 | EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)}" |
19 | 19 | ||
20 | EXTRA_OECONF += "--with-systemdsystemunitdir=${SYSTEMD_UNITDIR}" | 20 | inherit autotools systemd |
21 | |||
22 | inherit autotools | ||
23 | 21 | ||
24 | RRECOMMENDS_${PN} = "kernel-module-ipsec" | 22 | RRECOMMENDS_${PN} = "kernel-module-ipsec" |
25 | 23 | ||
@@ -31,3 +29,8 @@ FILES_${PN}-dbg += "${libdir}/ipsec/.debug ${libdir}/ipsec/plugins/.debug ${libe | |||
31 | FILES_${PN}-plugins += "${libdir}/ipsec/plugins/*" | 29 | FILES_${PN}-plugins += "${libdir}/ipsec/plugins/*" |
32 | 30 | ||
33 | INSANE_SKIP_${PN}-plugins = "staticdev" | 31 | INSANE_SKIP_${PN}-plugins = "staticdev" |
32 | |||
33 | RPROVIDES_${PN} += "${PN}-systemd" | ||
34 | RREPLACES_${PN} += "${PN}-systemd" | ||
35 | RCONFLICTS_${PN} += "${PN}-systemd" | ||
36 | SYSTEMD_SERVICE_${PN} = "${PN}.service" | ||
diff --git a/meta-systemd/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bbappend b/meta-systemd/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bbappend deleted file mode 100644 index 0a474fe3f..000000000 --- a/meta-systemd/meta-oe/recipes-support/strongswan/strongswan_5.0.0.bbappend +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | inherit systemd | ||
2 | |||
3 | PRINC := "${@int(PRINC) + 2}" | ||
4 | |||
5 | SYSTEMD_UNITDIR = "${systemd_unitdir}/system" | ||
6 | |||
7 | RPROVIDES_${PN} += "${PN}-systemd" | ||
8 | RREPLACES_${PN} += "${PN}-systemd" | ||
9 | RCONFLICTS_${PN} += "${PN}-systemd" | ||
10 | SYSTEMD_SERVICE_${PN} = "${PN}.service" | ||