summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-01-13 21:20:46 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-01-13 21:22:06 +0100
commitfbf853f629b3dcbee4d16669aec727c84903169e (patch)
tree5a1ac9f6521c4cb7466602003773b9b59a1101fa
parentcbe66021c51aceee7c15938b2759efc1a79c654c (diff)
downloadmeta-openembedded-fbf853f629b3dcbee4d16669aec727c84903169e.tar.gz
python-numpy: import from OE
Currently doesn't build Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--recipes-devtools/python/python-numpy/arm/config.h21
-rw-r--r--recipes-devtools/python/python-numpy/arm/numpyconfig.h17
-rw-r--r--recipes-devtools/python/python-numpy/mipsel/config.h21
-rw-r--r--recipes-devtools/python/python-numpy/mipsel/numpyconfig.h17
-rw-r--r--recipes-devtools/python/python-numpy/trycompile.diff33
-rw-r--r--recipes-devtools/python/python-numpy/unbreak-assumptions.diff16
-rw-r--r--recipes-devtools/python/python-numpy_1.4.1.bb26
7 files changed, 151 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-numpy/arm/config.h b/recipes-devtools/python/python-numpy/arm/config.h
new file mode 100644
index 000000000..17ef186d5
--- /dev/null
+++ b/recipes-devtools/python/python-numpy/arm/config.h
@@ -0,0 +1,21 @@
1/* ./src.linux-i686-2.5/numpy/core/include/numpy/config.h */
2/* #define SIZEOF_SHORT 2 */
3/* #define SIZEOF_INT 4 */
4/* #define SIZEOF_LONG 4 */
5/* #define SIZEOF_FLOAT 4 */
6/* #define SIZEOF_DOUBLE 8 */
7#define SIZEOF_LONG_DOUBLE 12
8#define SIZEOF_PY_INTPTR_T 4
9/* #define SIZEOF_LONG_LONG 8 */
10#define SIZEOF_PY_LONG_LONG 8
11/* #define CHAR_BIT 8 */
12#define MATHLIB m
13#define HAVE_FLOAT_FUNCS
14#define HAVE_LOG1P
15#define HAVE_EXPM1
16#define HAVE_INVERSE_HYPERBOLIC
17#define HAVE_INVERSE_HYPERBOLIC_FLOAT
18#define HAVE_ISNAN
19#define HAVE_ISINF
20#define HAVE_RINT
21
diff --git a/recipes-devtools/python/python-numpy/arm/numpyconfig.h b/recipes-devtools/python/python-numpy/arm/numpyconfig.h
new file mode 100644
index 000000000..c4bf6547f
--- /dev/null
+++ b/recipes-devtools/python/python-numpy/arm/numpyconfig.h
@@ -0,0 +1,17 @@
1/* cat ./src.linux-i686-2.5/numpy/core/include/numpy/numpyconfig.h */
2/*
3 * * This file is generated by numpy/core/setup.pyc. DO NOT EDIT
4 * */
5#define NPY_SIZEOF_SHORT 2
6#define NPY_SIZEOF_INT 4
7#define NPY_SIZEOF_LONG 4
8#define NPY_SIZEOF_FLOAT 4
9#define NPY_SIZEOF_DOUBLE 8
10#define NPY_SIZEOF_LONGDOUBLE 12
11#define NPY_SIZEOF_PY_INTPTR_T 4
12#define NPY_NO_SMP 0
13
14#define NPY_SIZEOF_LONGLONG 8
15#define NPY_SIZEOF_PY_LONG_LONG 8
16/* #define CHAR_BIT 8 */
17
diff --git a/recipes-devtools/python/python-numpy/mipsel/config.h b/recipes-devtools/python/python-numpy/mipsel/config.h
new file mode 100644
index 000000000..17ef186d5
--- /dev/null
+++ b/recipes-devtools/python/python-numpy/mipsel/config.h
@@ -0,0 +1,21 @@
1/* ./src.linux-i686-2.5/numpy/core/include/numpy/config.h */
2/* #define SIZEOF_SHORT 2 */
3/* #define SIZEOF_INT 4 */
4/* #define SIZEOF_LONG 4 */
5/* #define SIZEOF_FLOAT 4 */
6/* #define SIZEOF_DOUBLE 8 */
7#define SIZEOF_LONG_DOUBLE 12
8#define SIZEOF_PY_INTPTR_T 4
9/* #define SIZEOF_LONG_LONG 8 */
10#define SIZEOF_PY_LONG_LONG 8
11/* #define CHAR_BIT 8 */
12#define MATHLIB m
13#define HAVE_FLOAT_FUNCS
14#define HAVE_LOG1P
15#define HAVE_EXPM1
16#define HAVE_INVERSE_HYPERBOLIC
17#define HAVE_INVERSE_HYPERBOLIC_FLOAT
18#define HAVE_ISNAN
19#define HAVE_ISINF
20#define HAVE_RINT
21
diff --git a/recipes-devtools/python/python-numpy/mipsel/numpyconfig.h b/recipes-devtools/python/python-numpy/mipsel/numpyconfig.h
new file mode 100644
index 000000000..c4bf6547f
--- /dev/null
+++ b/recipes-devtools/python/python-numpy/mipsel/numpyconfig.h
@@ -0,0 +1,17 @@
1/* cat ./src.linux-i686-2.5/numpy/core/include/numpy/numpyconfig.h */
2/*
3 * * This file is generated by numpy/core/setup.pyc. DO NOT EDIT
4 * */
5#define NPY_SIZEOF_SHORT 2
6#define NPY_SIZEOF_INT 4
7#define NPY_SIZEOF_LONG 4
8#define NPY_SIZEOF_FLOAT 4
9#define NPY_SIZEOF_DOUBLE 8
10#define NPY_SIZEOF_LONGDOUBLE 12
11#define NPY_SIZEOF_PY_INTPTR_T 4
12#define NPY_NO_SMP 0
13
14#define NPY_SIZEOF_LONGLONG 8
15#define NPY_SIZEOF_PY_LONG_LONG 8
16/* #define CHAR_BIT 8 */
17
diff --git a/recipes-devtools/python/python-numpy/trycompile.diff b/recipes-devtools/python/python-numpy/trycompile.diff
new file mode 100644
index 000000000..3ab3d72f2
--- /dev/null
+++ b/recipes-devtools/python/python-numpy/trycompile.diff
@@ -0,0 +1,33 @@
1--- /tmp/setup.py 2008-09-01 10:37:44.000000000 +0200
2+++ numpy-1.1.1/numpy/core/setup.py 2008-09-01 10:38:20.373198000 +0200
3@@ -80,8 +80,7 @@
4 raise SystemError,\
5 "Non-existing %s. Perhaps you need to install"\
6 " python-dev|python-devel." % (python_h)
7- result = config_cmd.try_run(tc,include_dirs=[python_include],
8- library_dirs = default_lib_dirs)
9+ result = config_cmd.try_compile(tc)
10 if not result:
11 raise SystemError,"Failed to test configuration. "\
12 "See previous error messages for more information."
13@@ -95,7 +94,7 @@
14 if mathlib:
15 mathlibs_choices.insert(0,mathlib.split(','))
16 for libs in mathlibs_choices:
17- if config_cmd.try_run(tc,libraries=libs):
18+ if config_cmd.try_compile(tc):
19 mathlibs = libs
20 break
21 else:
22@@ -180,10 +179,7 @@
23 " python-dev|python-devel." % (python_h)
24
25 config.numpy_include_dirs
26- result = config_cmd.try_run(testcode,
27- include_dirs = [python_include] + \
28- config.numpy_include_dirs,
29- library_dirs = default_lib_dirs)
30+ result = config_cmd.try_compile(testcode)
31
32 if not result:
33 raise SystemError,"Failed to generate numpy configuration. "\
diff --git a/recipes-devtools/python/python-numpy/unbreak-assumptions.diff b/recipes-devtools/python/python-numpy/unbreak-assumptions.diff
new file mode 100644
index 000000000..c5b448167
--- /dev/null
+++ b/recipes-devtools/python/python-numpy/unbreak-assumptions.diff
@@ -0,0 +1,16 @@
1--- /tmp/system_info.py 2008-08-22 00:38:16.000000000 +0200
2+++ numpy-1.1.1/numpy/distutils/system_info.py 2008-08-22 00:40:33.013198000 +0200
3@@ -137,11 +137,8 @@
4 default_x11_lib_dirs = []
5 default_x11_include_dirs = []
6 else:
7- default_lib_dirs = ['/usr/local/lib', '/opt/lib', '/usr/lib',
8- '/opt/local/lib', '/sw/lib']
9- default_include_dirs = ['/usr/local/include',
10- '/opt/include', '/usr/include',
11- '/opt/local/include', '/sw/include']
12+ default_lib_dirs = ['/non-existant-dir']
13+ default_include_dirs = ['non-existant-dir']
14 default_src_dirs = ['.','/usr/local/src', '/opt/src','/sw/src']
15
16 try:
diff --git a/recipes-devtools/python/python-numpy_1.4.1.bb b/recipes-devtools/python/python-numpy_1.4.1.bb
new file mode 100644
index 000000000..ed47f47db
--- /dev/null
+++ b/recipes-devtools/python/python-numpy_1.4.1.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "A sophisticated Numeric Processing Package for Python"
2SECTION = "devel/python"
3PRIORITY = "optional"
4LICENSE = "PSF"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3c42211d73c3faa1026e671dd39883fa"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \
8 file://config.h \
9 file://numpyconfig.h \
10 "
11
12S = "${WORKDIR}/numpy-${PV}"
13
14inherit distutils
15
16# Make the build fail and replace *config.h with proper one
17# This is a ugly, ugly hack - Koen
18do_compile_prepend() {
19 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
20 ${STAGING_BINDIR_NATIVE}/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
21 true
22 cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/
23}
24
25SRC_URI[md5sum] = "5c7b5349dc3161763f7f366ceb96516b"
26SRC_URI[sha256sum] = "2e7bb84573e5123e07f3c919fd433bc09b78d606252b6b719e385c2a981d8e06"