summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-02-21 17:59:46 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-02-22 09:42:14 +0100
commitb9fbd254ba2bcf7d350842e8467f50c4016fc5b8 (patch)
treee4794bf85364b992b5e58c6844be314193a7e8fa
parent1e3ebb18e3032a0d90fc78d909d036546bddd889 (diff)
downloadmeta-openembedded-b9fbd254ba2bcf7d350842e8467f50c4016fc5b8.tar.gz
vala: upgrade to newer vala from meta-smartphone/meta-fso layer
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-oe/recipes-devtools/vala/vala-0.14.2/0001-git-version-gen-don-t-append-dirty-if-we-re-not-in-g.patch53
-rw-r--r--meta-oe/recipes-devtools/vala/vala_0.12.1.bb7
-rw-r--r--meta-oe/recipes-devtools/vala/vala_0.14.2.bb14
3 files changed, 67 insertions, 7 deletions
diff --git a/meta-oe/recipes-devtools/vala/vala-0.14.2/0001-git-version-gen-don-t-append-dirty-if-we-re-not-in-g.patch b/meta-oe/recipes-devtools/vala/vala-0.14.2/0001-git-version-gen-don-t-append-dirty-if-we-re-not-in-g.patch
new file mode 100644
index 000000000..e6c7941a7
--- /dev/null
+++ b/meta-oe/recipes-devtools/vala/vala-0.14.2/0001-git-version-gen-don-t-append-dirty-if-we-re-not-in-g.patch
@@ -0,0 +1,53 @@
1From 2460d7b79f7e90dcfeebde5e9c53d9b6798a1f3c Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Tue, 21 Feb 2012 17:12:50 +0100
4Subject: [PATCH] git-version-gen: don't append -dirty if we're not in git
5 repo
6
7* for example if we have some dirty directory and we unpack clean vala tarball in it, then it will append -dirty
8
9Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
10---
11 build-aux/git-version-gen | 25 ++++++++++++++-----------
12 1 files changed, 14 insertions(+), 11 deletions(-)
13
14diff --git a/build-aux/git-version-gen b/build-aux/git-version-gen
15index 0fa6faa..1d1f9d2 100755
16--- a/build-aux/git-version-gen
17+++ b/build-aux/git-version-gen
18@@ -126,18 +126,21 @@ fi
19
20 v=`echo "$v" |sed 's/^v//'`
21
22-# Don't declare a version "dirty" merely because a time stamp has changed.
23-git status > /dev/null 2>&1
24+if test -d .git
25+then
26+ # Don't declare a version "dirty" merely because a time stamp has changed.
27+ git status > /dev/null 2>&1
28
29-dirty=`sh -c 'git diff-index --name-only HEAD' 2>/dev/null` || dirty=
30-case "$dirty" in
31- '') ;;
32- *) # Append the suffix only if there isn't one already.
33- case $v in
34- *-dirty) ;;
35- *) v="$v-dirty" ;;
36- esac ;;
37-esac
38+ dirty=`sh -c 'git diff-index --name-only HEAD' 2>/dev/null` || dirty=
39+ case "$dirty" in
40+ '') ;;
41+ *) # Append the suffix only if there isn't one already.
42+ case $v in
43+ *-dirty) ;;
44+ *) v="$v-dirty" ;;
45+ esac ;;
46+ esac
47+fi
48
49 # Omit the trailing newline, so that m4_esyscmd can use the result directly.
50 echo "$v" | tr -d '\012'
51--
521.7.8.4
53
diff --git a/meta-oe/recipes-devtools/vala/vala_0.12.1.bb b/meta-oe/recipes-devtools/vala/vala_0.12.1.bb
deleted file mode 100644
index 1049ed62f..000000000
--- a/meta-oe/recipes-devtools/vala/vala_0.12.1.bb
+++ /dev/null
@@ -1,7 +0,0 @@
1require vala.inc
2SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/vala/0.12/vala-${PV}.tar.bz2"
3
4FILES_${PN} += "${datadir}/vala-0.12/vapi"
5
6SRC_URI[md5sum] = "bf35262cc611de447147d01cbac33767"
7SRC_URI[sha256sum] = "d9a2be21bb8ab88eab838e7f3a4d0aaa2a1fddf35615dca32bef6a0051f58ea8"
diff --git a/meta-oe/recipes-devtools/vala/vala_0.14.2.bb b/meta-oe/recipes-devtools/vala/vala_0.14.2.bb
new file mode 100644
index 000000000..18e6346e7
--- /dev/null
+++ b/meta-oe/recipes-devtools/vala/vala_0.14.2.bb
@@ -0,0 +1,14 @@
1require recipes-devtools/vala/vala.inc
2
3PR = "r1"
4
5DEPENDS += "gtk+"
6
7SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/vala/0.14/vala-${PV}.tar.xz \
8 file://0001-git-version-gen-don-t-append-dirty-if-we-re-not-in-g.patch \
9"
10
11FILES_${PN} += "${datadir}/vala-0.14/vapi"
12
13SRC_URI[md5sum] = "f05263a56c1e328637e4c97a61befdad"
14SRC_URI[sha256sum] = "807e6978484f66cab3cf4fefd72f37a4293d2831d7a5fd29119bdf9d38a5b3d0"