summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-15 13:19:04 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-15 13:19:04 +0100
commitb2d8d42efd598a522e8c95e09259fcddcdd7a257 (patch)
tree0a58b6fd2b7a0227e2431ba5040ef8c77417d473
parent6032d213fa6599678a4c737bc757785a7c35e382 (diff)
downloadmeta-openembedded-b2d8d42efd598a522e8c95e09259fcddcdd7a257.tar.gz
python-imaging: add 1.1.7
Based on OE classic 1.1.6 recipe Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-oe/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch55
-rw-r--r--meta-oe/recipes-devtools/python/python-imaging_1.1.7.bb36
2 files changed, 91 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch b/meta-oe/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch
new file mode 100644
index 000000000..c6e2ee452
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch
@@ -0,0 +1,55 @@
1From 07d4f095a9e22ae676a8d68073101131e65012dc Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Tue, 15 Nov 2011 13:16:54 +0100
4Subject: [PATCH] python imaging setup.py: force paths for zlib, freetype and jpeg and don't add host paths
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7
8Upstream-Status: Unknown
9---
10 setup.py | 14 +++-----------
11 1 files changed, 3 insertions(+), 11 deletions(-)
12
13diff --git a/setup.py b/setup.py
14index 5d4d53a..b1a22ec 100644
15--- a/setup.py
16+++ b/setup.py
17@@ -34,10 +34,10 @@ def libinclude(root):
18 # TIFF_ROOT = libinclude("/opt/tiff")
19
20 TCL_ROOT = None
21-JPEG_ROOT = None
22-ZLIB_ROOT = None
23+JPEG_ROOT = os.environ['STAGING_LIBDIR']
24+ZLIB_ROOT = os.environ['STAGING_LIBDIR']
25 TIFF_ROOT = None
26-FREETYPE_ROOT = None
27+FREETYPE_ROOT = os.environ['STAGING_LIBDIR'], os.environ['STAGING_INCDIR']
28 LCMS_ROOT = None
29
30 # FIXME: add mechanism to explicitly *disable* the use of a library
31@@ -147,7 +147,6 @@ class pil_build_ext(build_ext):
32 add_directory(library_dirs, "/opt/local/lib")
33 add_directory(include_dirs, "/opt/local/include")
34
35- add_directory(library_dirs, "/usr/local/lib")
36 # FIXME: check /opt/stuff directories here?
37
38 prefix = sysconfig.get_config_var("prefix")
39@@ -207,13 +206,6 @@ class pil_build_ext(build_ext):
40 if os.path.isfile(os.path.join(tcl_dir, "tk.h")):
41 add_directory(include_dirs, tcl_dir)
42
43- # standard locations
44- add_directory(library_dirs, "/usr/local/lib")
45- add_directory(include_dirs, "/usr/local/include")
46-
47- add_directory(library_dirs, "/usr/lib")
48- add_directory(include_dirs, "/usr/include")
49-
50 #
51 # insert new dirs *before* default libs, to avoid conflicts
52 # between Python PYD stub libs and real libraries
53--
541.7.2.5
55
diff --git a/meta-oe/recipes-devtools/python/python-imaging_1.1.7.bb b/meta-oe/recipes-devtools/python/python-imaging_1.1.7.bb
new file mode 100644
index 000000000..851c53fe8
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-imaging_1.1.7.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "Python Imaging Library"
2SECTION = "devel/python"
3
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://README;beginline=92;endline=117;md5=003338c482e1d2eb2e4d862897f3abbf"
6
7DEPENDS = "freetype jpeg tiff"
8SRCNAME = "Imaging"
9
10SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \
11 file://0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch \
12"
13SRC_URI[md5sum] = "fc14a54e1ce02a0225be8854bfba478e"
14SRC_URI[sha256sum] = "895bc7c2498c8e1f9b99938f1a40dc86b3f149741f105cf7c7bd2e0725405211"
15
16S = "${WORKDIR}/${SRCNAME}-${PV}"
17
18inherit distutils
19
20do_compile() {
21 export STAGING_LIBDIR=${STAGING_LIBDIR}
22 export STAGING_INCDIR=${STAGING_INCDIR}
23 distutils_do_compile
24}
25
26do_install() {
27 export STAGING_LIBDIR=${STAGING_LIBDIR}
28 export STAGING_INCDIR=${STAGING_INCDIR}
29 distutils_do_install
30 install -d ${D}${datadir}/doc/${PN}/html/
31 install -m 0644 ${S}/README ${D}${datadir}/doc/${PN}/
32 install -m 0644 ${S}/Docs/* ${D}${datadir}/doc/${PN}/html/
33
34}
35RDEPENDS_${PN} = "python-lang python-stringold"
36