summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2015-02-13 08:49:55 -0800
committerArmin Kuster <akuster808@gmail.com>2015-03-21 07:48:52 -0700
commit9c464502dcf3c12edda16b257ad1e091b7aae690 (patch)
tree723bb6818f5bd6e97a5954ac98d664c865606977
parentd85e6b328e38a8035d05fed600b696f540bcec3e (diff)
downloadmeta-openembedded-9c464502dcf3c12edda16b257ad1e091b7aae690.tar.gz
wireshark: fix pcap-config issue
configure: error: Header file pcap.h not found; if you installed libpcap don't use pcap. Use the internal version. And minor configure cleanups Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-support/wireshark/wireshark_1.12.3.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-networking/recipes-support/wireshark/wireshark_1.12.3.bb b/meta-networking/recipes-support/wireshark/wireshark_1.12.3.bb
index 7604bd7ff..f16d0f68f 100644
--- a/meta-networking/recipes-support/wireshark/wireshark_1.12.3.bb
+++ b/meta-networking/recipes-support/wireshark/wireshark_1.12.3.bb
@@ -4,7 +4,7 @@ SECTION = "network"
4LICENSE = "GPL-2.0" 4LICENSE = "GPL-2.0"
5LIC_FILES_CHKSUM = "file://README.linux;md5=631e077455b7972172eb149195e065b0" 5LIC_FILES_CHKSUM = "file://README.linux;md5=631e077455b7972172eb149195e065b0"
6 6
7DEPENDS = "perl-native libcap libpcap pcre expat glib-2.0 sbc" 7DEPENDS = "perl-native pcre expat glib-2.0 sbc"
8 8
9SRC_URI = " \ 9SRC_URI = " \
10 http://wiresharkdownloads.riverbed.com/wireshark/src/wireshark-${PV}.tar.bz2 \ 10 http://wiresharkdownloads.riverbed.com/wireshark/src/wireshark-${PV}.tar.bz2 \
@@ -23,10 +23,11 @@ ARM_INSTRUCTION_SET = "arm"
23# Works with either gtk+ or gtk3. 23# Works with either gtk+ or gtk3.
24WHICH_GTK = "gtk3" 24WHICH_GTK = "gtk3"
25 25
26PACKAGECONFIG ??= "gnutls gcrypt libnl" 26PACKAGECONFIG ??= "libcap gnutls libnl"
27PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "${WHICH_GTK} graphics", "", d)}" 27PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "${WHICH_GTK} graphics", "", d)}"
28PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}" 28PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}"
29 29
30PACKAGECONFIG[libcap] = "--with-libcap=${STAGING_DIR_HOST}, --with-libcap=no, libcap"
30PACKAGECONFIG[libsmi] = "--with-libsmi=yes, --with-libsmi=no, libsmi" 31PACKAGECONFIG[libsmi] = "--with-libsmi=yes, --with-libsmi=no, libsmi"
31PACKAGECONFIG[libnl] = "--with-libnl=yes, --with-libnl=no, libnl" 32PACKAGECONFIG[libnl] = "--with-libnl=yes, --with-libnl=no, libnl"
32PACKAGECONFIG[portaudio] = "--with-portaudio=yes, --with-portaudio=no, portaudio-v19" 33PACKAGECONFIG[portaudio] = "--with-portaudio=yes, --with-portaudio=no, portaudio-v19"
@@ -45,7 +46,7 @@ PACKAGECONFIG[geoip] = "--with-geoip=yes, --with-geoip=no, geoip"
45PACKAGECONFIG[adns] = "--with-adns=yes, --with-adns=no, adns" 46PACKAGECONFIG[adns] = "--with-adns=yes, --with-adns=no, adns"
46PACKAGECONFIG[c-ares] = "--with-c-ares=yes, --with-c-ares=no, c-ares" 47PACKAGECONFIG[c-ares] = "--with-c-ares=yes, --with-c-ares=no, c-ares"
47 48
48EXTRA_OECONF = "--with-qt=no --enable-usr-local=no --enable-tshark" 49EXTRA_OECONF += "--with-qt=no --enable-usr-local=no --enable-tshark --with-pcap=no --enable-pcap-ng-default"
49 50
50do_configure_prepend() { 51do_configure_prepend() {
51 # force to use fallback 52 # force to use fallback